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1. DESCRICAO DAS IMAGENS

Estdo disponiveis para as aulas praticas deste curso imagens dos satélites CBERS, SPOT,
LANDSAT-5, e IKONOS, conforme descrigao abaixo.

(a) CBERS_Campinas

Imagem multiespectral (bandas 1, 2, 3 e 4 - azul, verde, vermelho e infravermelho) do satélite
Sino-Brasileiro CBERS, drbita/ponto 154/126, sensor CCD, da regido de Campinas, SP, de 27 de
Abril de 2000.

(b) Ikonos_Holambra_MS_Pan

Imagem multiespectral fundida (MS+PAN com as bandas azul, verde e vermelho - 1, 2 e 3 +
Pan), do satélite de alta resolucao Ikonos, da regidao de Holambra, SP, de 12 de Julho de 2000.
(c) Landsat_Campinas

Imagem multiespectral (bandas 1, 2, 3, 4, 5, 6 e 7 - azul, verde, vermelho, NIR, SWIR, Termal e
TIR) do satélite Landsat-5, sensor Thematic Mapper (TM), drbita/ponto 219/076, da regiao de
Campinas, SP, de 19 de Marco de 1999.

(d) Spot_Campinas_XS

Imagem multiespectral (bandas 1, 2 e 3 - verde, vermelho e infravermelho proximo) do satélite
Spot, sensor MS, orbita/ponto 715/396, da regidgo de Campinas, SP, de 18 de Maio de 1988.

2. OBSERVACOES GERAIS SOBRE 0 ENVI

(a) Uso do cursor

O botdo esquerdo seleciona funcoes e define o inicio de agdes interativas. Para desenhar ou
mover objetos, movimente o cursor com o botao esquerdo pressionado. O botao da direita aceita
a Ultima acdo e finaliza tarefas.

(b) Opgao de ajuda

Em caso de divida no uso de alguma fungdo, selecione Help no menu da janela principal e
localize a descricao da funcao desejada.

(c) Entrada e saida de dados

Em todas as janelas do ENVI existe uma opcao File que permite salvar e recuperar as informagoes
relacionadas com a funcao da janela corrente.

3. PRATICA: APRENDENDO A USAR O ENVI.
(a) Carregando uma imagem

Janela Principal => File => Open Image File => Janela Enter Data Filenames => Selecione
Ikonos_Holambra_MS_Pan.img => Abrir => Janela Available Bands List => Selecione RGB



Color => Selecione as bandas R, G, e B => Selecione Load RGB => Janelas Scroll, Image,
Zoom,

Janela Scroll: Apresenta a imagem completa de toda a regidgo e um retangulo referente a
subregido em observacao na janela image. A posicao do retangulo pode ser alterada com o
cursor.

Janela Image: Apresenta a imagem do interior do retangulo de observacdo da janela scroll e um
retangulo referente a subregido em observagao na janela zoom. A posicdo do retangulo pode ser
alterada com o cursor.

Janela Zoom: Apresenta a imagem do interior do retangulo de observagao da janela image. A
posicao do retangulo da janela image (ou seja a regidao apresentada na janela zoom) pode ser
modificada com o cursor na janela zoom.

Observagoes: Os dados sobre a imagem podem ser vistos e editados em Janela Principal =>
File => Edit ENVI Header. Qualquer banda pode ser visualizada isoladamente em um novo display
selecionando-se GRAY e Display #1 => New Display na janela available band list.

(b) Localizando uma regiao de interesse na imagem

Janela Scroll => Movimente o retangulo de observacdo com o cursor até encontrar na janela
image uma plantacao de laranja no formato triangular com o solo exposto no formato trapezoidal
ao lado.

(c) Fazendo anotacgoes

Janela Image => Overlay => Annotation => Janela Annotation => Mude cor do texto para
amarelo e escreva "Plantacao de Laranja". Janela Image => Selecione posi¢ao do texto sobre a
plantacao de laranja. Janela Annotation => Mude objeto para Arrow no menu Object. Janela
Image => Desenhe e selecione posicao da seta sobre a plantagao de laranja. Janela
Annotation => File => Save Annotation => salve em um arquivo holambra.ann no seu diretério
de trabalho. Observe que a opcao Janela Annotation => File => Restore Annotation permite
recuperar as anotagdes posteriormente.

(d) Visualizando a localizagao e os valores dos pixels

Janela Image => Tools => Cursor Location/Value => Janela Cursor Location/Value.
Movimentando o cursor na janela image observa-se na janela cursor location/value a localizacao
em coordenadas de pixel e cartograficas, e os valores das bandas 1, 2 e 3, que no caso sdo
R,G,B, do pixel localizado na posicao do cursor.

Observe que o valor G dos pixels é maior que os valores R e B na vegetagao, R é maior que G e B
no solo exposto e B é maior que R e G na agua das piscinas que aparecem na imagem.

Janela Image => Tools => Pixel Locator => Janela Pixel Locator. Movimentando o cursor na
janela zoom com o botdo esquerdo pressionado observa-se na janela pixel locator a localizagao
em coordenadas de pixel do pixel localizado na posicao do cursor. No menu options de pixel
locator é possivel mudar de coordenadas de pixel para cartograficas.



(e) Obtendo medidas na imagem

Janela Image => Tools => Measurement Tool => Janela Display Measurement Tool .
Escolha opgdes na janela display measurement tool para obter area e perimetro da plantagao de
laranja em m?. Estas medidas s3o obtidas delineando-se com o cursor na janela image o contorno
da plantacao de laranja. Em seguida selecione na janela display measurement tool a janela de
zoom e obtenha usando o cursor na janela image a distancia entre dois pés de laranja.

Exercicio: Recupere sua anotagdo anterior e acrescente a area, o perimetro, a
distancia entre dois pés de laranja e as coordenadas cartograficas dos vértices da
regido que corresponde a plantagdao de laranja. Salve o resultado no mesmo arquivo
holambra.ann.

(f) Isolando regiodes de interesse

Janela Image => Tools => Region of Interest => ROI Tool => Janela ROI Tool. Delineie e
selecione o contorno da plantagao de laranja na janela image com o cursor.

Janela ROI Tool => Edit => troque a cor da regido para verde e o preenchimento de sélido
para linha => New Region.

Delineie e selecione o contorno do terreno exposto na janela image com o cursor, depois troque a
cor para amarelo e o preenchimento sdlido para linha.

Janela ROI Tool => File => Save ROIS => Salve regides de interesse no arquivo holambra.roi.
(g) Calculando estatisticas

Janela ROI Tool => Selecione regiao de interesse => Mean => Janela ROI Means. A janela
ROI means apresenta de forma grafica o valor médio de cada banda na regidao de interesse
selecionada.

Janela ROI Tool => Selecione regiao de interesse => Stats => Janelas Statistics Report e
Average Spectrum. A janela statistics report apresenta os valores minimo, maximo, médio e
desvio padrao de cada banda na regido de interesse selecionada. A mesma informacdo é
apresentada de forma grafica na janela Average Spectrum, onde linhas coloridas representam as
medidas acima mencionadas.

Observacoes: As informacOes estatisticas de todas as regides de interesse podem ser obtidas ao
mesmo tempo no menu options da janela ROI Tool. As informacdes estatisticas de todas as
bandas, sem levar em conta regides de interesse, podem ser obtidas no menu basic tools da
janela principal.

4. PRATICA: REGISTRO E GEOREFERENCIAMENTO.

Este exercicio tem por objetivo fazer o geo-referenciamento de uma imagem cujo sistema interno
de coordenadas encontra-se especificado em termos de “"linhas” (/ines) e “"colunas” (samples), a
fim de que ela possa passar a ter os seus pixels localizados em um sistema de projecao

cartografica (por exemplo, em graus/minutos/segundo).

Para a finalidade deste exercicio, pressupde-se que a imagem disponivel ("Spot_Campinas_XS")
nao seja geo-referenciada e que um conjunto de pontos de controle no terreno (GCPs, ou Ground
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Control Points) encontra-se previamente disponivel. Estes GCPs podem ser obtidos por meio da
identificacdo de pontos comuns entre a imagem e um mapa cartografico, no qual se obteve as
coordenadas exatas de cada um deles no mapa (utilizando, por exemplo, uma mesa digitalizadora
para maior precisao). Outra maneira de se obter esses pontos é através da coleta em campo
utilizando um receptor GPS. Em ambos os casos, o sistema de projecao cartografico, bem como o
datum, a serem atribuidos a imagem apds o processo de geo-referenciamento sera o mesmo do
mapa ou o do receptor GPS. Uma vez geo-referenciada, a imagem pode ser posteriormente
convertida para qualquer outro sistema de projecao e datum, utilizando o software de PDI ou de

SIG.

1.

Inicialize o Envi e abra as imagem "Spot Campinas_ XS’ exibindo-a em uma composicao
RGB das bandas 3, 2 e 1.

No menu principal, clique em Map => Registration => Select GCPs: Image to Map.

Na janela Image to Map Registration selecione a projegao UTM, digite 23 em “Zone” e
cliqgue em “S”. Em seguida, clique em “Datum”e selecione “Cdrrego Alegre”da lista.
Finalmente, estabeleca o tamanho do pixel, tanto em X quanto em Y, em 20 metros ("X
Pixel Size” e Y Pixel Size"). Isto quer dizer que a regido de Campinas encontra-se na zona
23 do hemisfério Sul no sistema UTM, o datum utilizado foi Cérrego Alegre e a imagem
resultante do processo de geo-referenciamento tera resolucao espacial de 20 metros (que
é a resolucdo normal desse sensor). Apds clicar OK aparecera o menu “Ground Control
Points Selection”, que devera ficar aberto durante a etapa de definicdo dos GCPs deste
exercicio.

Utilize a tabela de pontos de controle (GCPs) abaixo para localizar na imagem alguns
pontos cujas coordenadas precisas ja foram previamente obtidas e que serao utilizados no
exercicio.

GCP Image X ImageY E N

1 396 361 282543 7476275
2 287 637 280353 7470762
3 499 944 284610 7464621
4 651 1068 287650 7462135
5 977 850 294157 7466502
6 799 560 290603 7472301
7 1053 314 295677 7477222
8 650 413 287617 7475228

Entre com as coordenadas Image X e Image Y do primeiro GCP da tabela no lado direito
do menu Ground Control Points Selection. Em seguida, entre com as coordenadas E e
Ndo ponto 1 do lado esquerdo do mesmo menu, e finalize clicando no botao Add Point.
Para cada um dos pontos definidos pelas coordenadas de Sample (Coluna) e Line (Linha)
da tabela acima, entre na janela de Ground Control Points Selection com as
respectivas coordenadas de longitude (E) e latitude (N). Faga o mesmo para todos os 8
GCPs.

Observe o Erro Médio Quadratico (RMS Error), que ja é automaticamente calculado pelo
programa conforme os GCPs sao fornecidos e que idealmente devem ficar abaixo do valor
1,0 (pixel). O programa da varias opcoes para cada GPC, tal como edita-lo, remové-lo,
atualiza-lo, etc.

Uma vez satisfeito com o resultado do RMS para o seu conjunto de GCPs, salve-os em um
arquivo por meio de File => Save GCPs w/ Map Coordinates, escolhendo o home de



arquivo “GCPs_Camp_Spot.pts”. Lembre-se de selecionar o mesmo diretdrio onde esta
0 arquivo da imagem.

8. No menu principal, clique em Map => Registration => Warp From GCPs => Image to
Map. O programa solicitara que vocé indique o arquivo contendo os GCPs que acabou de
criar. Feito isto, aparecera novamente a janela Image to Map Registration. Selecione a
projecao UTM, zona 23, datum Cdrrego Alegre, X Pixel Size = 20 e Y Pixel Size = 20,
clicando OK ao final.

9. O programa solicitara entdo que vocé selecione o arquivo contendo a imagem que vai ser
geo-referenciada. Como este arquivo ja esta aberto, selecione-o e clique OK.

10. Na janela Registration Parameters indique somente o nome do arquivo de saida, que
ird entdo conter a imagem geo-referenciada a ser criada. Digite
"Spot_Campinas_XS_Geo”, selecionando o mesmo diretdrio onde esta a imagem
original, e clique OK.

11. Abra o arquivo com a imagem recém-criada e exiba-a numa janela de display. No menu
dessa janela clique em Tools => Cursor Location/Value. Ao passar o cursor pela janela
contendo a imagem recém geo-referenciada vocé ira notar que aparecem as coordenadas
geograficas dos pixels da imagem (tanto em lat/long como também em
grau/minuto/segundo), indicado que ela esta efetivamente geo-referenciada.

5. PRATICA: MANIPULANDO, VISUALIZANDO E INTERPRETANDO IMAGENS.

(a) Gerando e aplicando uma mascara a partir das regioes de interesse

Recarregue a imagem Ikonos de Holambra. Recupere as regides de interesse em holambra.roi
selecionando Janela Image => Overlay => Region of Interest => Janela ROI Tool => File
=> Restore ROIs => Procure, selecione e abra o arquivo holambra.roi.

Para gerar a mascara da plantacao de laranja selecione Janela Principal => Basic Tools =>
Masking => Build Mask => Janela Mask Definition => Selecione Display #1 => Options =>
Import ROIs => Janela Mask Definition Input ROIs => Selecione regido que corresponde a
plantagdo de laranja e pressione ok. Na janela Mask Definition, escolha o diretério de trabalho e
0 nome do arquivo de saida como holambra_mask, e pressione Apply.

Para aplicar a mascara na imagem de Holambra selecione Janela Principal => Basic Tools =>
Masking => Apply Mask => Janela Apply Mask Input File => Selecione a imagem
Ikonos_Holambra_MS_Pan.img => Select Mask Band => Selecione a banda de holambra_mask e
depois pressione ok => Janela Mask Parameters => escolha o diretdrio de trabalho e o nome
do arquivo de saida como holambra_laranjal e pressione OK. Use a janela Available Band List
para carregar e visualizar a imagem holambra_laranjal. Aproveite e recarregue a anotagao em
holambra.ann sobre esta imagem.

(b) Gerando composicoes coloridas
Feche todas as janelas e faca Janela Principal => File => Open Image File => Janela Enter

Data Filenames => Selecione Landsat_Campinas.img => Abrir => Janela Available Band
List => Selecione banda 3 (red) como R, banda 2 (green) como G, e banda 1 (blue) como B =>



Load RGB. Esta é a composicdo em cores naturais da imagem de Campinas. Localize na imagem a
mata de Santa Genebra ao lado de uma plantacdo de cana, o terreno exposto proximo a regiao
do CTI, e a lagoa do taquaral. Centralize o retangulo da janela de scroll para que todas essas
regides figuem na janela image.

Sabemos que a vegetagao absorve 80-90% do vermelho (banda 3) incidente e reflete 40-50% do
infra-vermelho proximo (banda 4). Entdo devemos esperar que na imagem da banda 4 a mata
apareca em tons mais claros do que a plantacao de cana ao seu lado? Para verificar esta pergunta
abra um segundo display gray com a banda 4 (Janela Available Band List => Selecione banda
4 da imagem de Campinas e Gray Scale => Selecione display #1 => New Display => Load Band.
Posicione as janelas image de ambas uma ao lado da outra e faca com que as imagens mostrem a
mesma regiao (Janela Image => Tools => Link => Link Displays => Janela Link Displays
=> Selecione Ok. Observe que o brilho da mata na banda 4 nao estda mais claro que o da
plantacdo de cana. Portanto a resposta a pergunta acima é Nao. Isto porque o que importa é a
diferenca entre a reflectancia na banda 4 e a reflectancia na banda 3. Vegetacao mais sadia
apresenta maiores diferencas. Assim podemos dizer que se dividirmos a banda 4 pela banda 3,
entdo a mata aparecera em tons mais claros do que a plantacao de cana ao lado. Esta forma de
realce é chamada razao de bandas e pode ser obtida de duas formas no ENVI:

(i) Janela Principal => Transform => Band Ratios => Janela Band Ratio Input Bands =>
Selecione banda 4 no numerador e banda 3 no denominador => Selecione Enter Pair e pressione
OK => Janela Band Ratio Parameters => Selecione diretdrio de trabalho e arquivo de saida
como campinas_ratio e pressione OK. Agora troque o display #2 para apresentar a imagem
campinas_ratio de razao de bandas e verifique que a mata estda bem mais clara que a plantacdo
de cana.

(i) Janela Principal => Basic Tools => Band Math => Janela Band Math => Entre com a
expressao float(B4)/float(B3) e pressione ok => Janela Variables to Band Pairings =>
Selecione a varidvel B3 e a banda b3 da Landsat_Campinas, a varidvel B4 e a banda b4 da
Landsat_Campinas, e escolha como saida a memdria s6 para teste. Carregue no display #2 a
imagem gerada na memdria a partir da janela avaliable band list para verificar que o resultado é o
mesmo do procedimento (i).

Observagoes: A opcdao band math pode ser utilizada na operagao aritmética entre bandas todas
as vezes que o ENVI ndo possuir uma opcao direta para o calculo. A razao de bandas pode ser
obtida em qualquer outro sensor que tenha uma banda no infra-vermelho préximo e outra no
vermelho.

Continuando o laboratdrio, podemos esperar que a vegetacdo aparecera avermelhada em
qualquer composicao colorida que associe a banda infra-vermelho proximo (b4 do TM) a
componente R (red) do RGB. A mais comum no TM associa a banda b4 ao R, abandab3 ao Ge a
banda b2 ao B. Visualize esta composicao da imagem Landsat_Campinas no display #2 junto com
a composicao natural no display #1. Observe que a vegetacao fica avermelhada, o terreno
exposto fica esverdeado e a agua da lagoa do taquaral fica azul escura.

Visualize outras composicOes coloridas, tais como TM b7=R, b4=G, e b2=B onde as regioes
Umidas aparecem mais escuras, a vegetacao aparece verde, e é possivel distinguir regides mais
Umidas das menos Umidas na vegetacdo. Compare a umidade da mata de Santa Genebra com a
da plantacao de cana ao lado.

(c) Calculando indices



Os indices podem ser usados no estudo de solos, na avaliacdo da vegetacdo, em aplicacdes
agricolas, e como atributos para classificacao. O indice NDVI (normalized density vegetation
index) explora a razdo de bandas infra-vermelho préximo e vermelho dos sensores para medir a
quantidade e as condigbes da vegetacdo em uma dada regido. Sua férmula geral é:

IR-R
IR+R

NDVI =

onde IR é a banda infra-vermelho préximo e R é a banda do vermelho. No caso do TM temos as
bandas b4 e b3 como IR e R, respectivamente. No ENVI podemos calcular a imagem GRAY do
NDVI por operacdes matematicas ou diretamente em Janela Principal => Transform => NDVI
(Vegetation Index) => Janela NDVI Calculation Input File => Selecione a imagem
Landsat_Campinas, pressione OK, e salve o arquivo como campinas_ndvi no diretério de trabalho.
Agora carregue a imagem campinas_ndvi e use a opgao Janela Image => Tools => Pixel
Location/Value para verificar os valores NDVI sobre a mata de Santa Genebra e a plantagao de
cana. Observe que quanto melhor for a salde da vegetacao, mais claro serao os pixels na
imagem NDVL.

O indice Tasseled Cap desenvolvido por Kauth e Thomas em 1976 produz ao mesmo tempo varias
informagdes importantes sobre uma regiao (e.g. sua concentragao de clorofila - verde, seu brilho
e a umidade). Para cada sensor existe uma férmula diferente que pode ser calculada através de
operacdes matematicas ou diretamente em Janela Principal => Transform => Tasseled Cap
=> Janela Tasseled Cap Transform Input File. Selecione a imagem Landsat_Campinas e
salve a saida como campinas_tcap no seu diretdrio de trabalho. Em seguida visualize cada banda
de campinas_tcap em um display separado. Observe que na banda Greenness a vegetagao mais
verde aparece mais clara e na banda Third (associada a umidade) a agua da lagoa do taquaral
fica complemente branca. Os valores reais desses indices podem ser vistos em Janela Image
=> Tools => Pixel Location/Value.

(d) Espacos de cores

Espacos de cores podem ser usados para realce de imagens e para extracao de atributos para
classificacao. Os espacos HSV e HLS expressam as trés componentes principais da cor: matiz,
saturagao e brilho. Considere inicialmente a composigao R=TM3, G=TM2, e B=TM1 da imagem
Landsat_Campinas no display #1. Para visualizar esta imagem HSV faca: Janela Principal =>
Transform => Color Transforms => RGB to HSV => Janela RGB to HSV Input => Selecione
display #1 => Janela RGB to HSV Parameters => Escolha o diretdrio de trabalho para salvar
0 arquivo de saida como campinas_hsv e pressione OK. Em seguida abra cada uma das imagens
matiz, saturacao e brilho em um novo display. O caminho inverso de HSV para RGB pode ser
realizado de forma similar.

Um experimento interessante é modificar a composicdo de cores da imagem Landsat_Campinas
para R=TM4, G=TM3, B=TM2 e converter para HSV. A principio ndo existe nenhum significado
fisico para esta transformacao, uma vez que TM 4,3,2 nao correspondem ao RGB da luz visivel,
mas podemos observar que apds a transformacao a mata de Santa Genebra e a agua da lagoa do
taquaral ficam com brilhos homogéneos e bem caracterizados na imagem de saturacao. Podemos
inclusive distinguir a vegetacao e a agua na lagoa do taquaral. Essas diferencas podem ser ainda
mais realgadas com o uso de mapa de cores.

Um mapa de cor associa uma cor R, G, B para cada valor de brilho de uma imagem cinza.
Experimente, por exemplo, selecionar na imagem de saturacdao Janela Image => Tools =>
Color Mapping => ENVI Color Tables => Janela ENVI Color Tables => Selecione mapa
BLUE/GREEN/RED/YELLOW. Outro exemplo interessante € a visualizacdo da banda termal do TM,
onde regides mais claras indicam maior temperatura. Visualize esta imagem usando os tons
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avermelhados do mapa de cores RED TEMPERATURE e observe que a mata de Santa Genebra e a
lagoa do taquaral aparecem escuras por serem regides mais frias, e o solo exposto e a cidade
aparecem mais claros devido a maior dissipacao de calor.

Outra forma de usar mapa de cores € na operacao de fatiamento de niveis de cinza (density
slicing). Nesta operagao podemos associar uma cor distinta para certos intervalos de cinza. Por
exemplo, carregue a banda b7 do TM da imagem de Campinas. Selecione Janela Image =>
Tools => Color Mapping => Density Slice => Janela Density Slice => Use o botao Delete
Range para remover todos os intervalos deixando apenas trés => Use o botdo Edit Range para
modificar a cor e o intervalo desejado na janela Edit Density Slice Range. Sabemos que na banda
b7 do TM, a agua tem reflectancia proxima de zero, a vegetacao tem reflectancia um pouco maior
gue a agua e o solo exposto tem reflectancia maior que a vegetacdo. Poderiamos calcular o valor
médio e o desvio padrao nessas regides e usar esses valores para definir cada intervalo. Em vez
disso vamos definir a cor cyan no intervalo de 0 a 7 para representar a agua, a cor verde no
intervalo de 9 a 15 para representar a vegetacao e a cor marrom no intervalo de 40 a 51 para
representar o solo exposto. Selecione Apply para visualizar o resultado desta operacao. Observe
as regioes correspondentes a mata de Santa Genebra e a plantagdo de cana, a lagoa do taquaral
e ao solo exposto.

Exercicio: Através de operacoes matematicas, converta aimagem TM b3 =R, b2 = G,
e bl = B de Campinas de RGB para o espaco IHS de Pratt. Esta transformacao segue a
seguinte receita:

_R+G+B V:R+G+ZB R+2G

|l=———— 1 V, =
56— 6
3 S=4V,2+V,’ V6
H :tan‘l%ﬁ
1

ondeS=>0,V<l,e0<H<2n.

Observacgao: A transformacao inversa é dada por:
V, = Scos (H) V, = Ssin (H)

R=121-49V, -245V, G =-6l+245V, +2.45V, B =3l +2.45V,

6. PRATICA: REALCE DE IMAGENS

(a) Aplicando transformacgoes radiométricas

No final do laboratdrio 4 vimos uma forma simples de realce usando mapa de cores para distinguir
melhor as mudangas de contraste em uma imagem cinza. Na verdade, os valores originais dos
pixels nas imagens de sensoriamento remoto normalmente apresentam baixo contraste e o que
vemos na tela é resultado de uma transformacao radiométrica. Carregue, por exemplo, a imagem
SPOT_Campinas_XS.img. Para melhorar o contraste da imagem selecione Janela Image =>
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Enhance => Linear 2%. Observe que a imagem do SPOT combina infra-vermelho préximo em R,
com vermelho em G, e azul em B. Isto é equivalente a TM b4=R, b3=G, b2=B. Experimente
outras transformacgOes radiométricas nesta opcdao. Para entender como funcionam essas
transformacoes, selecione Janela Image => Enhance => Interactive Stretching => Janela
Interactive Stretching. Esta janela mostra o histograma original e o transformado para as
opcoes anteriores e permite ainda a modificacao interativa do histograma. Para modificar o
histograma de qualquer banda interativamente, selecione a banda e use o cursor para
movimentar as barras verticais no grafico do histograma original. No menu da janela interactive
stretching é possivel modificar o tipo de stretching e salvar o mapeamento em uma look-up table.

(b) Realce por decorrelacao

Um dos aspectos importantes no realce de imagens coloridas é a descorrelagao entre as bandas.
Quando a composicao envolve bandas correlacionadas, a alteracao do contraste de uma banda
independente do contraste da outra afeta a matiz das cores originais. Tomemos o exemplo de
uma composicao TM b3=R, b2=G, e b1=B da imagem Landsat_Campinas. Experimente equalizar
a imagem selecionando Janela Image => Enhance => Image Equalization.

Equalize esta imagem sem alterar as matizes originais, convertendo de RGB para HSV,
equalizando S e/ou V, e depois voltando para RGB. Verifique que o mesmo é valido para outros
tipos de realce.

(c) Realce por casamento de histogramas

Algumas situagoes, tais como registro de duas imagens, requerem que os histogramas estejam
casados. Isto significa que uma das imagens deve sofrer uma transformacao radiométrica tal que
o histograma da imagem transformada seja o mais préximo possivel do histograma da outra
imagem. Quando as imagens sao coloridas, o casamento ocorre entre as respectivas imagens de
brilho.

Selecione, por exemplo, a composicao TM b3=R,b2=G,b1=B da imagem Landsat_Campinas no
display #1 e a mesma composicao da imagem CBERS_Campinas no display #2. Na janela image
da segunda, selecione Enhance => Histogram Matching => display #1.

Exercicio: Faga o casamento de histogramas entre as imagens CEBERS e Landsat de
Campinas convertendo ambas de RGB para HSV, fazendo o casamento entre as
respectivas bandas de brilho e voltando a imagem do CEBERS para RGB. Compare seu
resultado com aquele obtido pela opcao Janela Image => Enhance => Histogram
Matching.

7. PRATICA: FILTRAGEM DE IMAGENS

Filtros podem ser usados para realce de imagens, reducao de ruido, e extracdo de atributos para
classificacdo. Neste laboratdrio vamos exercitar varias classes de filtros. Selecione Janela
Principal => Filters => Convolutions ou Morphology => Janela Convolutions and
Morphology Tools. Nesta janela é possivel definir os valores e as dimensdes das mascaras de
convolugao ou operagao morfoldgica. Também é possivel combinar através de média ponderada,
o resultado da filtragem com a imagem original. A opcao Quick Apply aplica o filtro sobre uma
dada banda enquanto a opgao Apply to File aplica sobre todas as bandas da imagem. Inicialmente
experimente alguns filtros ja definidos nas opgdes convolution e morphology. Alguns desses filtros
também podem ser aplicados a partir da opgao enhance da janela image.
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(a) Realce de bordas (Edge enhancement)

Os filtros de Sobel, de Robert, e os Laplacianos realcam as bordas da imagem em detrimento das
regides homogéneas. No menu da janela convolutions and morphology, as opcdes Sobel e Robert
calculam a magnitude do vetor gradiente cujas componentes sao representadas pelos resultados
da filtragem de Sobel nas direcoes 0° e 90° e Robert nas diregdes 45° e -45°. Defina e aplique as
mascaras direcionais dos filtros de Sobel a imagem CBERS_Campinas. O resultado dessas
mascaras isoladamente embossa as bordas. Depois use as operacoes aritméticas para combina-las
na imagem de magnitude de gradiente. Compare seu resultado com a opgao correspondente ja
definida no menu. Repita o exercicio para outros filtros direcionais de realce de bordas dados na
aula tedrica e para os filtros Laplacianos.

A combinacao ponderada entre filtros de realce de bordas e a imagem original pode ser usada
para reduzir efeitos de borramento na imagem original. Comparando lado a lado a imagem
CBERS_Campinas com a imagem SPOT_Campinas_XS, que tem a mesma resolugao espacial, ou
mesmo com a imagem Landsat_Campinas que tem uma resolugao espacial um pouco menor,
podemos verificar que a imagem do CEBERS esta borrada. Para melhorar sua qualidade, tente
adicionar 70% da imagem original nas operacdes de realce de bordas. Outra opcao é aumentar o
valor do pixel central nas mascaras de Laplacianos. Teste esta alternativa e compare os
resultados.

(b) Suavizacao (Smoothing)

Filtros Gaussianos e média sao utilizados para tornar mais homogéneas regides de interesse na
imagem. Eles podem ser usados como pré-processamento antes da extracdao de atributos para
classificacao dessas regides. Em contrapartida, esses filtros borram as bordas da imagem. Uma
opcao interessante é aplicar um filtro de suavizacao e depois um filtro sharpen. Experimente esta
opcao na imagem Landsat_Campinas (use composicao b3=R,b2=G,b1=B) via Janela Image =>
Enhance => Filters. Para verificar que as regides de interesse ficaram mais homogéneas (i.e. o
desvio padrao ficou menor), selecione uma regiao de interesse sobre a mata de Santa Genebra e
compare os resultados estatisticos antes e depois dos filtros. Verifigue que as curvas de desvio
padrao ao longo das bandas ficam mais préximas no segundo caso.

(c) Mediana

Filtros de mediana sdo normalmente usados para remover ruido do tipo speckle (comum em
imagens de radar), mas também podem auxiliar na deteccdo de caracteristicas pontuais nas
imagens. Um bom exemplo s3o os pés de laranja na imagem holambra_laranjal que geramos no
primeiro laboratdrio. Para estimar o nimero de pés de laranja, nds poderiamos usar as
informacOes de area e distancia entre os pés, mas uma forma mais precisa seria detectar os pés
de laranja como componentes conexas e contar o nimero de componentes. A primeira etapa
pode ser feita com o seguinte procedimento. Converta a imagem holambra_laranjal de RGB para
HSV. Selecione a banda S, onde os pés aparecem como pontos brancos na imagem. Aplique um
filtro mediana com janela de tamanho 7x7 pixels sobre a banda S e subtraia o resultado da
filtragem da prdpria banda S para eliminar ruido de fundo. Em seguida aplique sobre a imagem
da subtracao a opcao de fatiamento de niveis para selecionar uma Unica regidgo branca com
valores minimo 0.1 e maximo 1.0. Observe que os pés ficam pintados de branco e o resto da
imagem fica preto.

(d) Morfolagicos
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No resultado acima, cada pé de laranja deveria ser representado por uma Unica componente
conexa branca, mas se observarmos com cuidado vamos ver que alguns pés correspondem a
duas ou mais componentes proximas. A operacao de fechamento morfoldgico pode ser usada
para unir as componentes proximas. Na janela convolutions and morphology existem opgdes para
dilatacdo, erosao, fechamento e abertura morfoldgicos. Essas operacdes podem ser aplicadas em
imagens cinzas e bindrias, como foi visto na aula tedrica. Verifique os resultados dessas operacoes
na imagem de brilho V do HSV da plantacao de laranja.

Exercicio: Calcule o gradiente morfolégico na banda V do espago HSV para a imagem
CBERS_Campinas e depois combine cada banda da imagem original com a imagem de
gradiente para realcar o contraste da imagem original. Lembre-se que o gradiente
morfoldgico pode ser definido pela subtracdo da imagem dilatada pela erodida.
Compare seu resultado com os resultados dos filtros sharpen do menu Enhance =>
Filters da janela image.

8. PRATICA: ESPACO DE ATRIBUTOS

a) Abra a imagem Landsat_Campinas

b) Selecione uma composicao RGB com as bandas 4, 5 e 2

¢) Na janela da imagem va em Tools -> 2-D Scatter Plots e faga um scattergrama das
bandas 4 e 2; na janela do scattergrama, va em Options e selecione Density Slice para
ver as concentracoes dentro do conjunto de pixels em cores;

d) Desenhe poligonos em diferentes regides do conjunto de pixels (mantenha pressionado
o botdo da esquerda do mouse ao desenhar o poligono e clique no botdo da direita
para fecha-lo) e observe na imagem onde estdo localizados esses pixels. Para
representar cada poligono numa cor diferente, va em Class -> Itens 1:20 e mude a cor
a cada novo poligono. Para apagar todos os poligonos, va em Options e selecione Clear
All.

e) Mantendo o botdo esquerdo do mouse pressionado, percorra diferentes areas da
imagem e observe no scattergrama onde os pixels correspondentes estao localizados;
isto € chamado de Dancing Pixels.

f) Para fazer o contrario (desenhar poligonos na imagem e observar onde os pixels se
localizam no scattergrama), va em Options e selecione Image:ROL.

g) Repita essa mesma operagao para outros conjuntos de duas bandas (por ex., bandas 1
e 5, bandas 3 e 4, etc.). Para isso, va em Options -> Change Bands e selecione as
bandas desejadas.

h) Varias janelas de Scatter Plot podem ser abertas simultaneamente, se necessario.

9. PRATICA: REGIOES DE INTERESSE PARA CLASSIFICAGAO

Regides de interesse (ROIs) sao porcdes de uma imagem que podem ser selecionadas
interativamente ou por meio do estabecimento de limiares de DNs. As ROIs podem ter qualquer
formato, sendo normalmente definidas por poligonos irregulares, e sao utilizadas para extrair
parametros estatisticos para operacao de classificacdo e para aplicagdo de mascaras. O ENVI
permite a selecdo de uma combinagao de poligonos, pontos ou vetores para definir ROIs. Uma ou
mais ROIs podem ser definidas e desenhadas na janela de Imagem Principal, na janela de Scroll
ou na janela de Zoom. ROIs podem ainda ser expandidas para pixels adjacentes, limitadas por
limiares.
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Para fins de classificagao de imagens, as ROIs sdo utilizadas para definir as Areas de
Treinamento, a partir das quais serao coletados os parametros estatisticos para uso na
classificagao. Podem ser usadas diversas Areas de Treinamento para definir as classes, sendo o
conjunto entao denominado Conjunto de Treinamento.

Utilizando a imagem Landsat_Campinas e faca uma composicao colorida das bandas 453 em
RGB. Vamos estabelecer algumas areas de treinamento por meio de ROIs, para posterior uso no
exercicio de classificagao.

a) A partir do menu principal do Envi, selecione Basic Tools -> Regions of Interest -> ROI

b)

Na janela ROI Tool, selecione a opcdo Zoom para poder definir os poligonos da ROI com
maior precisao na imagem ampliada da janela de zoom. Recomenda-se aumentar o
tamanho da janela de zoom, para ter uma area maior de visao da imagem. (Obs.:
quando a funcao de definicao de ROI esta ativada, acoes como zoom,
movimentagao sobre a imagem, etc. sdo desativadas; para ativa-las e ao
mesmo tempo manter a definicao de ROIs, acione a opcdo "Off” na janela de
"ROI Tool”)

Com o curso do mouse na janela de zoom ampliada, desenhe o poligono que representa
a regiao de interesse selecionada:

a. A primeira ROI vai definir uma area de treinamento pertencente a categoria

“Mata Atlantica” (vegetacao florestal original da regiao de Campinas, hoje
reduzida a poucos fragmentos). Para isso, usaremos a area da Mata de Santa
Genebra (em cor vermelho vivo na composicao RGB 453, situada no centro do
quadrante superior esquerdo da cena Landsat). Desenhe o poligono clicando no
botdo esquerdo do mouse para definir os vértices e no botao direito (2 vezes)
para fecha-lo. Se cometer algum erro na definicao da ROI, selecione “Delete” e
desenhe novamente o poligono. (Obs.: a opcdo "Erase”da janela "ROI Tool”
apenas apaga a ROI da tela, mas a mantém no sistema). Usando a opao
“Edit”, mude o nome da area de treinamento para “Mata”. Em seguida ao nome
da ROI, aparece o nimero de pixels que compdem cada area de treinamento.
A segunda ROI vai definir uma area de treinamento referente a cultura de cana.
Para desenha-la, selecione “New Region” e desenhe um novo poligono na area
imediatamente a sul da Mata de Santa Genebra, ocupada por cana na época da
aquisicdo da imagem (cor vermelho claro na composicao 453). Nomeie esta area
de treinamento como “Cana”.

Usando a janela principal da imagem, mova 0 zoom um pouco mais para sudeste
da area anterior (area vermelho escuro na composicdo 453) e selecione em
seguida uma area plantada com eucalipto. Nomeie esta area de treinamento
como “Eucalipto”.

Em seguida, use a area urbana ao lado do eucalipto para definir uma nova area
de treinamento (cor azul claro a cinza), a ser nomeada de “Urbano 1”.

Em seguida, mova o zoom para a area central de Campinas (area de cor cinza
escura/azulada no centro da mancha urbana) e defina a area de treinamento
“Urbano 2".

Mova a janela de zoom para a area da Lagoa do Taquaral (¢ recomendavel
aumentar o zoom em algumas vezes) e selecione a area de treinamento “Agua”
usando os pixels da Lagoa (de cor escura na composicao 453).

Mova o zoom para a regido superior direita da imagem e selecione uma area de
solo exposto (cor cyan/azul claro), denominando a area de treinamento “Solo1”.
Em seguida, mova o zoom para uma area de outro tipo de solo exposto situada
no canto inferior esquerdo da imagem (cor verde), homeando-a de “Solo2".
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/. Finalmente, mova o zoom para uma area de pastagem situada imediatamente a
nordeste da Mata de Santa Genebra (cor vermelho/alaranjado na composicao
453), nomeando-a de “Pasto”.

d) A opcdo de “Stats” da janela “ROI Tool” permite o calculo dos parametros estatisticos

para cada area de treinamento em todas as bandas do Landsat, mostrando o espectro
médio de todos os pixels, os valores minimo e maximo e o desvio-padrdo. A opc¢ao
“Mean” mostra apenas o espectro médio de todos os pixels em cada area de
treinamento. Selecione algumas areas de treinamento que foram definidas e examine
esses parametros para cada uma delas.

O préximo passo € salvar as 9 areas de treinamento definidas por meio das respectivas
ROIs. Para isso, na janela “ROI Tools” va em “File” e clique em “Save ROIs". Ao abrir a
janela de “Save ROIs to File” clique em “Select All Items” e em seguida em “Choose”
para abrir um diretdrio. Use o diretdrio do curso, onde esta a imagem original, e dé o
nome de “camp_rois.roi’ para o arquivo.

10. PRATICA: CLASSIFICACAO SUPERVISIONADA

Vamos em seguida utilizar as areas de treinamento que acabamos de definir para classificar toda
a cena Landsat de Campinas utilizando diferentes técnicas de classificagdo supervisionada.

Método do Paralelepipedo

a)
b)

9)

h)

No menu principal, va em “Classification => Endmember Collection” e selecione a
imagem a ser classificada, dando um “Ok” em seguida.

Na janela “Endmember Collection” que ira se abrir selecione “Import -> from ROI from
Input File”. Na janela “Input Regions of Interest” que ira se abrir, clique em “Select All
Items” e “Ok”. Todas as areas de treinamento definidas irdo aparecer na janela
“Endmember Collection”.

Selecione “Options” e “Plot Endmembers” para visualizar o espectro médio de todas as
areas de treinamento nas 7 bandas do Landsat TM (clicando o botdo da direita do
mouse dentro da janela “Endmember Spectra” selecione Plot Key e ira aparecer uma
legenda com o nome da area de treinamento e respectiva cor da curva no grafico).

Na janela “Endmember Collection” selecione “Algorithm” para definir qual a técnica de
classificacdo a ser utilizada. Inicialmente, selecione o método do Paralelepipedo,
seguido de “Apply”.

A janela “Parallelepiped Parameters” ira se abrir; digite “20” no parametro “Pipe Half
Width DN” (esse valor representa a dimensado do paralelepipedo em DNs), entre com o
nome da imagem de classificacao a ser criada em “Enter Output Class Filename” (use
“camp_class_paralel” no diretério do curso) e selecione “No” na opgao “Output Rule
Filename?”.

A imagem de classificacdo ira aparecer no topo da lista de imagens disponiveis
(“Available Bands List”). Selecione-a, clique na opgao “Gray Scale” e escolha “New
Display” para abrir uma nova janela de imagem (mantenha a janela com a composi¢ao
colorida RGB 453 para comparagao com a imagem de classificacao).

Clique em “Load Band” para abrir a imagem de classificagao na nova janela de
imagem. Repare que, apesar de voce ter selecionado uma imagem preto e branco
("Gray Scale”), a imagem de classificacao vem em cores, pois o sistema a reconhece
automaticamente. As cores que voce Vvé nessa imagem sao as mesmas cores das areas
de treinamento selecionadas (mata em vermelho, cana em verde, etc.). Uma
caracteristica deste classificador é que dificilmente ele consegue classificar todos os
pixels de uma imagem, deixando muitos deles como “nao classificados”
(“unclassified”), que estdo representados na cor preta.

Para inserir uma legenda na imagem de classificacao, siga os seguintes passos:
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i)

a. Na janela da imagem classificada, clique em “Overlay -> Annotation”; na janela
“Annotation Text” clique em “Object -> Map Key".

b. Clique o botao esquerdo do mouse no local da imagem classificada onde quer
colocar a legenda; vocé pode arrasta-la para qualquer parte da imagem que
desejar. A cor do fundo da legenda pode ser mudada em “Back -> Itens 1:20 -
> Black”. O nome de cada classe também pode ser editado, assim como o
tamanho e a cor da fonte, etc.

Compare os resultados obtidos na imagem classificada e na imagem colorida RGB 453.
Note, por exemplo, que o classificador paralelepipedo ndo foi capaz de separar a Mata
de Santa Genebra da plantagao de cana que fica logo abaixo, ainda que diferentes
areas de treinamento tenham sido usadas para definir ambas como sendo diferentes.
Procure outros possiveis érros comparando as duas imagens (classificacao e
composicao colorida 453).

Método da Distancia Minima

a)
b)

0)

d)

No menu principal, va em “Classification” e selecione “Endmember Collection”.

Repita os passos ja explicados anteriormente até a selecdo do “Algorithm” de distancia
minima na janela “Endmember Collection”.

A janela “Minimum Distance Parameters” ira se abrir; o parametro “Max Distance Error
(DN)” pode ser deixado em branco, e neste caso todos os pixels da imagem serao
atribuidos a uma das classes, ou entdo pode-se estabelecer o valor maximo da
distancia em DNs, que representa um limiar para limitar o nimero de pixels atribuido a
cada classe com base na distancia; experimente fazer a classificacao deixando esse
parametro em branco e depois repetindo a classificagdo com esse parametro igual a 35
— compare os resultados.

Entre com o nome da imagem de classificacao a ser criada em “Enter Output Class
Filename” (use “camp_class_min_dist” para a primeira e
“camp_class_min_dist_35"para a segunda, salvando ambas no diretdrio do curso);
selecione “No” na opcao “Output Rule Filename?”. Em seguida clique “Ok".

Repita os demais passos ja vistos na classificacdo pelo método do paralelepipedo para
visualizar e comparar as imagens de classificacdo com a composicao colorida 453 e
também com a imagem de classificacdo pelo método do paralelepipedo.

Método da Distancia de Mahalanobis

a)
b)

9

d)

No menu principal, va em “Classification” e selecione “Supervised -> Mahalanobis
Distance”.

Na janela "Classification Input File” selecione a imagem Landsat_Campinas. e de um
“Ok".

A janela “Mahalanobis Distance Parameters” ira se abrir; o parametro “Max Distance
Error (DN)” pode ser deixado em branco (todos os pixels da imagem serdo atribuidos a
uma das classes); em seguida clique no botao “Select All Items” para selecionar as
areas de treinamento,

Entre com o nome da imagem de classificacao a ser criada em “Enter Output Class
Filename” (use “camp_class_mahalanobis”, e salve no diretorio do curso);
selecione “No” na opgao “Output Rule Filename?” e clique “Ok".

Repita os demais passos ja vistos na classificacdo pelos dois métodos anteriores para
visualizar e comparar as imagens de classificacdo com a composicao colorida 453 e
também com as outras duas imagens de classificacdo dos métodos anteriores.

Método da Maxima Verossimilhanca

a)

No menu principal, va em “Classification” e selecione “Supervised -> Maximum
Likelihood”.
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b) Na janela "Classification Input File” selecione a imagem Landsat_Campinas. e de um
“Ok".

c) A janela “Maximum Likelihood Parameters” ira se abrir; o parametro “Probability
Threshold” é opcional e define o nivel de probabilidade no qual pixels sao considerados
corretamente classificados (deixe-o em branco, o que equivale a 1.0); em seguida
clique no botdo “Select All Items” para selecionar as areas de treinamento,

d) Entre com o nome da imagem de classificacao a ser criada em “Enter Output Class
Filename” (use “camp_class _max_like”, e salve no diretdrio do curso); selecione
“"No” na opgao “Output Rule Filename?” e clique “Ok”".

e) Repita os demais passos ja vistos na classificacdo pelos trés métodos anteriores para
visualizar e comparar as imagens de classificacao com a composicao colorida 453 e
também com as outras trés imagens de classificagao dos métodos anteriores.

Comparando a Imagem Original com a Classificada

a) No menu da janela da composicao colorida 453, va em “Overlay -> Classification”.

b) A janela “Interactive Class Tool” permite que vocé faca a superposicao de uma ou mais
classes sobre a composicao colorida; selecionando cada uma das classes vocé podera
analisar a sua localizagao e distribuicao na imagem.

¢) Na funcao “Options” dessa mesma janela vocé pode analisar a distribuicdo em area das
classes (“Class distribution™), editar e modificar as cores e os nomes das classes (“Edit
class/color names”) ou mesmo fundir duas classes em uma so (“Merge classes”).

11. PRATICA: CLASSIFICACAO NAO-SUPERVISIONADA

As técnicas de classificagao ndo supervisionadas sao utilizadas para agrupar os pixels de uma
imagem em classes, com base apenas na estatistica da prdpria imagem, sem o uso de areas de
treinamento definidas pelo usuario. Dois algoritmos de agrupamento (*clustering”) sao
comumente utilizados para isso: K-medias e Isodata.

Classificacdo Nao-Supervisionada Usando o K-Médias

a) No menu principal, va em “Classification -> Unsupervised -> K-Means”

b) Selecione a imagem Landsat_Campinas.

¢) Clique “Ok” para abrir a janela “K-Means Parameters”.

d) O numero de classes estabelece quantas classes devem ser definidas pelo processo de
agrupamento; selecione 9 classes.

e) O valor do limiar (“threshold”) é usado para terminar o processo de iteragdes, quando
0 numero de pixels atribuido a cada classe muda num valor menor do que o do desse
limiar. O processo de classificacdo ira terminar ou quando esse valor for alcancado no
processo iterativo, ou entdo quando o nimero maximo de iteracdes for atingido; entre
com um valor de 5% para o limiar.

f) O ndmero de iteracoes define o valor maximo a ser utilizado para separar as classes;
entre com o nimero de 10 iteragoes;

g) Os parametros “Max Stdev From Mean” e “Maximum Distance Error” sao opcionais e
alternativos um ao outro; podem ser deixados em brancos, o que faz com que todos os
pixels da imagem sejam classificados.

h) Entre com o nome da imagem de classificacao a ser criada em “Enter Output Class
Filename” (use “camp_class_kmedias”, e salve no diretdrio do curso).

Classificagao Nao-Supervisionada Usando o Isodata
a) No menu principal, va em “Classification -> Unsupervised -> Isodata”
b) Selecione a imagem Landsat_Campinas.
¢) Clique “Ok” para abrir a janela “Isodata Parameters”.
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d) O numero de classes pode ser fixado entre um minimo e um maximo; isto se deve a
que o algoritmo Isodata divide e funde as classes durante o processo de iteragdes com
base no valor de limiar e ndo mantém um ndmero fixo de classes; selecione um
minimo de 6 e um maximo de 9 classes.

e) O numero de iteracdes define o valor maximo a ser utilizado para separar as classes;
entre com o nimero de 10 iteragdes;

f) O valor do limiar (“threshold”) é usado para terminar o processo de iteracoes, quando
0 numero de pixels atribuido a cada classe muda num valor menor do que o do desse
limiar. O processo de classificacdo ira terminar ou quando esse valor for alcancado no
processo iterativo, ou entdo quando o nimero maximo de iteracdes for atingido; entre
com um valor de 5% para o limiar.

g) O numero minimo de pixels em uma classe define qual o menor tamanho aceitavel
para que o agrupamento seja considerado uma classe; entre com um valor de 100.

h) O “Maximum Class Stdev” (em DNs) é um critério usado para dividir uma classe em
duas outras; se o desvio-padrao de uma classe for maior do que o valor do limiar,
entdo a classe é dividida em duas; entre com um valor de 1.

i) O “Minimum Class Distance” (em DNs) define o critério de distancia entre as médias
das classes, a partir do qual duas ou mais classes serao fundidas em uma so; entre
com o valor 5.

j) O “Maximum # Merge Pairs” define o nUmero maximo de pares de classes a serem
fundidas; entre com o valor de 2;

k) Os parametros “Max Stdev From Mean” e “Maximum Distance Error” s3o opcionais e
alternativos um ao outro; podem ser deixados em brancos, o que faz com que todos os
pixels da imagem sejam classificados.

I) Entre com o nome da imagem de classificacao a ser criada em “Enter Output Class
Filename” (use “camp_class_isodata”, e salve no diretdrio do curso).

Faca uma comparacao entre as imagens classificadas pelos dois métodos nao-supervisionados e
também com os resultados da classificacao supervisionada. Procure notar onde estdo as
similaridades e as diferencas nos resultados obtidos pelos diferentes métodos.

12. PRATICA: FUNCOES POS-CLASSIFICACAO

As imagens de classificacdo requerem uma etapa final de analise para avaliar a acuracia do
processo. O Envi possui uma série de funcles de pds-classificacdo para esse fim.

Estatisticas das Classes
Esta funcao permite a extracao de dados estatisticos da imagem usada para gerar a imagem
classificada e da prdpria imagem classificada. Esses dados sao calculados para cada classe e
consistem de: valores minimo e maximo, média, desvio-padrao, autovalores, histogramas e
espectro médio.
a) No menu principal, va em “Classification -> Post Classification -> Class Statistics”.
b) Na janela “Classification Input File” selecione o arquivo contendo a imagem classificada
(voce pode usar qualquer das imagens de classificacao que foram produzidas, como
por exemplo camp_class_max_like).
¢) Na janela “Statistics Input File” selecione em seguida o arquivo contendo a imagem
Landsat de Campinas (Landsat_Campinas).
d) Na janela “Class Selection” selecione uma das classes.
e) Na janela “Compute Statistics Parameters” selecione todos os parametros estatisticos
disponiveis e clique “Ok”".
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Matriz de Confusao

Esta funcao permite a comparacdo estatistica entre duas imagens classificadas (considerando-se
uma delas como a imagem de classificacdo e a outra como a imagem de “verdade terrestre”), ou
entao entre uma imagem classificada e as ROIs utilizadas no processo. A imagem de “verdade
terrestre” (“ground truth”) pode ser outra imagem classificada (considerada, neste caso, como
sendo 100% correta), ou criada a partir de medidas de verdade terrestre feitas em campo.

a)
b)

c)
d)

9)

Abra as imagens Landsat_Campinas e camp_class_max_like.

Carregue composicao colorida 453 em uma janela de imagem e va em “Overlay ->
Region of Interest”. Na janela “ROI Tool” que ira se abrir, va em “File -> Restore ROI”
e selecione o arquivo de ROIs salvo no inicio desta aula (Tépico 2e): camp_rois.roi.
No menu principal, va em “Classification -> Post Classification -> Confusion Matrix ->
Using Ground Truth ROIs”.

Na janela “Match Classes Parameters”, clique na classe que deseja comparar em
“Matched Classes”, selecione essa classe ho campo “Select Ground Truth ROI” e
também no campo “Select Classification Image”, clicando em “Ok” ao final e
confirmando com outro “Ok” na janela de “Confusion Matrix Parameters”

Analise a Matriz de Confusdo buscando os possiveis érros de omissao e de comissao
(pixels que pertenciam a uma das ROIs e que foram classificados como outra classe).
O parametro “Overall Accuracy” é obtido dividindo-se o nimero de pixels corretamente
classificados pelo nimero total de pixels. No caso deste exercicio que acabamos de
fazer, um pixel é considerado como corretamente classificado se ele estiver dentro da
respectiva ROI.

O parametro “Kappa Coefficient” é outra medida da acuracia da classificacdo e é obtido
pela multiplicacao do nimero total de pixels em todas as classes (V) pela soma da
diagonal da matriz de confusao (), subtraindo a soma dos pixels de verdade
terrestre em uma classe vezes a soma dos pixels classificados naquela classe somada
sobre todas as classes (x¢:Xsx), € dividindo pelo quadrado do nimero total de pixels
menos a soma dos pixels de verdade terrestre naquela classe vezes a soma dos pixels
classificados naquela classe somada sobre todas as classes:

Homogeneizagao de Classes

O resultado do processo de classificacao geralmente produz uma imagem em que areas sao
majoritariamente associadas a diferentes classes, mas que também apresentam um ndmero de
pixels atribuidos a diferentes classes que ocorrem de forma isolada, espalhados pela imagem.
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Esses pixels possuem a aparéncia de “ruido” em uma imagem de classificacao, dificultando a
generalizacao das classes e a producao de mapas tematicos. As fungdes de “Clump” e “Sieve”
permitem fazer essa generalizagao e sao usadas de forma complementar (“sieve” remove os
pixels isolados e “clump” adiciona consisténcia espacial aos pixels modificados).
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a) No menu principal, va em “Classification -> Post Classification -> Sieve Classes”,
selecione uma das imagens de classificacao produzidas e define um nome de arquivo
de saida: camp_class_sieve.

b) Em seguida, use esse mesmo arquivo camp_class_sieve como a entrada para a
operacao de “clump”, criando o arquivo camp_class_clump.

c¢) Compare a imagem classificada original que vocé utilizou com a imagem produzida
pelas operagdes complementares de “sieve” e “clump”. Utilize a janela de zoom para
comparar em detalhes.

Combinacao de Classes
Essa funcao é utilizada quando se quer combinar duas ou mais classes em uma s6, como
alternativa para generalizagado do resultado de classificacao

Edicao das Cores das Classes
As cores das classes de uma imagem de classificacao podem ser mudadas pelo processo de
edicao:
a) Abra uma imagem de classificacdo qualquer; no menu da janela da imagem va em
“Tools -> Color Mapping -> Class Color Mapping”.
b) Selecione a classe cuja cor deseja editar e mude a cor deslizando as barras no sistema
RGB, HLS ou HSV, ou entao clicando no botao “V” e selecionando a cor pelo nome. Os
pixels pertencentes a classe sendo editada mudardo interativamente na imagem de
classificacao, permitindo que se faga uma combinacao apropriada das cores.
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