N

MICROCHIP

M
SIMULATO
USE

PLAB® IDE
R, EDITOR

R'SGUIDE

© 2002 Microchip Technology Inc.



Note the following details of the code protection feature on PICmicro® MCUs.

The PICmicro family meets the specifications contained in the Microchip Data Sheet.

Microchip believes that its family of PICmicro microcontrollers is one of the most secure products of its kind on the market today,
when used in the intended manner and under normal conditions.

There are dishonest and possibly illegal methods used to breach the code protection feature. All of these methods, to our knowl-
edge, require using the PICmicro microcontroller in a manner outside the operating specifications contained in the data sheet.
The person doing so may be engaged in theft of intellectual property.

Microchip is willing to work with the customer who is concerned about the integrity of their code.

Neither Microchip nor any other semiconductor manufacturer can guarantee the security of their code. Code protection does not
mean that we are guaranteeing the product as “unbreakable”.

Code protection is constantly evolving. We at Microchip are committed to continuously improving the code protection features of

our product.

If you have any further questions about this matter, please contact the local sales office nearest to you.

Information contained in this publication regarding device
applications and the like is intended through suggestion only
and may be superseded by updates. It is your responsibility to
ensure that your application meets with your specifications.
No representation or warranty is given and no liability is
assumed by Microchip Technology Incorporated with respect
to the accuracy or use of such information, or infringement of
patents or other intellectual property rights arising from such
use or otherwise. Use of Microchip’s products as critical com-
ponents in life support systems is not authorized except with
express written approval by Microchip. No licenses are con-
veyed, implicitly or otherwise, under any intellectual property
rights.

DNV Certification, Inc. DNV MSC

ANSI+-RAB
Qms

*

7

DINW

>
~
~
=
m
o
-
m
o

1SO 9001 / QS-9000
REGISTERED FIRM

The Netherlands
Accredited by the RvA

Trademarks

The Microchip name and logo, the Microchip logo, KEELOQ,
MPLAB, PIC, PICmicro, PICSTART and PRO MATE are
registered trademarks of Microchip Technology Incorporated
in the U.S.A. and other countries.

FilterLab, microlD, MXDEV, MXLAB, PICMASTER, SEEVAL
and The Embedded Control Solutions Company are
registered trademarks of Microchip Technology Incorporated
in the U.S.A.

dsPIC, dsPICDEM.net, ECONOMONITOR, FanSense,
FlexROM, fuzzyLAB, In-Circuit Serial Programming, ICSP,
ICEPIC, microPort, Migratable Memory, MPASM, MPLIB,
MPLINK, MPSIM, PICC, PICDEM, PICDEM.net, rfPIC, Select
Mode and Total Endurance are trademarks of Microchip
Technology Incorporated in the U.S.A. and other countries.

Serialized Quick Turn Programming (SQTP) is a service mark
of Microchip Technology Incorporated in the U.S.A.

All other trademarks mentioned herein are property of their
respective companies.

© 2002, Microchip Technology Incorporated. Printed in the
U.S.A,, All Rights Reserved.

f‘} Printed on recycled paper.

Microchip received QS-9000 quality system
certification for its worldwide headquarters,
design and wafer fabrication facilities in
Chandler and Tempe, Arizona in July 1999
and Mountain View, California in March 2002.
The Company’s quality system processes and
procedures are QS-9000 compliant for its
PICmicro® 8-bit MCUs, KEELOQ® code hopping
devices, Serial EEPROMSs, microperipherals,
non-volatile memory and analog products. In
addition, Microchip’s quality system for the
design and manufacture of development
systems is ISO 9001 certified.

DS51025E - page ii

© 2002 Microchip Technology Inc.



MICROCHIP MPLAB® IDE USER’S GUIDE

Table of Contents

Preface
INEFOAUCTION .t e e e 1
HIGhIIGNTS .. 1
ADOUL ThiS GUITE ... ee e e eeeeeeas 1
Warranty Registration ..o 3
Recommended Reading ........cccuuuiiimiiiiiiiiieeeeeeee e 4
The Microchip Internet Web Site ..., 5
Development Systems Customer Notification Service ...........cccccuvviineene. 6
(G101 (o]0 =T GRS U] o] o Jo ] i AR EPPPPPPRRPPPRP 8

© 2001 Microchip Technology Inc. DS51025E-page iii



MPLAB® IDE User’s Guide

Chapter 1.

Chapter 2.

Chapter 3.

Part 1 - Getting Started with MPLAB IDE

MPLAB IDE Preview
1.1 INtrOdUCTION . 9
1.2 HIighlIghts ... 9
1.3 Whatis MPLAB IDE ..o 9
1.4  How MPLAB IDE Helps YOU ....ccooiiiiiieieieee e 9
1.5 MPLAB IDE — An Integrated Development Environment (IDE) ..... 10
1.6 MPLAB IDE Development TOOIS ..........iiiiiiiiiiiiiiiiiiieieceen 11

MPLAB IDE Installation
2.1 INtrodUCTION . 13
2.2 HIighlightS ....oeoieieii e 13
2.3 Host Computer System Requirements .........cccccooeeeeiiiicciiiiiienne. 13
2.4  Obtaining the Program Files ... 13
2.5 Installing MPLAB IDE ... 14
2.6 Uninstalling MPLAB IDE ... 16

Getting Started with MPLAB IDE - A Tutorial
3.1 INtrodUCTION e 17
3.2 HighlightS ....oeeiiieii e 17
3.3  Setting up the Development Mode .........ccooeeeeiiiiiiiiciiiiceeee, 18
3.4  Creating a Simple New Project .........cccccoiiiiiiiiieeee e 19
3.5 Creating a Simple New Source File .......cccccooiiiiiiiiiie 25
3.6  Entering Source Code ..........cceeeeiiiiiiiiiiiiieeeee e 26
3.7  Assembling the Source File ..o 27
3.8  RUuNnNNiNg YOUr Program ..o e ee e 28
3.9 Opening Other Windows for Debugging ..........ccccceiiiiiiiineiennee. 29
3.10 Using a Watch WINdOW ..........oouiiiiiiiiiiiiiii e 29
3.11 Setting a Break Point ............oooiiiiii e 32
B.12  SUMMANY ot 32

DS51025E-page iv

© 2001 Microchip Technology Inc.



Table of Contents

Chapter 4. Projects Tutorial

41
4.2
4.3
4.4
4.5

4.6

4.7

INErOAUCHION ... 35
HIGhlIGNS ... 35
Overview Of Projects .......oocuueeiiiiiiiiiieeieeeeee e 35
Making a Project with One MPASM™ Assembler Source File ...... 38
Compiling a Single MPASM Assembler Source File

Without Creating @ Project ...........ooocvieeiiiiiiiiieecc e 45
Making a Project with Multi%a MPASM Assembler

Source Files using MPLINK ™ Linker 49
Making a Project with Other TOOIS ........ooccuiiiiiiiii e 58

Part 2 - Using MPLAB IDE

Chapter 1. MPLAB Editor

1.1 INTrOAUCTION .o 59
1.2 HIghlights .o 59
1.3  What is the MPLAB EditOr .......ccooiiiiiiieieeeeeeie e, 59
1.4  How MPLAB Editor Helps YOU ......coooiiiiiiiie e 60
1.5 MPLAB Editor Features ... 60
1.6  MPLAB Editor FUNCLIONS ......coooiiiiieiee e, 61
Chapter 2. Debugging and MPLAB SIM Simulator
2.1 INTrOAUCTION .o 65
2.2 HIghlights ..o 65
2.3 MPLAB IDE Debugging Functions ............ccccoiiiiiiiiiiiiiiieeeeeee 65
2.4 Real-Time Program EXeCUtION .........cccoviiiiiiiiiiiiiiiiiieeeeeee 66
2.5 MPLAB SIM Simulator Environment ..............ooiiiiiiiiiiieeeeeeee, 67
2.6 Simulator Considerations .........cccccoeeeiiiiiiiiiiiiee e 68
2.7 Breakand Trace POINtS .......cccooviiiiiiiiiiii e 69
2.8 Conditional Break Dialog ........cccoooiiiiiiiiiiiiiiiieeeeee e 75
2.9  StMUIUS FUNCLIONS ...ooeieieiieiccie e 76

© 2001 Microchip Technology Inc. DS51025E-page v



MPLAB® IDE User’s Guide

Chapter 1.

Chapter 2.

2.10 12-Bit Core Device Simulator ISSUES .......cccceeeeeeeiiiiieiiiiiiiieiieiii, 86
2.11 14-Bit Core Device Simulator ISSUES .......ccccceeveeeiiiiieiiiiiiiiiiieiii, 88
2.12 16-Bit Core Device Simulator ISSUES .......cccceeeeeeeiiiiiiiiiiiiiiiiieiii, 93
2.13 Enhanced 16-Bit Core Device Simulator Issues ..........ccccceeuennnnee. 97
Part 3 - MPLAB IDE Reference
MPLAB IDE Toolbar and Menu Options
1.1 INTrOAUCTION e e 101
1.2 HIghIIGhTS oo 101
1.3  MPLAB IDE DESKIOP ..uuiiiieiiieeeeieeeeeeeetree e 102
1.4 File MENU ... 104
1.5 ProjeCt MeNU ........ooooiiiiiiiiee e 117
1.6 EAiEMENU ..o 118
1.7 Debug MENU ..o 129
1.8 Programmer MENU .........oooo oo 149
1.9 OPtONS MENU ..ooeiiiiiiiiiieee et 152
1.10  TOOIS MENU ..o 185
1,11 WINAOW MENU ..oeeeee e 187
1,12 HeIP MENU .. 216
MPLAB IDE Toolbar and Status Bar Definitions
2.1 MPLAB IDE Toolbars .......ccoooiiiiiiiie e 219
2.2 MPLAB IDE Status Bar ........cccoeevviieiieieccee e 222

DS51025E-page vi

© 2001 Microchip Technology Inc.



Table of Contents

Appendix A. MPLAB IDE Key Mapping Functions

Al INtrOdUCTION ... 225
A2 MPLAB IDE Key Mapping FUNCLIONS ........coovviiiiiiiiiiiieeeieeeeeeeee, 225
Appendix B. MPLAB Editor Default Key Commands
B.1  INtrodUCHION .....eeeii e 233
B.2  HIghlightS ... 233
B.3  FUNCHON KEYS ..ot 233
B.4  Movement KeYS ... 235
B.5  CONrOl KEYS ....ueiiiiiiiiiieeieeeee e 237
B.6  Formatting and Editing Keys ... 238
Appendix C. File Extensions Used by MPLAB IDE
GIOSSANY ...ttt sttt b et ne e en s 241
INEFOAUCTION ... e e e e e e ennnes 241
HIGhIGNTS . e e 241
=1 00 T TP UPPPUPPPPPPRTRPPPO 241
INA@X ..ttt ne e e e 259

© 2001 Microchip Technology Inc. DS51025E-page vii



MPLAB® IDE User’s Guide

DS51025E-page viii © 2001 Microchip Technology Inc.



MICROCHIP MPLAB® IDE USER’S GUIDE

Preface

Introduction

This first chapter contains general information that will be useful to know
before running MPLAB IDE.

Highlights
The information you will garner from this chapter:
* About This Guide
* Warranty Registration
* Recommended Reading
¢ The Microchip Internet Web Site
¢ Development Systems Customer Notification Service
» Customer Support

About This Guide

Document Layout

This document describes how to use MPLAB IDE. The manual layout is as
follows:

¢ Part 1, Chapter 1: MPLAB IDE Preview — An overview of what MPLAB
IDE is and how it works.

¢ Part 1, Chapter 2: MPLAB IDE Installation — How to install MPLAB
IDE on your computer.

e Part 1, Chapter 3: Getting Started with MPLAB IDE — A Tutorial —
How to begin using MPLAB IDE.

e Part 1, Chapter 4: MPLAB IDE Projects Tutorial — A tutorial on how
to use MPLAB IDE projects.

e Part 2, Chapter 1: MPLAB Editor — A discussion of the basic MPLAB
Editor functions and features.

e Part 2, Chapter 2: Debugging and MPLAB SIM Simulator — A dis-
cussion of MPLAB IDE debugging functions and related MPLAB SIM
simulator considerations.

¢ Part 3, Chapter 1: MPLAB IDE Menu and Toolbar Options — A
description of the options available via the MPLAB IDE menus and tool-
bars. This chapter includes all menu options associated with the
MPLAB Editor.

© 2001 Microchip Technology Inc. DS51025E-page 1
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¢ Part 3, Chapter 2: MPLAB IDE Toolbar and Status Bar Definitions —

Identifies each MPLAB IDE Toolbar button and its function, and dis-
cusses how to interpret the information displayed on the MPLAB IDE
Status Bar.

¢ Appendix A: MPLAB IDE Key Mapping Functions — Lists the avail-

able MPLAB IDE key mapping functions.

* Appendix B: MPLAB Editor Default Key Commands — Describes the

default key commands specific to the MPLAB Editor and lists the equiv-
alent menu command (if any).

* Appendix C: File Extensions Used by MPLAB IDE — Lists the types

of files that MPLAB IDE uses and identifies each file type’s default

extension.

* Glossary — A glossary of terms used in this guide.

¢ Index — Cross-reference listing of terms, features and sections of this

document.

* Worldwide Sales and Service — A listing of Microchip sales and ser-
vice locations and telephone numbers worldwide.

Conventions Used in this Guide

This manual uses the following documentation conventions:
Table: Documentation Conventions

Description

Represents

Examples

Code (Courier font):

Plain characters

Sample code
Filenames and paths

#define START
c:\autoexec.bat

Angle brackets:
< >

Variables

<label>, <exp>

Square brackets [ ]

Optional arguments

MPASMWIN
[main.asm]

Curly brackets and
pipe character: { | }

Choice of mutually exclusive
arguments
An OR selection

errorlevel {01}

n is a hexadecimal digit

Lower case Type of data “filename”
characters in
quotes
Ellipses... Used to imply (but not show) list
additional text thatis notrele- | [*1ist option...
vant to the example , “list option”]
Oxnnn A hexadecimal number where | OxFFFF, 0x007A

DS51025E-page 2
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Documentation Updates

Table: Documentation Conventions (Continued)

Description

Represents

Examples

ltalic characters

A variable argument; it can be
either a type of data (in lower
case characters) or a specific
example (in uppercase
characters).

char isascii
(char, ch);

Interface (Helvetica font):

Underlined, italic
text with right arrow

A menu selection from the
menu bar

File > Save

Bold characters

A window or dialog button to
click

OK, Cancel

Characters in angle
brackets < >

A key on the keyboard

<Tab>, <Ctrl-C>

Documents (Helvetica font):

ltalic characters

Referenced books

MPLAB IDE User’s
Guide

All documentation becomes dated, and this user’s guide is no exception.
Since MPLAB IDE and other Microchip tools are constantly evolving to meet
customer needs, some MPLAB IDE dialogs and/or tool descriptions may differ
from those in this document. Please refer to our web site at
http://www.microchip.com to obtain the latest documentation available.

Warranty Registration

Please complete the enclosed Warranty Registration Card and mail it
promptly. Sending in your Warranty Registration Card entitles you to receive
new product updates. Interim software releases are available at the Microchip

web site.

© 2001 Microchip Technology Inc.
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Recommended Reading

This user’s guide describes how to use MPLAB IDE. The user may also find
the data sheets for specific microcontroller devices informative in developing
firmware.

README.LAB

For the latest information on using MPLAB IDE, read the README.LAB file
(an ASCII text file) on the MPLAB IDE CD-ROM. README.LAB contains
update information that may not be included in the MPLAB IDE User’s Guide.

README.XXX

For the latest information on using other tools, refer to an information file
about the product that is more current than the printed manual. Check the
MPLAB IDE folder for other README files. (In the case of MPASM
assembler, for instance, the file is called README.ASM.)

Microchip Technology Library CD-ROM (DS00161)

This CD-ROM contains comprehensive application notes, data sheets, and
technical briefs for all of Microchip products. To obtain this CD-ROM, contact
the nearest Microchip Sales and Service location (see back page).

Embedded Control Handbook Vol.1 & 2 and the Embedded Control
Update 2000 (DS00092, DS00167, and DS00711)

These handbooks contain a wealth of information about microcontroller
applications. To obtain these documents, contact the nearest Microchip Sales
and Service location (see back page).

The application notes described in these manuals are also obtainable from
Microchip Sales and Service locations or from the Microchip web site
(http://www.microchip.com).

Microsoft Windows® Manuals

This manual assumes that users are familiar with the Microsoft Windows
operating system. Many excellent references exist for this software, and
should be consulted for general operation of Windows.

DS51025E-page 4
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The Microchip

Internet Web Site

Microchip provides on-line support on the Microchip World Wide Web (WWW)
site.

The web site is used by Microchip as a means to make files and information
easily available to customers. To view the site, the user must have access to
the Internet and a web browser, such as Netscape® Communicator or
Microsoft® Internet Explorer®. Files are also available for FTP download from
our FTP site.

Connecting to the Microchip Internet Web Site

The Microchip web site is available by using your favorite Internet browser
to connect to:

www.microchip.com
The file transfer site is available by using an FTP service to connect to:
ftp://ftp.microchip.com

The web site and file transfer site provide a variety of services. Users may
download files for the latest Development Tools, Data Sheets, Application
Notes, User’s Guides, Articles, and Sample Programs. A variety of Microchip
specific business information is also available, including listings of Microchip
sales offices, distributors and factory representatives. Other data available for
consideration includes:

¢ Latest Microchip Press Releases

¢ Technical Support Section with Frequently Asked Questions
¢ Design Tips

* Device Errata

¢ Job Postings

* Microchip Consultant Program Member Listing

¢ Links to other useful web sites related to Microchip Products

¢ Web conferences for products, Development Systems, and technical
information

e Listing of seminars and events

© 2001 Microchip Technology Inc.
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Development Systems Customer Notification Service

Microchip provides a customer notification service to help our customers keep
current on Microchip products with the least amount of effort. Once you
subscribe, you will receive e-mail notification whenever we change, update,
revise or have errata related to that product family or development tool you
have selected.

Click on the Customer Change Notification link on the Microchip web site at
www.microchip.com. From there you may register and select the product
groups and product categories about which you want to receive notifications.

The Development Systems product categories are:
e Compilers

e Emulators

In Circuit Debuggers
MPLAB

* Programmers

You may return to this location on the web site at any time to change your
selected product categories or your profile information. You may also review
product change notification documents for all categories that have been
posted.

Compilers

The latest information on Microchip C compilers, Linkers and Assemblers.
These include the MPLAB C17 and MPLAB C18 C Compilers, MPLINK™
Linker, MPASM™ Assembler as well as the Librarian, MPLIB™ for MPLINK
Linker.

Emulators
The latest information on Microchip emulators. These include the MPLAB ICE
2000 in-circuit emulator and PICMASTER® emulator.

In-Circuit Debuggers

The latest information on Microchip in-circuit debuggers, such as the MPLAB
ICD.

DS51025E-page 6 © 2001 Microchip Technology Inc.
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MPLAB

The latest information on MPLAB IDE, the Windows Integrated Development
Environment for development systems tools. This list is focused on MPLAB
IDE, MPLAB SIM Simulator, MPLAB IDE Project Manager and general editing
and debugging features. For specific information on MPLAB IDE compilers,
linkers and assemblers, subscribe to the COMPILERS list. For specific
information on MPLAB IDE emulators, subscribe to the EMULATORS list. For
specific information on MPLAB IDE device programmers, please subscribe to
the PROGRAMMERS list.

Programmers

The latest information on Microchip PICmicro® microcontroller (MCU) device
programmers. These include PRO MATE® Il and PICSTART® Plus.

© 2001 Microchip Technology Inc. DS51025E-page 7
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Customer Support

Users of Microchip products can receive assistance through several
channels:

¢ Distributor or Representative

¢ Local Sales Office

* Field Application Engineer (FAE)

» Corporate Applications Engineer (CAE)
e Hotline

Customers should call their distributor, representative, or field application
engineer (FAE) for support. Local sales offices are also available to help
customers. See the back cover for a listing of sales offices and locations.

Corporate applications engineers (CAEs) may be contacted at
(480) 792-7627.

In addition, there is a Systems Information and Upgrade Line. This line
provides system users a listing of the latest versions of all of Microchip's
development systems software products. Plus, this line provides information
on how customers can receive any currently available upgrade kits.

The Hotline Numbers are:
1-800-755-2345 for U.S. and most of Canada, and
1-480-792-7302 for the rest of the world.

DS51025E-page 8
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Chapter 1. MPLAB IDE Preview

1.1

1.2

1.3

1.4

Introduction

This chapter will give an overview of MPLAB IDE.

Highlights

In this chapter, we discuss:
* What is MPLAB IDE
e How MPLAB IDE Helps You

* MPLAB IDE — An Integrated Development Environment (IDE)
e MPLAB IDE Development Tools

What is MPLAB IDE

MPLAB IDE is a Windows®-based Integrated Development Environment
(IDE) for the Microchip Technology Incorporated PICmicro® microcontroller
(MCU) families. MPLAB IDE allows you to write, debug, and optimize
PICmicro MCU applications for firmware product designs. MPLAB IDE
includes a text editor, simulator, and project manager. MPLAB IDE also
supports the MPLAB ICE 2000 emulator, MPLAB ICD debugger, PICSTART®
Plus and PRO MATE® || programmers, and other Microchip or third party
development system tools.

How MPLAB IDE Helps You

The organization of MPLAB IDE tools by function makes pull-down menus
and customizable quick keys easy to find and use. MPLAB IDE tools allow
you to:

Assemble, compile, and link source code

Debug the executable logic by watching program flow with the simula-
tor, or in real-time with the MPLAB ICE 2000 emulator or MPLAB ICD
debugger

Make timing measurements

View variables in watch windows

Program firmware with PICSTART Plus or PRO MATE Il programmers
Find quick answers to questions from the MPLAB IDE on-line Help

and much more.

© 2001 Microchip Technology Inc.
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1.5 MPLAB IDE - An Integrated Development
Environment (IDE)

MPLAB IDE is an easy-to-learn and use Integrated Development
Environment (IDE). The IDE provides firmware development engineers the
flexibility to develop and debug firmware for Microchip’s PICmicro MCU
families. MPLAB IDE runs under Microsoft Windows 3.1x and higher.

MPLAB IDE provides functions that allow you to:
* Create and edit source files
¢ Group files into projects
e Debug source code
* Debug executable logic using the simulator or emulator(s)

MPLAB IDE allows you to create and edit source code by providing you with a
full-featured text editor.

Further, you can easily debug source code with the aid of a Build Results
window that displays the errors found by the compiler, assembler, and linker
when generating executable files.

A Project Manager allows you to group source files, precompiled object files,
libraries, and linker script files into a project format.

MPLAB IDE also provides feature-rich simulator and emulator environments
to debug the logic of executables. Some of the features are:

* A variety of windows allowing you to view the contents of all data and
program memory locations

* Source Code, Program Memory, and Absolute Listing windows allowing
you to view the source code and its assembly-level equivalent
separately and together (Absolute Listing)

* The ability to step through execution, or apply Break, Trace, Standard,
or Complex Trigger Points

DS51025E-page 10
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1.6 MPLAB IDE Development Tools

MPLAB IDE integrates several tools to provide a complete development
environment.

* MPLAB Project Manager

Use the Project Manager to create a project and work with the specific
files related to the project. When using a project, you can rebuild source
code and download it to the simulator or emulator with a single mouse
click.

* MPLAB Editor

Use the MPLAB Editor to create and edit text files such as source files,
code, and linker script files.

e MPLAB ICD In-Circuit Debugger

The MPLAB ICD In-Circuit Debugger is a powerful, low-cost develop-
ment and evaluation kit for many PICmicro MCU FLASH devices.

e MPLAB SIM Simulator

The software simulator models the instruction execution and I/O of the
PICmicro MCUs.

e MPLAB ICE 2000 In-Circuit Emulator

The MPLAB ICE 2000 emulator uses hardware to provide real-time
emulation of PICmicro MCUs, either with or without a target system.

e MPASM™ Assembler/MPLINK™ Linker/MPLIB™ Librarian

The MPASM assembler allows source code to be assembled without
leaving MPLAB IDE. The MPLINK linker creates the final application by
linking relocatable modules from MPASM, MPLAB C17 and MPLAB C18
C Compilers. The MPLIB librarian manages custom libraries for maxi-
mum code reuse.

e MPLAB CXX C Compilers

The MPLAB C17 and MPLAB C18 C Compilers provide ANSI-based
high level source code solutions. Complex projects can use a combina-
tion of C and assembly source files to obtain the maximum benefits of
speed and maintainability.

* PRO MATE® Il and PICSTART® Plus Programmers

Develop code with the simulator or an emulator, assemble or compile it,
then use one of these tools to program devices. This can all be accom-
plished with MPLAB IDE. Although the PRO MATE Il programmer does
not require MPLAB IDE to operate, programming is easier using MPLAB
IDE.

 PICMASTER® and PICMASTER CE Emulators

MPLAB IDE provides legacy support for the PICMASTER and PICMAS-
TER CE emulators.
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¢ Third Party Tools

Many other companies have development tools for Microchip products
that work with MPLAB IDE. Consult the Microchip Third Party Guide
(DS00104).

DS51025E-page 12 © 2001 Microchip Technology Inc.



MICROCHIP MPLAB® IDE USER’S GUIDE
Chapter 2. MPLAB IDE Installation

2.1 Introduction

This chapter describes the procedure for installing MPLAB IDE.

2.2 Highlights

The items discussed in this chapter include:

=
5
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m

¢ Host Computer System Requirements
* Obtaining the Program Files

¢ Installing MPLAB IDE

¢ Uninstalling MPLAB IDE

2.3 Host Computer System Requirements

The following minimum configuration is required to run MPLAB IDE:
 PC-compatible Pentium™-class system
¢ Microsoft Windows 3.1x or higher
¢ 16 MB memory (32 MB recommended)
¢ 45 MB of hard disk space

Note: Not all hardware components that function under MPLAB IDE,
such as emulators and device programmers, function under all cur-
rent Windows operating systems. Refer to the user’s guide of the
specific hardware device for details.

2.4 Obtaining the Program Files

The MPLAB IDE application is shipped with every Microchip Development
System. Also, MPLAB IDE may be obtained by contacting any Microchip
sales office and requesting the Technical Library CD-ROM or by downloading
the files from the Microchip web site (www.microchip.com).

The number and names of the files vary depending on the version. Version
5.00 of MPLAB IDE, for example, would have these files:

MP50000.EXE
MP50000.W02
MP50000.W03
MP50000.W04
MP50000.W05
MP50000.WO06
MP50000.W07

© 2001 Microchip Technology Inc. DS51025E-page 13
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2.5 Installing MPLAB IDE

The executable file MPvvvvv.EXE installs the Microchip MPLAB Integrated
Development Environment (IDE), where vvvvv is the version number of
MPLAB IDE.

To install MPLAB IDE, follow these steps:

1.
2.

3.

Enter Microsoft Windows.

If you are installing from the MPLAB IDE CD-ROM, place the CD-ROM
into the drive now.

Execute the installation program:

Windows 3.1: From the File Manager, or from the Program Manager >
Run option, run X:\MPvvvvv.exe, where X is the drive designation of the
install files and vvvvv is the version of MPLAB IDE you are installing. For
example, enter d:\MP50000.exe to install version 5.00 of MPLAB IDE,
where d: is the CD-ROM drive that contains the MPLAB IDE install.

Windows 95/98/ME, Windows NT®, or Windows 2000: If the CD starts
up automatically, follow the prompts given. Otherwise, click the Start but-
ton and select Run. Enter X:-\MPvvvvv.exe, where X is the drive designa-
tion of the install files and vvvvv is the version of MPLAB IDE you are
installing. For example, enter d:\\MP50000.exe to install version 5.00 of
MPLAB IDE, where d: is the CD-ROM drive that contains the MPLAB IDE
install. Then click OK.

Note: Windows NT and Windows 2000 users must have administrative

privileges in order to install MPLAB IDE.

Step through the displayed dialogs where you may customize your
MPLAB IDE installation. If you are unsure about any of the options dis-
played on the dialogs, simply accept the defaults as shown.

Installation Tips:
Selecting the Components

If you have a limited amount of PC memory and you have not purchased
a device programmer or emulator, you can install just the software tools:

- MPLAB IDE files

- MPASM Assembler/MPLINK Linker/MPLIB Librarian files

- MPLAB SIM Simulator Support Files

- Help Files

You can reinstall MPLAB IDE later to add additional components.
Selecting the Destination Folder

We recommend installing MPLAB IDE on a local hard drive rather than a
network drive.

DS51025E-page 14
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Selecting the System Files Folder

Installing the data link libraries (DLLs) to the \Windows\System folder
may allow better management and prevent a future installation of another
version from overwriting these MPLAB IDE files.

5. Watch as your MPLAB IDE files are installed on your system. View any
displayed screens for new product information.

6. View the readme files. The README files contain valuable information
on new features as well as limitations and known problems.
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Note: If you select No when asked if you want to view the README files,
you may view these files later from the MPLAB install folder. It is
recommended that you consult the README files before contact-
ing technical support.

7. Start MPLAB IDE by executing MPLAB . EXE or clicking on the MPLAB
IDE icon. You will see the MPLAB IDE desktop as shown in Figure 2.1.

= MPLAB [ 3
File Project Edit Debug PICSTART Pluz  Options Tool: Window Help

=)@ (b ]5]E]a] B8] %Rl

[E1102 | [T [ |PiC1EFa4

|po:0s00 w000 |- -2 dc o

BkOn [ED [4MHz [User

Figure 2.1: MPLAB IDE Desktop
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2.6 Uninstalling MPLAB IDE

To uninstall MPLAB IDE, open Windows Explorer (or File Manager for
Windows 3.1) and double-click on unwise32.exe (or unwise.exe if you
are using Windows 3.1) in the MPLAB folder to run it. Based on the log file
created during MPLAB IDE installation, the unwise . exe uninstall program
determines which files to remove from the MPLAB IDE, Windows, and
System folders.
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Chapter 3. Getting Sarted with MPLAB IDE —A Tutorial

3.1 Introduction

This tutorial is intended to be a quick introduction to the MPLAB IDE user
interface. It should take about 1 to 2 hours to complete the tutorial.
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This is not intended to discuss all of the details of MPLAB IDE, only to provide
a beginning understanding so you can use MPLAB IDE right away.

3.2 Highlights

In this tutorial, you will learn about:

Setting up the Development Mode
Creating a Simple New Project
Creating a Simple New Source File
Entering Source Code

Assembling the Source File

Running Your Program

Opening Other Windows for Debugging
Creating a Watch Window

Saving the Watch Window

Setting a Break Point

In addition, there is an overview of other features to be discussed in later
chapters.

With the operation of MPLAB IDE provided by this tutorial, you should be able
to:

¢ Become familiar with the MPLAB IDE Desktop

¢ Create a new assembly source code file and enter it into a new project
for the PIC16F84

Identify and correct simple errors

Run the built-in simulator

Set break points

Create Watch windows

Become familiar with the various debugging windows
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3.3 Setting up the Development Mode

1. Menu

2. Toolbar

3. Workspace

T~

4. Status Bar

TS

The previous chapter discussed how to install MPLAB IDE. Now you will
begin setting up the application.

The MPLAB IDE desktop (Figure 3.1) contains the following major elements:

1. A menu across the top line

2. Atoolbar below the menu

3. A workspace in which various files, windows, and dialogs can be
displayed

4. A status bar at the bottom

Notice that the status bar includes information about how the system is

currently configured. We’ll cover some of these features in more detail later.
For now, let's see how to set the development mode.

T MPLAB

File Project Edit Debug PICSTART Plus Options  Tools ‘Window Help
//,' TR P

Figure 3.1: MPLAB IDE Desktop

The development mode sets which tool, if any, will execute code. For this
tutorial we will use MPLAB SIM, the software simulator. Later you may switch
to one of the emulator operations if you have an emulator. Operation will be
similar. “Editor Only” mode does not allow code execution, and is mainly
useful if you have not installed the simulator, do not have an emulator, and
are just creating code to program a PICmicro microcontroller (MCU).

Select the Options > Development Mode menu item and click the Tools tab to
select the development tool and processor for your project.

DS51025E-page 18
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g,

=

Development Mode E ;
Configuration ] Power ] Pinz ] Break Options b p
Tools ] Ports ] Clock ] Memory R >
oy

~+ Mone [Editor Only) Prucessur:| PIC16FB4 j E

‘+ MPLAB-SIM Simulator, Mot all peripherals have support for ﬂ

] simulation.
o LIFLGRIES (Bt Serial 1/0 iz not simulated.

~ PICMASTER Emulator | (Click 'Details' for additional
Lcpen information on PICT16F84.

» MPLAB-ICD Debugger Inquire | Details. . |
114 I Cancel | Apply | Help |

Figure 3.2: Development Mode Tools Dialog

MPLAB IDE is a constantly evolving product, so there may be subtle
differences between what you see and the picture here. Select MPLAB SIM
Simulator and choose the PIC16F84 from the pull-down list of available
processors supported by the simulator. Click OK. The simulator will initialize
and you should see “PIC16F84” and “Sim” in the status bar on the bottom of
the MPLAB IDE desktop. You are now in simulator mode for the PIC16F84
device.

3.4 Creating a Simple New Project

The simulator runs from the same file (a HEX file) that can be programmed
into the PICmicro MCU. For the simulator to run you must first create a source
code file and successfully assemble the source code.

The assembler produces, among other things, a HEX file. This file has the file
extension .HEX. In this tutorial the file will be named tutors84 .hex. Later
this file can be loaded directly into a device programmer without using the
assembler or an MPLAB IDE project. This file can also be loaded by most
other third party programmers.

Select File > New from the menu and you will see a dialog that looks like
Figure 3.3.
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Create Project | ]

A Project is not currently opened.
Would would like to create a new
project?

Yes O

Figure 3.3: Create Project Dialog

Click Yes, and a standard Windows browsing dialog will appear (Figure 3.4).
In this dialog, indicate the location where you want your project stored.
Remember where you put it. You'll need this information later. This tutorial
uses a folderin c: \Program Files\MPLAB and creates the project file
named tutor84.pjt.

“PJT” is a standard suffix for MPLAB IDE project files. The prefix of the project
file name, in this case tutorsg4, will become a default prefix for many of the
files that MPLAB IDE will use or create for this tutorial.

T > |

File Hame: Directories: | Ok I
|lutu|1.pil | | c:\progra™1\mplab
Cancel |
new.pit o =AY -
qq.pjt 25 progra™1 Help |
5 mplab =
£ example
[C3 help
= [Z3 template -
List Files of Type: Drives:
Project Files [*.pijt] j I = e j

Figure 3.4: New Project Dialog

Using the mouse to click OK will bring you to the Edit Project Dialog
(Figure 3.5).

The simulator, programmers, and emulator systems that work with MPLAB
IDE use a HEX file created by assembling, compiling, and/or linking source
code. Several different tools can create HEX files, and these tools are part of
each project. Projects give you flexibility to describe how the application will
be built and which software tools will be used to create the . HEX file. We will
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not get into these details in this tutorial, but as you need these features you
can use the Node Properties to set them. See Chapter 4 for information on
more complex projects.

— Project

Target Filename
|lutnl34_hex |

Include Path

Linker Script Path

Development Mode: |HPU-\B-5|H1EF34 | Change...

|

— Project Files
s I |
Eopy Hode. . |
elete Niode |
Bnld Node |
Mode Properties. . |

=3
5
=
T
A
>
w
]
m

Cancel

Help

ddi

Library Path

L

Language Tool Suite: |Micrnchip

Figure 3.5: Edit Project Dialog — Node Properties Enabled

Notice that the target file name of the Edit Project dialog has been filled in for
you. It uses the development mode that we set previously and defaults to
using the Microchip language tool suite.

In addition, the default language suite, paths, and nodes for all projects are
set by selecting Options > Environment Setup and clicking the Projects tab.
These defaults appear in the Edit Project dialog for all new projects.

In the Project Files window, you will find tutors4 .[hex]. Highlighting this
name will cause the Node Properties button to become usable.

Before doing anything else, we must tell MPLAB IDE how to create the HEX
file. Do this by clicking the Node Properties button. The Node Properties
dialog will appear (Figure 3.6).
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Node: | TUTOR84.HEX =] 1 Took| MPASM =l
— Dpti

Description | | | | Data =
Define 1 On ]
Hex Format 1 INHX8M 1 INHX8S 1 INHX32
Error File ¥ On o1 Off
List File ¥ On o1 Off
Cross-reference File =1 On ¥ Off
Yarning level 20 all L~ warnterr =1 err
Case sensitivity ¥ On o1 Off
Macro expansion 1 On o1 Off
Default radix S HEX ~1 DEC o 0CT
Tab size 1 On
Co d Line
[fe+ A+ #x- 7o+ /p16FBA |
Additional Command Line Options

|
Cancel | Help |

Figure 3.6: Node Properties Dialog

This dialog contains all of the default settings for the language tool shown in
the upper right of the dialog (in this case MPASM). In the simplest form, a
project contains a HEX file created from one assembly source file. This is the
default as the Node Properties dialog appears.

You can see that there are a lot of rows and columns on this dialog. Each row
usually corresponds to a “switch” — those things that are often set on the
command line when the tool is invoked. In fact, the setting of these switches is
reflected in the Command Line window near the bottom. This is the actual
command line that will be issued to the MPASM assembler when it is invoked
from MPLAB IDE.

For now you can use the default settings for all other entries, but as you
become more familiar with building an application, you will probably find that
you'll want to change some of these.

Click OK to apply these defaults, return to the Edit Project dialog and enable
the Add Node button (Figure 3.7).
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Edit Project 1]
— Project

Target Filename
|lutnr34_hex |

Include Path Cancel

ddi

Library Path el
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Linker Script Path

Development Mode: |MPLAB—SIM1BFB4 | Change. ..

Language Tool Suite: |Hicmchip j|

— Project Files

S s T |
Lopy Node... |
relete Node |

Build Node |
MNode Froperties... |

Figure 3.7: Edit Project Dialog — Add Node Enabled

Click Add Node. You will see the standard Windows browse dialog
(Figure 3.8), and the working folder will be the same as the project folder.
Enter the file name tutor84 .asm and click OK.

Add Node HE|
File narme: Enlders:
ItutDrB#.asm chprogra™1 smplab

Cancel

IDASK1E ASM ] = ot | —I
IDASMT7.ASM = PROGRA™
P LS50 = (PLAB Help |
README . ASMM
SAMPLE ASHM 3 EXAMPLE Network |
SakPORB) ASM 3 LER =
TUTEFT A5 TEMPLATE -
TUTOR.ASM 7 = _I

Lizt files of twpe: Drrives:

ISDur-:e file= [*.c” azm] ;I I = o ;I

Figure 3.8: Add Node Dialog
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You will return to the Edit Project dialog and should see tutor84.asm
indented and below the HEX file, indicating that it is a contributing node
(Figure 3.9).

Edit Project E3

— Project

Target Filename
|lutur34_ hex |

Include Path

Development Mode: |MPLAB—5IM, 16FB4 | Change. ..

Cancel

ik

Library Path Help

Linker Script Path

Language Tool Suite: |Hicmchip j|

Hode Properties... |

— Project Files

orf4 [
tutord4 [_asm]

Figure 3.9: Edit Project Dialog — Node Added

Clicking OK takes you back to the MPLAB IDE desktop with an open and
unnamed source code file.
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3.5 Creating a Simple New Source File z
=
Click once in the blank space of the empty file window that has been created =
for you. It is probably titled Untitled. This gives the window focus. Use the File 3
> Save As menu option and save the empty file as tutorsg4 .asm. When the >
standard browse dialog opens, you will find tutor84 .asm located in the E
current working folder of the project. Enter the file name and click OK. w)
m
File Hame: Directones:
|lulnr34.asm | c:\progra™~1implab
Cancel |
IDASM1G6.ASM - = e -
IDASH17 ASM n
MULBXE ASM %T:E&I;A 1 Help |
README ASM
SAMPLE ASM 0 EXAMPLE
SAMPOBJ ASM £ LKR ™ UNIX format
TUTB77.ASM — TEMPLATE | v K back
TUTDR.ASM hd = H Bl
List Files of Type: Dnves: M
Source files [*.c;*.asm] j I Hec: j

Figure 3.10: Save Source File

You will now be presented with the MPLAB IDE desktop and the empty file
window, but the name of the file window will reflect its new name.

The name of the source file and the name of the project (tutors4 in this
tutorial) must be the same in this kind of project. If you change the name of
the source file, you must also change the name of the project to match. Other
projects that use the linker allow the output file name to be different from the
input file. Section 4.6 provides a tutorial on creating projects using the linker.

Note: For a single source file project, the MPASM assembler creates its
output HEX file with the same name as the source file. The project
name, HEX file, and source file MUST have the same name.
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3.6 Entering Source Code

Use the mouse to locate the cursor at the beginning of the tutorsg4 .asm
empty file window, and enter the following text, exactly as written, on each
line. You don’t have to enter the comments (the text following the
semicolons).

list
include
cl equ

org
reset
goto

org
start
movliw
movwf
loop
incfsz
goto

goto
end

p=16£84

<pl6F84.inc>

0x0c
0x00
start
0x04

0x09
cl

cl,F
loop

bug

I

I

I

Set temp variable counter cl at address 0xO0c

Set program memory base at reset vector 0x00

Go to start of the main program

Set program memory base to beginning of user code

Initialize counter to arbitrary value greater than zero
Store value in temp variable a defined above

Increment counter, place results in file register
Loop until counter overflows

When counter overflows, got to start to re-initialize

This code is a very simple program that increments a counter and resets to a
predetermined value when the counter rolls over to zero.

All labels start in the first column, and the last line has an end directive. Refer
to the MPASM User’s Guide with MPLINK and MPLIB (DS33014) for more
information about directives. The PICmicro MCU data sheets contain full
information about instructions along with examples of their use.

Save the file by using the File > Save menu item.
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3.7 Assembling the Source File

Assembling the file can be accomplished in several ways. The method
described here uses the Project > Build All menu item. This will execute the
MPASM assembler in the background using the defaults saved with the
project as noted before. Once the assembly process is complete, the Build
Results window will appear (Figure 3.11).
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Build Results M= E
Building TUTORS4.HEX... A

Compiling TUTORBY4._ASH:
Command line: “C:WPROGRA™1YHPLAB\MPASHUWIN.EXE /p16F84 fq C:\PROGRA™1WMPLABATUTOR8Y.ASH"
Error[113]  C:\PROGRA™M\MPLAB\TUTOR84.ASH 17 : Symbol not previously defined (bug)

HPLAB is unable to find output Ffile “TUTOR84.HEX".

Build failed.

A

Figure 3.11: Build Results Window — Build Failed

You have intentionally entered at least one error if you entered the code as
written in Section 3.6. The last goto in the program references a nonexistent
label called bug. Since this label has not been defined before, the assembler
reports an error. You may have other errors as well.

Using the mouse, double-click on the error message. This will bring the cursor
to the line in the source code that contains the error. Change bug to start.
Use the Build Results window to help find the errors, and repair any other
bugs in your source code. Reassemble by executing the Project > Build All
menu function. This process may take a couple of iterations.

Note: Whenever you rebuild a project all of your source files will be saved
to disk.

When you'’ve fixed all problems in the source code, the Build Results window
will display “Build completed successfully” (Figure 3.12). You now have a
complete project that can be executed using the simulator.

Build Results H=lE
Building TUTOR84.HEX... ﬂ

Compiling TUTOR34.ASH:
Command line: "C:\PROGRA™1\HPLAB\MPASHWIN.EXE /p16FB4 /q C:\PROGRA™~1\MPLAB\TUTOR84.ASH"

Build completed successfully.

Al M

Figure 3.12: Build Results Window — Build Successful
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3.8 Running Your Program

Use the Debug > Run > Reset to initialize the system. The program counter
will be reset to zero, which is the reset vector on the PIC16F84. The source
code line at this address may be highlighted with a dark bar. Also, you may
notice that PC is set to 0x00 in the status bar at the bottom of MPLAB IDE.

Use the Debug > Run > Step menu item. This causes the program counter to
advance to the next instruction location. The dark bar will follow the source
code and the program counter displayed in the status bar should advance to
“pc:0x04.”

2 MPLAB - C:\PROGRA~1\MPLABATUTORS4.PJT

Fil= Project  Edil PICSTART Fluz  Options Toole Window Help

Fun Fs
Execute 3 Rezet FE

‘progra™1% Simulatar Stimulug b Halt F5

| list I . HElh Trace: ShiftrE
include - Center D ebug Location Chl+FS

Animate

cl  equ | Break Settings. .. F2
Trace Settings... Step Owver
I‘esegrg Triggen bt & ethirgs. . Update All Registers %08
goto J igger b Eaints. LChange Program Courter...
Clear All Paints...
star:rg Bl Tiigee S i, base to beginning of user code
moulu 1| o Coverane to arbitrary value greater than zero
lnnpmoum: 1 LClear Program Memory... Chil+Shift+F2 variable a defined aboue
incfFsz o Custem Fesst Etrl+5h!rt+F3 place results in file register
goto - Power-On-Reset... Crl+Shift+F5 overfFlous
goto start ; When counter overflows, got to start to re-initialize
end
] v o

Figure 3.13: Debug > Run > Step Menu ltem

You may notice as you execute the Debug > Run > Step menu item that there
is text on the right side of the menu item that says <F7>. This stands for
“function key seven” on your keyboard. Many MPLAB IDE functions are
assigned to shortcut keys. These keys have the same effect as executing the
menu item itself. Press <F7> a few times and watch the program counter and

dark bar advance through the program.

Execute the Debug > Run > Run menu item or press <F9> to start the

program running from the current location counter. The status bar will change
colors indicating the program is executing instructions. None of the other
fields on the status bar will be updated until the program is halted.

Stop the program by executing the Debug > Run > Halt menu item or by
pressing <F5>. The status bar will change back to its original color, and the
current program counter and other status information will be updated.
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Another way to execute functions is to use the toolbar at the top of the screen.
If you place the cursor over the items in the toolbar, you can see the name of
the function in the status bar at the bottom. The left button is a standard Swap
Toolbar button that allows you to scroll through the available toolbars.
Toolbars can be customized (see Section 1.9.5.1.2). On the debug toolbar,
the green light is equivalent to <F9> (Run) and the red light is the same as
<F5> (Halt).

3.9 Opening Other Windows for Debugging

There are many ways to look at your program and its execution using MPLAB
IDE. For example, this program is intended to increment a temporary counter,
but how do you know for sure that is happening? One way is to open and
inspect the file register window. Do this by executing the Window > File
Registers menu item. A small window with all of the file registers, or RAM, of
the PIC16F84 will appear.

Press <F7> (Execute Single-Step) a few times and watch the values update
in the file register window. We put the counter variable at address location
0x0C. As the temporary counter is incremented, this is reflected in the file
register window. File registers change colors when their value changes so
that they can easily be noticed on inspection. However, in very complex
programs, many values may change, making it difficult to focus on one or two
variables. This problem can be solved by using a Watch window.

3.10 Using a Watch Window

3.10.1

MPLAB IDE allows the contents of file registers to be monitored through a
Watch window.

Creating a Watch Window

To create a Watch window, select Window > Watch Window > New Watch
Window. If you have already created a Watch window and saved it to disk,
select Window > Watch Window > [ oad Watch Window. Select the Watch
window file to load and click OK, or double-click the desired file.

The Add Watch Symbol dialog will appear (Figure 3.14).
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3.10.2

Add Watch Symbol B

Symbol:
lc1 |

C1 e
oC Delete
eeadr

EEADR —
eeconl
EECOM1
eecon? FProperties
EECOM2

eedata

EEDATA h

Cloze

d udl:

Help

Figure 3.14: Add Watch Symbol Dialog

Typing ‘c1’ in the symbol name box will cause the list to scroll to the c1
symbol. Highlight the symbol and click the Add button, then click the Close
button. You will be left with the Watch window on your MPLAB IDE desktop
(Figure 3.15) displaying the current value of the temporary counter value ‘c1.

Watch_1 =] B3
Address Symbol Ualue
ac cl H*@88*
] [

Figure 3.15: Watch Window

You can display the contents of the Watch window with or without line
numbers. To change this setting, select Toggle Line Numbers from the
system menu inside the Watch window.

Press <F7> to single step the program a few times and notice that as the
counter value is incremented, the display is updated in the Watch window. If
you've left the file register window open, it will update as well.

Saving the Watch Window

You can save the Watch window and its settings by selecting Window >
Watch Window > Save Active Watch from the MPLAB IDE menu or by
selecting Save Watch from the system menu inside the Watch window. (The
system menu button is located in the upper left-hand corner of the Watch
window. Clicking this button once will cause the menu underneath to cascade
down.) Choose a name and click OK.
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Save Watch E |

File Hame: Directories:
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| c:\progra™1implab
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[= PROGRA™1
= MPLAB
1 EXAMPLE

1 LKR
1 TEMPLATE ¥

Help

List Files of Type: Drives:
Watch Window Files (= 7| | | = c: ANTYN43ABA  v]

Figure 3.16: Save Watch Window Dialog

The window’s open or closed status and location on the screen is saved with
the project so the next time you open your project, your Watch windows will
be restored as well.

3.10.3 Editing the Watch Window

You can also edit the Watch windows after you’ve created them.

Use either the Window > Watch Window submenu or the system menu inside
the Watch window to edit the information in the Watch window.

Add a symbol Select Window > Watch Window > Add to Active Watch
to the Watch from the MPLAB IDE menu or select Add Watch from
window the system menu inside the Watch window.

Delete a symbol Click on the symbol in the Watch window, then select
from the Watch Delete Watch from the system menu.
window

Change the dis- Select Window > Watch Window > Edit Active Watch
play format of from the MPLAB IDE menu or select Edit Watch from
symbols the system menu inside the Watch window. Then, click
Properties. The Properties dialog allows you to select
the format, size, byte order, and display bits for display
in the Watch Window.
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3.11 Setting a Break Point

Press <F5> (Debug > Run > Halt) to make sure that the simulator processor
is halted. Click in the source code window on the line immediately after the
start label that says movlw 0x09. Click the right mouse button and a small
shortcut menu will appear (Figure 3.17).

Break Fointis)
Trace Foint(s)
Trigger Faointi=)

Run to Here

Figure 3.17: Right Mouse Button Pop-up Menu

Select the Break Point(s) menu item and the menu will disappear and the line
where the cursor was located will change colors, indicating that a break point
has been set at that location.

Press <F6> or execute the Debug > Run > Reset menu item to reset the
system. Then run the system by pressing <F9>. The program will run and
then halt at the instruction just after the break point. ‘c1’, as displayed in either
the Watch window or the file register window (if one is still open), will reflect
the reset status of zero; stepping once will execute the code and ‘c1’ will
reflect a value of 0x09. Press <F9> a few times and notice the status bar
change color while running, and will change again when the processor halts.

Note: If execution doesn’t halt at the break point, select Options > Devel-
opment Mode and click the Break Options tab. Make sure that
Global Break Enable is selected (check marked).

3.12 Summary

This tutorial has shown you how to:

¢ Set up a new project

Create and enter a source file into a project
Assemble code

Run your code using the simulator

Set break points and single step your code
e Watch variables in your code

Once you are comfortable with the topics introduced here, you should look at
the next section for more information on MPLAB IDE.
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Some hints and tips:

Break Points — You can set break points in the Window > Program Memory
window, in the source file window (in this case tutor84 . asm), or in the
Window > Absolute Listing window.

Source Files — Use the Window > Project Window to bring up a list of your
source files. You can double-click on the file name here to bring up that file in
the editor.
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MPASM Errors — If the MPASM assembler gives you an error, double-click on
that error in the error window to go to the error in the source code. If you've
got multiple errors, always choose the first error. Often one error will cause
subsequent errors and fixing the first one may fix them all.

Configuration Bits and Processor Mode — Configuration bits in the source
file will not set the mode of the processor for the simulator or emulators. For
instance, the Watchdog Timer Enable configuration bit can be set so that
when you program a device, the Watchdog Timer (WDT) will be turned on.
You will also need to select Options > Development Mode and click the
Configuration tab to enable the WDT for the simulator or emulator. This
allows you to debug with it on or off without changing your source code. Use
the Options > Development Mode Configuration tab to set the processor
mode as well. Even though you can set these bits in your MPASM assembler
or MPLAB CXX source file, MPLAB IDE does not automatically change
modes.

Options — Go to Options > Environment Setup and click the General tab to
do the following:

* Change the screen font or font size

* Position the toolbar on the side or bottom of the screen
¢ Modify the toolbar

e Change the number of characters displayed for labels

Before you close the dialog, click the Key Mappings tab to map European
Keys to MPLAB IDE functions and special ASCII characters.

Map Files — Go to Project > Edit Project dialog and change MPASM’s Node
Properties to produce a MAP file named tutor84 .map. After you've built the
project, look at tutors4 . map to see build information.

Grayed Out Menus — If you find menus “grayed out,” check to make sure that
you haven’t somehow entered the Editor Only mode. If you're sure everything
is set up correctly, try exiting MPLAB IDE and restarting the program.
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Chapter 4. Projects Tutorial

4.1 Introduction

This chapter discusses in detail how to use projects in MPLAB IDE. If you
completed the tutorial in Chapter 3, you may want to skip this chapter for now
and return to it when you are ready to learn more about projects.

The project managers of MPLAB IDE v3.40 and later support multiple files.
Previously established projects from MPLAB IDE v3.31 and earlier will be
converted automatically by newer versions of MPLAB IDE when they are
opened. Once a project is converted, it cannot be reopened using a previous
version of MPLAB IDE.

4.2 Highlights

In chapter you will learn these functions of MPLAB IDE Projects:
* Qverview of Projects

=
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* Making a Project with One MPASM Assembler Source File

* Compiling a Single MPASM Assembler Source File Without Creating a
Project

* Making a Project with Multiple MPASM Assembler Source Files using
MPLINK Linker

* Making a Project with Other Tools
To perform these tasks, you will use the following features of MPLAB IDE:
* Install Language Tool
¢ New Project
¢ Add Nodes to a Project
¢ Set Project Node Properties
Make/Build Project
* Project Window

4.3 Overview of Projects

A Project in MPLAB IDE is the group of files needed to build an application
along with their associations to various build tools. A project is made up of a
project node and one or more source nodes. The source nodes are typically
assembly source files, C source files, precompiled object files, libraries and
linker scripts. Usually the project is placed in the same folder as the main
source files.
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prog.cod prog.hex prog.lst ‘ prog.map
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SIMULATOR/
EMULATORS/
PROGRAMMERS

Figure 4.1: Project Relationships
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In this MPLAB IDE Project, the C source file main. c is associated with the
MPLAB CXX compiler. MPLAB IDE will use this information to generate an
object file (main. o) for input into the linker (MPLINK). See the MPLAB CXX C
Compilers User’s Guide (DS51217) for more information on using the
compiler.

An assembly source file (prog.asm) is shown also with its associated
assembler (MPASM). MPLAB IDE will use this information to generate the
object file prog. o for input into the MPLINK linker. See the MPASM User’s
Guide with MPLINK and MPLIB (DS33014) for more information on using the
assembler.

In addition, precompiled object files (precomp . o) may be included in a
project, with no associated tool required. Types of precompiled object files
that are generally required in a project are:

¢ Start up code

¢ |nitialization code

¢ [nterrupt service routines
* Register definitions

Precompiled object files are often device and/or memory model dependent.
For more information on available Microchip precompiled object files, see the
MPLAB CXX C Compilers Reference Guide (DS51224).

Some library files (math.1ib) are available with the compiler. Others may be
built outside the project using the librarian tool (MPLIB). See the MPASM
User’s Guide with MPLINK and MPLIB (DS33014) for more information on
using the librarian. For more information on available Microchip libraries, see
the MPLAB CXX C Compilers Reference Guide (DS51224).

The object files, along with library files and a linker script file (device. 1kr)
are used to generate the project output files via the linker (MPLINK). See the
MPASM User’s Guide with MPLINK and MPLIB (DS33014) for more
information on linker script files and using the linker.

The main output file generated by the MPLINK linker is the HEX file
(prog.hex), used by simulators (MPLAB SIM), emulators (MPLAB ICE 2000
and PICMASTER®) and programmers (PRO MATE Il and PICSTART Plus).
The other output files are:

* Code file (.cod) — Debug file used by MPLAB IDE.

e Listing file (.Ist) — Original source code, side-by-side with final binary
code.

* Map file (.map) — Shows the memory layout after linking. Indicates
used and unused memory regions.

The tools shown here are all Microchip development tools. However, many
third party tools are available to work with MPLAB IDE Projects. Please refer
to the Third Party Guide (DS00104) for more information.

© 2001 Microchip Technology Inc.
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4.4 Making a Project with One MPASM'* Assembler
Source File

To make a project that has only one MPASM assembler source file, or that
uses the previous method of projects (MPLAB IDE v3.31 or earlier), wherein a
single source file would #include other files, follow these steps.

source
sample.asm R
file

MPASM ASSEMBLER

v
sample .hex I main output
file

Figure 4.2: Project Relationships For One MPASM Assembler
Source File

4.4.1 Set Development Mode

Select the proper development mode for the application. Select Options >
Development Mode and click the Tools tab. For this tutorial, select MPLAB
SIM simulator and select the PIC16F84 PICmicro microcontroller (MCU).

Click OK.
Development Mode
Configuration ] FPower ] Pins ] Break Options B
Tools ] Ports ] Clock ] Memory q
~~ None [Editor Only) Pmcessur:| PIC1GF84 =

+ MPLAB-SIM Simulator Mot all peripherals have support for ﬂ

N simulation.
I e Serial 1/0 iz not zimulated.

- PICMASTER Emulator | [Click ‘Details’ for additional
T AT information on PIC16F84. LI

 MPLAB-ICD Debugger e | Details. .. |
(1] 4 I Cancel | Apply | Help I

Figure 4.3: Development Mode Dialog
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4.4.2 New Project =3
=
Select Project > New Project, select a folder for the new project, then type in =
its name. Use the \Program Files\MPLAB installation folder and name it o
SAMPLE . PJT for this tutorial. ;
oy
=
File Hame: Directories: | oK I
|sample|.pit | | c:\progra™~1implab
Cancel |
new. pit - et -
qg.pit 5 progra™ Hel |
tutor84._pjt =4 mplab Help
[ example
[ help
= [Z template -
Lizt Files of Type: Drives:
Project Files [*.pjt] j I = c: j

Figure 4.4: New Project Dialog — sample.pijt

4.4.3 Project Dialog
After clicking OK, you will see the Edit Project Dialog:

Edit Project

— Project
Target Filename

|sample.hex |

Include Path

Library Path

Linker Script Path

Development Mode: [MPLAB-SIM16F84 | Change...

Cancel

Help

ddil

Language Tool Suite: |Micmchip j|

Add Node... |
Lopy Node: |
Diefete Node |

Binld/Niode |
Mode Properties... |

Figure 4.5: Edit Project Dialog
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444

Set Node Properties

Select the file name, sample . hex, in the Project Files window, then click the
Node Properties button.

Node Properties
Node: | SAMPLE HEX =] L Took[MpasM 7]
— Options
Description | | | | | Data >
Define & 0On I
Hex Format 0 INHXBM 1 INHX85 1 INHX32
Error File M On o off
List File M On 1 Off
Cross-reference File = On M Off
Warning level o all 1 warnterr 21 err
Case sensitivity # On o Off
Macro expansion o On o Off
Default radix o HEX -1 DEC o 0CT
Tab size & 0On
C d Line

[te+ 21+ 1x- 7e+ sp16FBA

Additional Command Line Options

T Cancel |

Help |

Figure 4.6: Node Properties Dialog

The Node Properties dialog shows the command line switches for the tool, in
this case MPASM. When you first open this dialog, the checked boxes
represent the default values for the tool. For this tutorial, these do not need to
be changed. Refer to the MPASM User’s Guide with MPLINK and MPLIB
(DS33014) for more information on these command line switches.

Click OK to return to the Edit Project dialog box.
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4.4.5 Add Node i
. . . . . =)
Click Add Node from the Edit Project dialog. Use sample . asm for this =
tutorial. This is the browse window that pops up when you click Add Node. o
-
>
w
Add Node B E 5
File name: Folders: m
Isample.asm c:hprogra™1 smplab
Cancel
12c508a.asm - = o ;I —I
12c508a2. azm ~
DEMDBF?.ASM ?E-PNTF‘DLI.E&HB'& ! Help |
IDASMIE.ASM
IDASMI7.A5M 3 EXAMPLE Metwork... |
b LIL 2 A5 R 3 LKR =
README A5 TEMPLATE ¥
SAMPLE.ASHM hd = =
Lizt filez of type: Crrives:
|Source files (*.casm) | | B2 o aNTYN4ZaRA  w|

Figure 4.7: Add Node Dialog

The MPASM assembler always makes a . HEX file with the same name as the
source .ASM file. The Project Manager will create a sample .hex file when
the project is built.
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4.4.6

The Edit Project dialog should look like this:

Edit Project E2
—Project

Target Filename

|sample.he:u: |

Cancel

Include Path —I

Library Path SEl

Linker Scnpt Path

Development Mode: |MPU\B—SIM1BFB4 | Change. .

Language Tool Suite: |Micmchi|:l ﬂ|

— Project Files

sample [ hex] AddHode...
sample [.azm]
Copy Hode. .. |
Delete Hode |
Euild/Hiode |
Node Properties. |

Figure 4.8: Edit Project Dialog with Node

In this simple example, no entries were made in the Path boxes. As your
application becomes more complex, you may need to enter the folders of your
include files, libraries, and linker scripts in the appropriate box. The default
language suite, paths, and nodes for all projects are set selecting Options >
Environment Setup and clicking the Projects tab.

Click OK in the Edit Project Dialog.

Make Project

Select Project > Make Project from the menu to compile the application using
the MPASM assembler. A Build Results window is created that shows the
command line sent to the assembler. It should look like this:

Build Results =13

Building SAMPLE.HEX...

Compiling SAMPLE.ASH:
Command line: "C:YPROGRA™1\MPLAB\MPASMWIN.EXE /p16F84 /fq C:\PROGRA™1\MPLAB\SAMPLE.ASH"

Build completed successfully.

K| O

Figure 4.9: Build Results Window
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4.4.7 Troubleshooting

If the build did not complete successfully, check these items:

1. Examine the Build Results window for syntax errors in your source file.
If you find any, double-click on the error in the Build Results window to
go to the line in the source file that contains the error. Correct the error,
then try the build again.

2. Select Project > Edit Project. Select the HEX file node and click Node
Properties. Check to see that the correct build tool (MPASM) is shown
in the Node Properties dialog.

3. Select Project > Edit Project. Check the names of the files listed in the
Project Files list. If you have accidentally added the wrong file, click on
it, click Delete Node, then add the correct node as described in
Section 4.4.5.

4. Select Project > Install Language Tool... and check that the MPASM
assembler is pointed to MPASMWIN. EXE in the MPLAB IDE installation
folder. Also, the “Windowed” option should be selected.

Alternatively, the MPASM assembler can point to MPASM. EXE and the
“Command-line” option selected; however this executable may not oper-
ate on Pentium 100MHz PCs and higher.

=
5
=
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Install Language Tool
Language Suite: |Micmchip jl

Tool Name: |MPASM =

Executable: |C:\PHDEHA“'1\MPLAB\MPASMW’IN.EXE | Browse. .. |

" Command-line & Windowed

Cancel | Help |

Figure 4.10: Install Language Tool Dialog
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4.4.8 Project Window

Open the Window > Project window to see that the target name is set properly
to match the Node source name. They will have different file
extensions, .ASM and .HEX, but both are named SAMPLE for this tutorial.

The Project window should look like this:

Project Window _ O] %]
Project Listing -
Path: C:\PROGRA™1\HPLABY

Project Mame: SAMPLE .PJT

Target: SAMPLE .HEX

Tool Suite: Microchip

Processor: PIC16F84

Development Hode: Simulator

Target Data

File List: SAMPLE .ASH;
Build Tool: MPASH
Node: SAMPLE .ASH
Dependency List:
P16F84.INC
< | v

Figure 4.11: Project Window

4.4.9 Summary

Here is a quick list of the steps to set up a new project as described above:
¢ Create new project with Project > New Project.

¢ Set project Node Properties to MPASM and select the desired build
options.

¢ Add Source file node.
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4.5 Compiling a Single MPASM Assembler Source
File Without Creating a Project

It is possible to compile a single file without opening up a project. The
disadvantage of this method is that although no initial project setup is needed,
you must specify options every time you compile the file. This example will
use the same assembly language file used in the last example.
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You must first close any open projects. To do this, select Project > Close
Project.

4.5.1 Set Development Mode

Select the proper development mode for the application. For this tutorial,
select Options > Development Mode and click the Tools tab. Select MPLAB
SIM simulator and select the PIC16F84 PICmicro MCU. Click OK.

Development Mode E3 |
Configuration ] Power ] Pins \I Break Ophions N
Tools ] Ports ] Clock 1 Memory b
~ None (Editor Only] | Processor:| PIC16F84 =

* MPLAB-SIM Simulator Mot all peripherals have support for ﬂ

MPLAB-ICE Emulat simulation.
4 milator Senal 170 i1z not simulated.

~ PICMASTER Emulator | [Click 'Details' for additional
L oEpn information on PIC16F84. -

 MPLAB-ICD Debugger T | Details... |
1] 4 I Cancel | Apply | Help |

Figure 4.12: Development Mode Dialog
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4.5.2 Open Source File

Open the source file that you wish to assemble. For this tutorial, use
sample.asm from the MPLAB IDE installation folder.

cr\progra~1implab\sample_asm M=l E3

-

H SAMPLE .ASH
H 8x8 Software Multiplier for 16Cxxx Family

The 16 bit result is stored in 2 bytes

H

; Before calling the subroutine ™ mpy ™, the multiplier should
be loaded in location * mulplr *, and the multiplicand in

* mulcnd ™ . The 16 bit result is stored in locations

H_byte & L_byte.

LIST p=16F84 ; PIC16F844 is the target processor
#include "P16F84_INC" ; Include header file

cblock @x18 Temporary storage

H
nulcnd ; 8 bit multiplicand
nulplr ; 8 bit multiplier, this register will be set to zero after multiply
H_byte ; High byte of the 16 bit result
L_byte ; Low byte of the 16 bit result
count ; loop counter
endc
org a8 =
K| o

Figure 4.13: Source File Window

4.5.3 Compile Source File

Select Project > Build Node from the menu to compile sample . asm using the
MPASM assembler. MPLAB IDE opens an Invoke Build Tool Dialog that looks

like this:
Invoke Build Tool [ ]
L Suite: | Mi hip LI' Language TDD|:| MPASH L||
— Dptions
Description | | | | | Data =
Define 1 On —_
Hex Format S0 INHXBM 1 INHX85 1 INHX32
Error File * On o Off
List File ¥ On o1 Off
Cross-reference File =1 On 0 Off
Warning level 1 all I warnterr - err
Case sensitivity * On o Off
Macro expansion 1 On o1 Off
Default radix o1 HEX I DEC o oCT
Tab size 21 On
C d Line
[fe+ 21+ fn- fo+ /p1GFBA |
Additional Command Line Options
|
Cancel | Help |

Figure 4.14: Build Tool Dialog

DS51025E-page 46 © 2001 Microchip Technology Inc.



Projects Tutorial

Verify that the MPASM assembler is selected, and set the tool options to
match those shown above. Click OK in the Invoke Build Tool Dialog to start
the build process. A Build Results window is generated that shows the
command line sent to the assembler and the build output. It should look like
this:
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Build Results [_ (O] %]
Building SAMPLE.ASH... -

Command line: "C:\PROGRA™A\MPLAB\HMPASHUIN.EXE fe+ /f1+ /x- jc+ /p16F8A fq SAMPLE .ASH"

Build completed successfully.

K 3y

Figure 4.15: Build Results Window

4.5.4 Troubleshooting

If the build did not complete successfully, check these items:

1. If you modified the sample source code, examine the Build Results win-
dow for syntax errors in your source file. If you find any, double-click on
the error in the Build Results window to go to the line in the source file
that contains the error. Correct the error, then try the build again.

2. Select Project > Install Language Tool... and check that MPASM assem-
bler is pointed to MPASMWIN. EXE in the MPLAB IDE installation folder.
Also, the “Windowed” option should be selected.

Alternatively, the MPASM assembler can point to MPASM. EXE and the
“Command-line” option selected; however this executable may not oper-
ate on Pentium 100MHz PCs and higher.

Install Language Tool

Language Suite: | Microchip j|

Tool Name: |MPASM =

Executable: |E:\PHDEHA“'1\MPLAB\MPASHW’IN.EXE | Browse. .. |

" Command-line * Windowed

Cancel | Help |

Figure 4.16: Install Language Tool Dialog
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4.5.5 Summary
Here is a quick list of the steps to set up a new project as described above:
e If a project is open, close it using Project > Close Project.

¢ Open the source file you wish to compile.
e Select Project > Build Node.

¢ Select the desired language suite, build tool, and build options in the
Invoke Build Tool dialog.
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4.6 Making a Project with Multiple MPASM
Assembler Source Files using MPLINK'" Linker

To use MPLINK linker to link two or more MPASM assembler object files,
follow these steps. If you followed through the previous section, select Project
> Close Project.

source
files

example.asm

example2.asm

v v

MPASM MPASM ASSEMBLER

Y Y

‘ object
example.o example2.o )
files
16f8a. lkrl IIInker script
file
MPLINK LINKER

v
example.hex I :::In OUtPUt

Figure 4.17: Project Relationships For Multiple MPASM Assembler
Source Files

4.6.1 Set Development Mode

Select Options > Development Mode and click the Tools tab. Select MPLAB

SIM simulator and select the PIC16F84 PICmicro MCU for this example. Click
OK.
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4.6.2

Configuration ] Power
Tools ] Ports

Development Mode E

] Break Ophions 3
] Memory 3

] Pins
] Clock

» Mone [Editor Only]

<+ MPLAB-SIM Simulator:
» MPLAB-ICE Emulator
* PICMASTER Emulator
e HLEERL

» MPLAB-ICD Debugger

F"mc:essm:| PIC16F84

[]

Mot all penpherals have support for ﬂ

simulation.

Senal 1/0 1z not simulated.
Chick 'Details’ for additional
information on PIC1G6F84.

=

Inguire |

Details. .. |

ox ]

Cancel | Apply

Help |

Figure 4.18: Development Mode Dialog

New Project

Select Project > New Project, browse to select a folder for a new project, then
type in its name. Use the \PROGRAM FILES\MPLAB\EXAMPLE folder for this
tutorial and name the file EXAMPLE . PJT.

Lizt Files of Type:

= e:r -
[= PROGRA™1

[= MPLAB

F= ExXAMPLE

Drives:

Project Files (~pitt |~

IE-::: j

Hew Project |
File Hame: Directories: | 1] 4 I
|examplel.pit | | c:\..\mplab\example

Cancel

i

Help

Figure 4.19: New Project Dialog — example.pijt
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4.6.3 Set Node Properties =3
>
Select the name of the project in the Project Files dialog of the Edit Project =
Dialog and click Node Properties to open this dialog. Set the language tool to o
MPLINK. r
>
vy)
o
m
Node: | EXAMPLE.HEX =] Language Tool: |
— Dptions
Descripti | [ [ [ [ Dat -
Map fileescrm e on = —
Hex Format S0 INHX8M 1 INHX8S 1 INHX32
Quiet mode =1 On
Lines per list page =1 On
No List File =1 On

Co d Line
[0 EXAMPLE.HEX |

Additional Command Line Options
1] .4 I Cancel I Help |

Figure 4.20: Set Node Properties Dialog

The Node Properties dialog shows the command line switches for the tool, in
this case MPLINK. When you first open this dialog, the checked boxes
represent the default values for the tool. For this tutorial, these do not need to
be changed. Refer to the MPASM User’s Guide with MPLINK and MPLIB
(DS33014) for more information on these command line switches.

Click OK to return to the Edit Project Dialog box.

4.6.4 Add First Source File Node

Select Add Node from the Edit Project Dialog. Use example.asm in the
\PROGRAM FILES\MPLAB\EXAMPLE folder for this tutorial.
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Add Mode =1

File name:

IE wample. azm

Exampled. azm

Lizt files of bppe:

c:hprogra™ 1 W mplabhexample

Cancel
= o\ ;I —I
[= PROGR.A™
= MPLAE 4|ﬂe'p
= EXAMPLE Metwark. .. |

Cirivees:

ISDurce files [*.o* asm) ;I

IEC: ;I

Figure 4.21: Add Node Dialog

You may select more than one file at a time from this dialog. To select several
files without selecting the files between them, hold the <Cirl> key while
selecting each file. To select a range of files hold the <Shift> key and select
the first and last files.

Select example . asm from the list of project files in the Edit Project dialog,
and click Node Properties.

Verify that the language tool is set to MPASM.

Mode Properties E
Node: | EXAMPLE.O = Language Taol:[MPASM =]
— Options
Description I I I I Data -
Define 1 On —
Error File * On o1 Off
List File ¥ 0On 1 Off
Cross-reference File =1 On ¥ Off
Warning level o0 all 1 warn+err 1 err
Case sensitivity ¥ 0On 1 Off
Macro expansion 1 On 1 Off
Default radix I HEX I DEC o 0CT
Tab size 1 On

Command Line

[fe+ A+ #x- Jc+ /D1GFBA fo+

Additional Command Line Options

Cancel | Help |

Figure 4.22: Node Properties Dialog — Example.o
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The Node Properties dialog shows the command line switches for the tool, in
this case the MPASM assembler. Refer to the MPASM User’s Guide with
MPLINK and MPLIB (DS33014) for more information on these command line
switches.

Click OK to return to the Edit Project Dialog box.
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4.6.5 Adding Additional Source Files

Follow the previous two steps to add the rest of the source files to the project.
For this tutorial, select example2.asm from the \PROGRAM
FILES\MPLAB\EXAMPLE folder. You can also use Copy Node to enter
subsequent files with the same Node Options as the first source file. Make
sure the Node Options are set properly on each file.

To use the Copy Node feature, select one of the source node files listed in the
Project Files box. Then click Copy Node. In the Add Node dialog box, select
one or more source files. Once the files are selected, click OK. This step will
set up the node properties for this selected files the same as the referenced
node used. This is especially useful for adding multiple source files with
identical node properties.

4.6.6 Select Linker Script

Select a linker script using the Add Node button and the method described
above. A linker script is a file that MPLINK linker uses to define the memory
architecture of each PICmicro MCU. Standard linker scripts come with
MPLINK linker and are in the MPLAB IDE installation folder. For this tutorial
select PIC16F84 . LKR from the \PROGRAM FILES\MPLAB\EXAMPLE folder.
Node options can not be set for a linker script.

© 2001 Microchip Technology Inc. DS51025E-page 53



MPLAB® IDE User’s Guide

Edit Project E

— Project

Target Filename

|example.hex |

Include Path Cancel |

| |
Library Path $|
|

Linker Script Path

Development Mode: |MPLAB—5IM1EFB4 | Change. ..

Language Tool Suite: | Microchip ﬂ|

— Project Files

example [_hex] | Add Hode._.
example [.asm]

example? [.asm]
16684 [Ikr] Copy Node..

Build Node

|

|

Deiste Hoae |
|

|

Node Properties..

Figure 4.23: Edit Project Dialog — Linker Script

Click OK in the Edit Project dialog.

In this simple example, no entries were made in the three “Path” boxes. As
your application becomes more complex, you may need to enter the folders of
your include files, library files, and linker script files in the appropriate box if
they are not in the same folder as the project. The default language suite,
paths, and nodes for all projects are set by selecting Options > Environment
Setup and clicking the Projects tab (see Section 1.9.5.2).
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4.6.7 Make Project

Select Project > Make Project to compile the application using MPASM
assembler and MPLINK linker. A Build Results window is created that shows
the command lines sent to each tool. It should look like this:

=
5
=
o
-
>
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o
m

Build Results =] 3
.

Building EXAMPLE .HEX...

Compiling EXAMPLE.ASH:
Command line: “C:\PROGRA™1\MPLAB\HPASHWIN.EXE fe+ /f1+ /x- /c+ /p16F84 /fo+ /fq C:\PROGRA™1\HPL

Compiling EXAMPLEZ2.ASH:
Command line: "C:\PROGRA™1\MPLAB\HPASHWIN.EXE fe+ /fl+ /x- Jc+ /p16F84 fo+ /fq C:\PROGRA™I\HPL

Linking:

Command line: "C:\PROGRA™1\MPLAB\MPLINK.EXE /o EXAWPLE.HEX EXAMPLE.O0 EXAMPLEZ.0 16F84_LKR
HMPLINK v2.18.81, Linker

Copyright (c) 2888 Microchip Technology Inc.

Errors H ]
Warnings : @

HPZCOD v2.18.81, COFF to COD File Converter
Copyright {c) 2088 Microchip Technology Inc.

Errors HI
Warnings : @

MP2HEX v2_18.81, COFF to HEX File Converter
Copyright (c) 2888 HMicrochip Technology Inc.

Errors H ]

Warnings : @

Build completed successfully.

Ki| o

Figure 4.24: Build Results Window
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4.6.8 Troubleshooting

If the build did not complete successfully, check these items:

1. If you modified the sample source code, examine the Build Results win-
dow for syntax errors in your source file. If you find any, double-click on
the error in the Build Results window to go to the line in the source file
that contains the error. Correct the error, then try the build again.

2. Select Project > Edit Project. Select the HEX file node and click Node
Properties. Check to see that the correct build tool (MPLINK) is shown
in the Node Properties dialog. The build tool for the source files for this
project should be MPASM.

3. Select Project > Edit Project. Check the names of the files listed in the
Project Files list. If you have accidentally added the wrong file, click on
it, click Delete Node, then add the correct node as described in
Section 4.6.5.

4. If MPLAB IDE reports the message, “Time-out,” click OK to continue.
Depending on the speed of your PC and the size of your project, you
may wish to configure the length of time MPLAB IDE will wait before
reporting a timeout message. This value is set by selecting Options >
Environment Setup, clicking the Project tab, and adjusting the Build
Timeout Length in the dialog box. Set the Build Timeout Length to 0O if
you never wish to see a timeout error.

Environment S5etup

General ] Pmiect] Filez ] Default Editor Modes ] Key Mappings ] Colors ]

Project Template

Default Language Suite: | Microchip j|

Default Project Type: > Linked < Absolute

Default Include Path: | |

Default Library Path: | |

Default Linker Script Path: | |

Default
Project Nodes:

Add Node._.
Delete Hode |

Project Dptions

Size of Most Recently Used Projects List: l:li’
Build Timeout Length: Seconds

OK I Cancel | Apply | Help

Figure 4.25: Environment Setup Dialog
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5. Select Project > Install Language Tool... and check that the MPASM g
assembler is pointed to MPASMWIN. EXE in the MPLAB IDE installation 5
folder. Also, the “Windowed” option should be selected. =
Alternatively, the MPASM assembler can point to MPASM. EXE and the o
“Command-line” option selected; however, this executable may not ;
operate on Pentium 100MHz PCs and higher. W

s
Install Language Tool
Language Suite: |Hicmchip LI|
Tool Name: |MPASM =l
Executable: |C:\PFIDEHA"'1\HPLAB\MPASHWIN_EXE | Browse. .. |
" Command-line &+ Windowed
Cancel | Help |

Figure 4.26: Install Language Tool Dialog — MPASM Assembler

4.6.9 Project Window

Open the Window > Project window. It should look like this:

Project Window =] B3
Project Listing -
Path: C:\PROGRA™\MPLABNEXAMPLEY

Project Mame: EXAMPLE .PJT

Target: EXAMPLE .HEX

Tool Suite: Microchip

Processor: PIC16F8Y

Development Mode: Simulator

Target Data

File List: EXAMPLE .0 ;EXAMPLEZ .0 ;16F84 .LKR;

Build Tool: MPLINK

Hode: EXAMPLE.D

File List: EXAMPLE .ASH;

Option String: fev; /e /-5 /c+;

Build Tool HPASH

Hode: EXAMPLE .ASH

Hode: EXAMPLE2.D

File List: EXAMPLE2 .ASH;

Option String: Fer fl+ /8- /c;

Build Tool HPASH

Hode: EXAMPLEZ .ASH

Hode: 16F 84 .LKR

| aw

Figure 4.27: Project Window
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4.6.10

Summary

Here is a quick list of the steps to set up a new project as described above:
* Create new project with Project > New Project.
¢ Set project Node Properties to MPLINK.
¢ Add Source file nodes, and set node properties as needed.
* Add Linker Script file node.

4.7 Making a Project with Other Tools

Other tools may be used with MPLAB IDE Projects to build applications.
Microchip makes the MPLAB C17 and MPLAB C18 C compilers for
PIC17CXXX and PIC18CXXX devices, respectively. Contact any Microchip
sales office (see back cover) or our web site (http:\\www.microchip.com) for
information on how to purchase these compilers. Also, see our web site for
tutorials on how to use these compilers with MPLAB IDE.

Certain third party tools also work with MPLAB IDE Projects. Consult the Third
Party Guide (DS00104) for more on these tools. Also, see our web site for
tutorials on how to use these tools with MPLAB IDE.
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Chapter 1. MPLAB Editor

1.1 Introduction

This chapter defines what MPLAB Editor is and how it helps you, as well as
introducing the features and functions of the editor. Since the MPLAB Editor is
integrated into MPLAB IDE, its functions are detailed in Part 3, Chapter 1
along with all other MPLAB IDE functions.

1.2 Highlights

The following topics are addressed in this chapter:
¢ What is the MPLAB Editor
* How MPLAB Editor Helps You
* MPLAB Editor Features
* MPLAB Editor Functions

1.3 What is the MPLAB Editor

The MPLAB Editor is an integrated part of the MPLAB Integrated
Development Environment (IDE). The editor is always available when MPLAB

IDE is running. It is not a separate executable file but a set of features in
MPLAB IDE.

=
o
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>0
WS
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Q
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= MPLAB - C:\PROGRA™1\MPLAB\EXAMPLEAEXAMPLE PJT

Fil= Project B Debug PICSTART Plus Options Tools Window Help

= el [tz L

Cut Chil+
Chl+C

— Lopy
Easte (St

§EERREN

Select Al SAMPLE .ASH
Select Word Multiplier for 16Cxxx Family

LDielete Line  Ctrl+5hift+k
Delete EOL Chl+k  lored in 2 bytes

GotoLine.. tine " mpy ", the multiplier should
Find... ulplr *, and the multiplicand in
Beplace.. esult is stored in locations

Repeat Find Shift+F3
Repeat Replace Shift+F4

Match Brace Chil+E

H
e [C16F 844 is the target processor|
Template

Test " ; Include header file

cblock 8218  ; Temporary storage
mulcnd ; 8 bit multiplicand

mulply ;5 8 bit multiplier, this register will be set to zero_|;|

Kl I
Ln 1 Coll BE | [wR [Mowrap INS PICTEF24  |pe0w00 w00 -—zdcc  |[BROn [Sim (4 MHz |[User

Figure 1.1: Using the MPLAB Editor
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1.4 How MPLAB Editor Helps You

The MPLAB IDE and Editor are designed to allow PICmicro microcontroller
developers an easy and quick method to develop and debug firmware for
Microchip Technology Incorporated’s PICmicro microcontroller product
families.

1.5 MPLAB Editor Features

1.5.1 File Size

The MPLAB Editor is limited only by the total amount of available memory on
your system. There are no limits on the number of editable files or on the
number of open edit windows. The MPLAB Editor also has no limit on the size
of file that it can open and has no limit on the number of lines that a file may
contain.

1.5.2 Windows MDI Conventions
MPLAB Editor adheres to the Windows MDI conventions:

¢ Invokes most commands and facilities from menus
* Moves around with a mouse or with standard keyboard shortcuts
¢ Supplies cut and paste capabilities from the clipboard

1.5.3 Reconfigure Keyboard

You can reconfigure the keys to meet your requirements. Commands may be
invoked by two-character key sequences like <Esc+G>, <Ctrl+K>, and
<Ctrl+B>. You may also use key sequences such as <Alt+F> and <Alt+S>.
You can map almost all keyboard keys in any combination.

1.5.4 Build Files Easily
MPLAB Editor allows you to:

¢ Define sets of templates — standard lines of text — that you can insert
into the current file with just a few mouse clicks.

¢ Group the templates you work with into distinct files.
¢ Load templates for automatic usage.
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1.6 MPLAB Editor Functions

The MPLAB Editor provides functions that allow you to perform the following
operations:

¢ File operations
¢ Template operations

Text handling

Editor window modes

C language awareness

1.6.1 File Operations

To create a file, select a file for editing, and save a file, use the File menu
options (see Section 1.4). The MPLAB Editor allows you to save the file by
overwriting the existing file or by saving the file to a new filename.
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1.6.2 Template Operations

How do you take the repetition (and the waste) out of creating new source
code files? You could simply paste the necessary code and text into your new
source files by copying it from your previously completed source files.
However, that can be an error-prone process.

MPLAB IDE provides you with templates, which are pre-built text files or
sections of text that you can insert in your source files. By inserting these
“canned” sections of text instead of repetitively typing it into new source files,
you reduce your initial code development time. You can use the absolute code
templates included in the Templates folder inside the MPLAB IDE folder or
create your own.

Once you set up MPLAB IDE to use your templates, you can create your new
source file (or open an existing one), insert the template text into the new
source file, and search for the special markers that help you quickly locate the
areas that you will need to customize during your application development.

You can repeat the above steps to create several different .tpl files if you wish.
For example, you may want to a separate .ipl file for each type of application
or for each device.
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1.6.3

Text Processing

Although MPLAB Editor is intended to be used as a program text editor, it has
several features that make it useful in general text editing. Refer to
Section 1.6 for details.

1.6.3.1 Inserting, Selecting, and Deleting Text

MPLAB Editor inserts text in either insert or strikeover mode. MPLAB Editor
shows the mode as either “INS” or “OVR” on the status bar.

Text selection features allow you to select a character, word, or an entire line.
You can delete a character, entire line, or delete from the cursor position to
the end of the line. You can also use the MPLAB Editor’s built-in find and
replace feature to search for and replace text or special characters.

1.6.3.2 Indenting and Unindenting Text

When editing program source, indenting and unindenting source is very
common. The MPLAB Editor provides a facility to change the indentation level
of one or more lines of text.

1.6.3.3 Changing Case

The MPLAB Editor allows you to change the case of selected text between
uppercase and lowercase.

1.6.3.4 Handling Braces

MPLAB Editor allows the user to manipulate brace characters such as
brackets and parentheses, which often delimit sections of text or program
sources.

1.6.3.5 Undoing Edit Actions

The MPLAB Editor records edit actions and can reverse them with the Undo
command.

1.6.3.6 Automatic Text Wrapping

When typing ordinary text, it may be convenient to have the program fit the
text into the available line width. This would typically not be the case when
editing a program source code file.

To change the text wrapping mode, double-click the left mouse button in the
wrap area of the status bar. This area shows the text “No Wrap” when
wrapping is not active. The double-click action turns wrapping on. For
example, the status bar shows “Wr 72” when wrapping is enabled and set at
column 72.
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1.6.4

1.6.5

The points at which MPLAB Editor wraps a line vary with the language type
defined for the window.

1.6.3.6.1. Language type “(none)” or “C”

MPLAB Editor breaks the line at the closest white space character or hyphen
to the defined wrap column.

1.6.3.6.2. Language type “TeXt”

MPLAB Editor breaks the line at the closest white space character to the
defined wrap column.

Note: MPLAB Editor wraps the line being typed only when the cursor is
at the end of the line. If you move the cursor to somewhere within
the line and enter text, MPLAB Editor does not wrap the line even
if it extends past the wrap column.

=
o
rC
>0
WS
(0
Q
m

Edit Window Modes

The MPLAB Editor associates a set of window modes with every edit window.
The possible window modes affect the screen formatting, text display and
input, printing, and file modes. See Part 3, Section 1.9.3 and Section 1.9.4 for
more information on Editor Modes.

C Language Awareness

When editing files that have language type set to “C,” MPLAB Editor provides
these facilities:

e MPLAB Editor always moves a “#” character typed in an otherwise
empty line to column 1.

* MPLAB Editor moves a closing “}” brace typed in an otherwise empty
line to the same column as the matching preceding opening brace “{” if
the opening brace is the only character in its line.

For example:

//

hkhkkhkkhkkhkhkhhhhhhhhhhkhkkkkkkkkkkkkkkkkkkkkk*
// EXAMPLE.C

Rk b o b S R Rk O kb R R R R O R

#include <PIC16C84.H>
void delay (void) ;
void main (void)
{
unsigned int 1i,3;
TRISB = Oxff;
PORTB = 0;
i = 0x1;

© 2001 Microchip Technology Inc.
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while (1)
{
PORTB = 1i;
if (i == 0x80)
i = 0x1;
else
1 <<= 1;
TRISB = 0;
delay () ;
TRISB = Oxff;
delay () ;
}
}
void delay (void)
{
int x, v;
x = 0x3f;
y = Oxff;
while (x--)
{
while (y--)
NOP () ;
}
}
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Chapter 2. Debuggingand MPLAB SIM Simulator

2.1 Introduction

This chapter discusses MPLAB IDE debugging functions and related MPLAB
SIM simulator considerations. You can be in the simulator (MPLAB SIM) or in

emulator mode (MPLAB ICE 2000 in-circuit emulator, PICMASTER®
emulator, ICEPIC, or MPLAB ICD) to access debugging functions. Refer to
the MPLAB ICE In-Circuit Emulator User’s Guide (DS51159) for information
on debugging using the MPLAB ICE 2000 emulator.

2.2 Highlights

This chapter covers the following information:

-
@
3

Q

MPLAB IDE Debugging Functions
Real-Time Program Execution
MPLAB SIM Simulator Environment
Simulator Considerations
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Break and Trace Points
Conditional Break Dialog
Stimulus Functions
Simulator Issues:

12-Bit Core Device
14-Bit Core Device
16-Bit Core Device
- Enhanced 16-Bit Core Device

2.3 MPLAB IDE Debugging Functions

After setting up and compiling projects in MPLAB IDE, you'll want to see how
your code runs. If you have a device programmer, you can program a
microcontroller device and plug the programmed device into your application
to verify that the application runs as expected. Usually, an application will not
run correctly the first time, and you'll have to debug the code. You can use
MPLAB SIM simulator to simulate your code or you can use the MPLAB ICE
2000 emulator to run your firmware in the application while you debug.

Either way, you will use break and trace points as you run your code. Look at
register values in the Register window or Special Function Register window to
see the processor's state as you run and single-step your code.
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The MPLAB ICE 2000 emulator runs code at the actual execution speed
(real-time) on your target hardware, stopping only at specified break points.
MPLAB SIM simulates the execution of any PICmicro microcontroller (MCU)
and simulates 1/0 conditions at speeds that depend on the speed of your PC.

The following debug functions work the same with the simulator or the
emulator. The main functions are:

e Emulation Memory (Program Memory Window)
* Break and Trace Points
¢ Single-Stepping

* Register Monitoring (Special Function Register or File Register
Windows)

All of these functions use information from an MPLAB IDE project. Line labels
in source code, symbolic locations in memory, and function names from code
can be used to set break and trace points and to examine and modify
registers.

2.4 Real-Time Program Execution

241

In this document the term “real-time” is usually applicable only to the
emulators (ICEs) or in-circuit debuggers (ICDs).

Execution in MPLAB SIM Simulator Mode

When the system is said to be running in real-time in the simulator mode,
instructions are executing as quickly as possible by the PC’s CPU. This is
usually slower than the actual PICmicro MCU would run at its rated clock
speed.

The speed at which the simulator runs depends on the speed of your
computer and the number of other tasks running in the background. The
software simulator must update all of the simulated registers and RAM,
monitor I/O, set and clear flags, check for break and trace points in software,
and simulate the PICmicro MCU instruction with instructions being executed
on your computer's CPU.

Note: Often loops are used in code to generate timing delays. When
using the simulator, you might wish to decrease these time delays
or conditionally remove those sections of your code with “IFDEF”
statements to increase simulation speed.

In general when this manual says “real-time” and you are in the simulator
mode, this means that the software simulation is executing simulated
PICmicro MCU code as fast as your PC can simulate the instructions.
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2.4.2 Animate Mode

Animate Mode is a method of automatically single-stepping the processor.
The simulator actually executes single steps while in Run mode, but it only
updates the values of the registers when it is halted. To view the changing
registers in the Special Function Register window or the Watch windows, use
Animate mode. Animate mode runs slower than the Run function, but allows
you to view changing register values.

2.5 MPLAB SIM Simulator Environment

MPLAB SIM simulator is a discrete-event simulator for the PICmicro MCU
families and is integrated into MPLAB IDE. The MPLAB SIM simulator tool is
designed to:

¢ Model operation of Microchip Technology's PICmicro MCU, e.g.,
PIC12CXXX, PIC14000, PIC16C5X, PIC16CXXX, PIC17CXXX, and
PIC18CXXX.

* Assist users in debugging software that uses Microchip PICmicro MCU
devices.
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A discrete-event simulator, as opposed to an in-circuit emulator (like MPLAB
ICE 2000) is designed to debug software. MPLAB SIM simulator allows you to
modify object code and immediately reexecute, inject external stimuli to the
simulated processor, and trace the execution of the object code. A simulator
differs from an in-circuit emulator in three important areas:

¢ 1/O timing
¢ Execution speed
e Cost

2.5.1 I/0 Timing

External timing in MPLAB SIM simulator is processed only once during each
instruction cycle. Transient signals, such as a spikes on MCLR smaller than an
instruction cycle, will not be simulated but may be caught by an in-circuit
emulator.

Note: Stimulus is injected into MPLAB SIM simulator prior to the next
instruction cycle.

2.5.2 Execution Speed

The execution speed of a discrete-event software simulator is orders of
magnitude less than a hardware oriented solution. Users may view slower
execution speed as a handicap or as a tool. MPLAB SIM simulator attempts to
provide the fastest possible simulation cycle, and depending upon the mode
of operation, can operate on the order of milliseconds per instruction.
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2.5.3

254

Cost

Microchip Technology has developed the MPLAB SIM simulator to be the
most cost-effective tool for debugging application firmware. The MPLAB SIM
simulator does not require any external hardware to your PC, and in most
respects operates exactly the same as the MPLAB ICE 2000 emulator.
Unless you need to debug your application in real-time on your actual
hardware, the MPLAB SIM simulator can usually be used to find and correct
most coding errors.

Debugging Tool

The MPLAB SIM simulator is particularly suitable for optimizing algorithms.
Unlike some emulators, the simulator makes many internal registers visible
and can provide software tools that are difficult or expensive to implement in a
hardware in-circuit emulator. For the most part, the MPLAB SIM simulator can
be used to fully debug your system unless you run into real-time issues or
peripheral device situations where an in-circuit emulator is required.

2.6 Simulator Considerations

The MPLAB SIM simulator executes on instruction cycle boundaries, and
resolutions shorter than one instruction cycle (Tcy) cannot be simulated. The
MPLAB SIM simulator is a discrete-event simulator where all stimuli are
evaluated, and all responses are generated, at instruction boundaries or Tcy
=4 Tosc, where Tosc is the input clock period. Therefore some physical
events cannot be accurately simulated. These fall into the following
categories:

e Purely asynchronous events
* Events that have periods shorter than one instruction cycle

In summary, the net result of instruction boundary simulation is that all events
get synchronized at instruction boundaries, and events smaller than one
instruction cycle are not recognized.

The following list itemizes the functions and peripherals among the entire
PICmicro MCU family of microcontrollers that are affected by simulation on
instruction cycle boundaries:

¢ Clock pulse inputs smaller than one cycle can not be simulated even
though timer prescalers are capable of accepting clock pulse inputs
smaller than one cycle.

* PWM output pulse resolution less than one cycle is not supported.
* Compares greater than 8 bits are not supported.

¢ In unsynchronized counter mode, clock inputs smaller than one cycle
can not be used.

* The oscillator waveform on RCO/RC1 pins can not be shown.
* MPLAB SIM simulator does not simulate serial I/O.
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2.7 Break and Trace Points

The debug functions affect execution of program instructions based upon the
following elements:

¢ Break Points
¢ Trace Points
¢ Pass Counter Addresses

MPLAB IDE limits the number of named address ranges to a maximum of 16
in each dialog.

Trace points and break points function totally independent of each other, and
you can set them at any program memory location.

The following figures show the dialog boxes for assigning names to address

=
v -
ranges. Access the Break Point Settings dialog through the Debug > Break ; o
Settings menu item, and the Trace Point Settings dialog through the Debug > WS
Trace Settings menu item. E‘Q
m
: Break Point Settings M= E3
Title [break3 | Add
| Asdehess v Guadbier —
Start - |
| Pass Count D et Remove
E"d| j' Remove All |
_v| hieakl START LOOP .
v q break2 25 25 Ml

Cloze

Help

__How |

Figure 2.1: Break Point Settings Dialog

Note: When using the MPLAB ICD, you can only set one break point
address, and no pass count may be set. When using MPLAB ICE
2000, use the Complex Trigger dialog to define any break points
that require a pass counter.
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Title |“E"'::'E=3 | | Addinas v Duaibey Add
Start | j| Pazz Count D Let [ - |
End| j|  Timen A8
o Fimee Prsd Deele Sy Remoxe All |
o Finee Data Deole ek
Dizable All |
_v| g tracel START LOOFP
_v| trace? 25 30 Enable All |
Help |

Figure 2.2: Trace Point Settings Dialog

Note: The Trace Point Settings dialog is not available in MPLAB ICE
2000 or MPLAB ICD. The MPLAB ICE 2000 trace may be config-
ured through the Complex Trigger dialog.

2.71 Real-Time Break Points

A break point is a condition in which the processor executes code and halts
after a certain condition is met.

Note: If execution doesn’t halt at the break point, select Options > Devel-
opment Mode and click the Break Options tab. Make sure that
Global Break Enable is selected (check marked).

MPLAB IDE provides the following ways to set a break point:
¢ Break on Address Match
Break on Trace Buffer Full

Break on Pass Count Reached

Break on Stack Overflow

Break on Watchdog Timer Time-out
User Halt
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The Program Memory Window shown in Figure 2.3 shows the following
information:

B Break Points
T Trace Points
Q Pass Counter Addresses
Program Memory Window [_ [O] x|
82 851 o128 movwf Bx2ZA -
83 8852 pam movlw Bx1
84 8853 @121 movwf  Bx21
85 8854 Boov movlwy Bx7
86 885 @122 movuwE  8x22
87 8856 EB5A Loop call Reduce
88 8e57 1722 decfsz 8x22 =
89 Be58 CO56 goto  Loop U
00 AB5Q CASA goto  Start ;
o1 B... BA5A 1D21 Reduce swapf 8x21 —
92 Baas5B  1C21 swapf B8x21,W Eg
oy apsD 6528 subwf Bx2Z8 rUrl
95 BBS5E EBLE call Double
96 BO5F BG6O0 retlw Bx0
97 8868 1D21 Double swapf 8x21
98 a@61  1C21 swapf B8x21,W
99 8e62 1D21 swapf Bx21
188 8863 8r21 addwf 8x21
181 8864 B6O8 retlw 8x8
182 8865 FFFF call B8x1FFF
183 8866 FFFF call B8x1FFF
184 8867 FFFF call B8x1FFF
185 BB68 FFFF call Bx1FFF
186 BB6e?  FFFF call Bx1FFF
187 BB6A  FFFF call Bx1FFF
188 BB6B  FFFF call Bx1FFF
189 BB6C  FFFF call Bx1FFF -
1| | aw

Figure 2.3: Program Memory Window
2.7.1.1 Break On Address Match

Break on Address Match allows you to halt the processor when the processor
program counter equals a certain value. The processor breaks before the
valid instruction is executed. For example, if a break point is set at address
5Ah, then the processor breaks before executing the instruction at address
5Ah.

2.7.1.2 Break On Trace Buffer Full

MPLAB IDE can be set to halt the processor after capturing 8K selected
cycles (when the trace buffer is full).
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2.7.2

2.7.1.3 Break On Pass Counter Equal to Predefined Value

MPLAB IDE has a Pass Counter switch that you can assign to either trace
logic or break logic. The Pass Counter can be used to break or trace after the
processor executes an address a predefined number of times.

For example, if the Pass Counter is assigned to break logic, then when the
pass counter decrements to zero, the Pass Counter acts as a break point and
halts the processor.

2.7.1.4 Break On Stack Overflow

Break on Stack Overflow causes MPLAB IDE to execute a break when the
stack overflows.

2.7.1.5 Break On Watchdog Timer

If enabled, MPLAB IDE executes a break when a Watchdog Timer time-out
generates a device RESET.

2.7.1.6 User Halt

MPLAB IDE provides three ways to stop at a break point any time the
processor is running:

e Click Debug > Run > Halt.
* Click F5.
* Click the Halt Icon (red stop light).

Real-Time Trace Points

A trace is a function that logs program execution. The MPLAB SIM simulator
has an 8K real-time trace buffer that logs addresses and opcodes as they
execute. This circular trace buffer continues logging data after the buffer is
full, losing the oldest data (unless you have selected Break on Trace Buffer
Full in the Break Options tab of the Development Mode dialog).

2.7.21 Circular Trace Buffer

MPLAB IDE continuously captures selected bus cycles into the trace buffer.
The status information captured into the trace buffer is grouped as follows:
* 16 Bits of Address
¢ 16 Bits of Opcode/Data
¢ Time Stamp and Changed Registers
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Trace Memory Window M= E3
1 CALL Reduce ; Perform the inner portion of 117668 . 00us a |
2 8856 EBSA op call Reduce ; 117688.680us 58804 |
3 DECFSZ OuterLoop,f ; the loop. 117612.00us
4 pes7 1722 decfsz Bx22 ; 117612.80us 58806 |[ 57 ]
5 GOTOD Loop 117642 . 08us
6 BO58 CO56 goto Loop ; 117642 .00us 58821 |22:61 04:]
7 CALL Reduce Perform the inner portion of 117646 . B0us
8 6056 EO5A Loop call Reduce ; 117646.00us 58823 |
9 DECFSZ OuterLoop,f ; the loop. 1176508, 8Bus
18 o7 1722 decfsz Ox22 ; 117650.080us 58825 |[ 57 ]
11 GOTOD Loop 117682 . 00us
12 BB58 CA56 goto Loop ; 117682 _80us 58841 |22:80 B4:]
13 GALL Reduce Perform the inner portion of 117686 . 80us
14 86856 EB5A op call Reduce ; 117686.080us 58843 |
15 DECFSZ2 OuterLoop,f ; the loop. | 117688 . B0us
16 86857 1722 decfsz Bx22 ; 117688 _00us 58844 |BA:FF
17 GOTO Loop 117690.00us
18 G658 CO56 goto Loop ; 117690.080us 58845 |20:FF B4:|
19 CALL Reduce Perform the inner portion of 117692 . 00us
20 86856 EBSA oop call Reduce ; 117692 _00us 58846 |BA:61
21 DECFSZ OuterLoop,f ; the loop. 117694 . 80us
22 BB57 1722 decfsz Bx22 ; 117694.00us 58847 [21:081 04:]
23 GOTOD Loop 1177062 .00us
24 BOSE CO5H goto  Loop ; 117702.0Bus 58851 |[ 57 ] =
25 CALL Reduce Perform the inner portion of 117732.00us
26 6856 EB5A Loop call Reduce ; 117732.00us 58866 |22:086 04: -U
27 DEGFSZ OuterLoop,f : the loop. 117736 BBus & —c
Al o1 > 0
WS
EQ
I m
Timing,
Address Labe changed registers
Opcode Instruction Data and stack

Figure 2.4: Trace Memory Window

2.7.2.2 Halting Trace from the Toolbar ﬁ

Halt Trace allows you to take a snapshot of the trace buffer and look at the
captured trace without halting the processor. In the toolbar, click Halt Trace to
display a snapshot of the trace buffer without halting the processor. Once the
trace buffer is halted, click Halt Trace again to take another trace snapshot.
2.7.2.3 MPLAB SIM Simulator Trace Display

The trace window can be used to collect executed instructions from the
MPLAB SIM simulator. The trace will show the program memory address,
executed code, time stamp and changes to registers. The time stamp uses

the same data as the MPLAB IDE Stop Watch. You can reset the time stamp
by resetting the Stop Watch.

2.7.3 Assigning a Pass Count to Break or Trace Points

MPLAB IDE’s 16-bit Pass Counter decrements by one on any address match
in program memory.

When the processor is in a Halt state, you can modify the count value for the
pass counter in the Break Point Settings or Trace Point Settings dialog box.
To set up the Pass Counter, first set the desired address ranges, then load the
counter with a desired count value (up to 16 bits). When the counter
decrements to zero, the emulator will halt.
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Note: The pass counter does not automatically reset. You must select Set.

2.7.3.1 Pass Counter Assigned to Break

If the Pass Counter is assigned to Break, the processor halts upon

encountering a break point (either internal or external conditions) or when the

Pass Counter reaches zero.

i Break Point Settings

=101 %]

I
]
X

Title |1 0K_Passzes

Start 500 -
End 500 |

| | Address iz Qualifier

Pazz Count Set |

_+*| Halt_Range 100 200

Remove
Hemowe All
Dizable All
Enable All

Cloze

ui;

Help

Figure 2.5: Break Point Settings Dialog — Pass Counter

Example 2.1: This example shows break points and pass counter
addresses used in the same code (Figure 2.5). Keep in mind that break
points and pass counter addresses are independent of each other.

1. Set up a named break point range from address 100 to 200.

- Type Halt_Range in Title box.
- Type 100 in the Start box and 200 in the End box.
- Click Add to enter the break point.
Set a Pass Counter Address at 500.
- Type 10K_Passes in Title box.
- Type 500 in the Start box and in the End box.
- Click Add to enter the break point.
Load the Pass Counter with a value of 1000.
- Select (click on) the 10K_Passes break point.
- Click on the check box of the now-ungrayed Address is Qualifier.
- Type 1000 in the Pass Count box and click Set.

The processor halts if it executes any instructions within the address range
100 to 200 or after executing 1000 instructions at address 500.
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2.7.3.2 Pass Counter Assigned to Trace

If the Pass Counter is assigned to trace, then the real-time trace buffer does
not capture data until the Pass Counter decrements to zero. When the pass
counter decrements to zero, the trace buffer starts capturing data on valid
cycles.

2.7.3.3 Using Pass Counter to Count Events

The Pass Counter decrements each time an event occurs. You can use this
feature to count the number of times an event happens.

2.8 Conditional Break Dialog

When a conditional break is set, MPLAB IDE halts when the value of a
specified internal register reaches a preset value or condition.

-
@
3

Q

Access the Conditional Break dialog through the Debug > Execute >
Conditional Break menu item.

3dl 9vidin

Conditional Break
* Single Cycles gggg Eggi %DD]:\ caii geguce ~
- oop  Ca =duce
O Lliie Dk D056 E05A cop call  Reduce

| Update Display

Conditions:
Number of Cycles j

Reg[l |
| Trace Data

Add | Hemove Close |

Hemowve all | Help |

Break Settings |

Save Buffer |

Figure 2.6: Conditional Break Dialog

Note: The Conditional Break dialog is not available in MPLAB ICE 2000
or MPLAB ICD development modes. For MPLAB ICE 2000, refer
to the Complex Trigger dialog for this functionality.
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2.8.1 Conditions

MPLAB IDE will stop at a break point in the Conditional Break dialog based on
one of the following conditions:

e User Halt — MPLAB IDE executes until you click the Halt button on the
Conditional Break dialog.

* Number of Cycles — MPLAB IDE halts after the target processor exe-
cutes the specified number of cycles.

* Logic Condition satisfied.

2.8.2 Trace Data

Trace Data allows you to track the value of the registers in the Conditional
Break dialog.

2.8.3 Single Cycle

In the Single Cycle mode, MPLAB IDE single steps the processor until the
condition is met.

2.8.4 Multiple Cycles

In Multiple Cycle mode:

¢ Conditional Break executes instructions in real-time (in the emulator),
halts at user selected break points, checks the specified condition, and
continues executing instructions in real-time. The emulator or simulator
only stops when meeting the specified condition.

* Break points and register conditions are only checked at the break
points you specify in the Break Settings dialog.

2.9 Stimulus Functions

The stimulus generates signals for the simulator. You can set pins high or low,
and inject values directly into registers. The four stimulus modes are:

¢ Asynchronous Stimulus — An interactive dialog to control signals on
input pins

» Stimulus Pin File — The contents of a text file describe signals to input
pins

¢ Stimulus Register File — The contents of a text file are used to set 8-bit
values directly into a register

¢ Clock Stimulus — A regular, programmable, periodic source of stimulus
pulses
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2.9.1 Asynchronous Stimulus Dialog

This stimulus feature provides a dialog button to simulate +5 and 0 volts being
applied to input pins. As your program executes with the simulator, you can
click buttons on this dialog to change levels on pins.

As an example, we’ll set up a signal that will toggle the level on a pin on 1/O
portb of the PIC16F84.

Select Debug > Simulator Stimulus > Asynchronous Stimulus. This dialog will
be displayed:

1 Aspnchronous Stimulus Dialog

TEm AP stim 2 (P) Stim 3 (P) Stim 4 (P)
Stim 5 [P) Stim 6 [P) Stim 7 (P) Stim 8 [P)
Stim9(P) | Stm10(P) | Stm11(P) | Stim12(P)

Cloze I Help I

-
@
3

Q

=
3
L
>
w
)
m

Figure 2.7: Asynchronous Stimulus Dialog

Place the cursor over the button labelled “Stim1 (P)” and click the right mouse
button. A shortcut menu will appear. Scroll down and select Toggle.

Azzign Pin...

Pulze
Lo
High

v Tooggle

Help...

Figure 2.8: Toggle Option

Again put the cursor over the button now labelled “Stim1 (T)” (the “P” was
replaced by a “T,” meaning “Toggle”), click the right mouse button and select
Assign Pin from the shortcut menu.
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2.9.2

A dialog will display a list of pins on the PIC16F84.

Pin Selection B

Double click to select.

MCLR BN
RAD
RA1
RAZ
RA3
RA4

RB1 —

RB2
RB3
RB4 hd

Figure 2.9: Pin Selection

Put the cursor over “RB0” and double-click. The Asynchronous Stimulus
dialog should now look like Figure 2.10. Note that the button now shows “RB0
(T)'!!

1 Asynchronous Stimulug Dialog

REO (T) Stim 2 [P) Stim 3 (P) Stim 4 (P
Stim 5 [P) Stim 6 [P) Stim 7 (P) Stim 8 (P)
Stim9(P) | Stm10(P) | Stm11(P) | Stimi2(P)

Help |

Figure 2.10: Asynchronous Stimulus Dialog — RBO(T)

Choose Debug > Run > Animate to get the processor running in a “fast single
step” mode. The status bar will alternate run to stop very fast.

Click the “RBO (T)” button on the Asynchronous Stimulus dialog. You should
see the value of portb in the Special Function Register window change as you
repeatedly click the button to simulate a high signal then a low signal applied
to portb pin 0.

Pin Stimulus Files

A Pin Stimulus file consists of columns of input ones and zeros that will be
applied to pins when the “Cycle” value in the Stopwatch matches the CYCLE
column.

2.9.2.1 Creating a Pin Stimulus file

1. Select File > New File. An Untitled window will appear on your desktop.
You will create the Pin Stimulus file in this window.
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2. Type the word CYCLE in the first line of the Untitled file window.

Note: For backward compatibility with earlier versions of the simulator,
the first line must always start with the word CYCLE or STEP. The
first column specifies the CYCLE (as determined by MPLAB IDE's
Stopwatch window) where the values in the other columns will be
applied.

3. To the right of the word CYCLE, type the pin name for the PICmicro MCU
pin that will receive the high stimulus value. The third item on the first line
of the file should be the pin to receive the low stimulus value. These
names must match the Microchip PICmicro MCU pin names for the pro-
cessor being simulated. You can add additional columns for additional
pins.

Note: To see a list of supported pins, select Debug > Simulator Stimulus
> Asynchronous and right-click on a stimulus button.
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4. In the remaining lines of the file, type the cycles during which the pins
are to receive the stimuli, followed by the high and low values. You can
put comments on a line using the “” or “I” character preceded and fol-
lowed by at least one space.

5. Select File > Save As... to save your file. Select the drive and folder in
which the file is to be stored, and enter the file name you would like to
assign it. Give the file a . st i extension. Your file is now ready to use.

2.9.2.2 Using a Pin Stimulus file

1. Select Debug > Simulator Stimulus > Pin Stimulus > Enable and select
the appropriate file to enable the pin stimulus file.

2. Open the Stopwatch window by selecting Window > Stopwatch. Also
select Window > Special Function Registers. Watch the port the pins are
on. Or, simply add the port that the pins are on to a Watch window. The
Stopwatch window will show the elapsed time at each instruction, as
determined from the CYCLE value and the clock frequency. If the Stop-
watch is reset to 0, the pin stimulus file will also be effectively reset.

3. Reset and single step. The port will change its value as set in your stim-
ulus file.

2.9.2.3 Pin Stimulus File example

Note: This example assumes that you have completed the simple project
tutorial in Chapter 3.

1. Select File > New File and type in the following text. You do not have to
type in the text after the “;” and “I” comment delimiters, but it is a good
idea to include them in this file.
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CYCLE
20
41
52
55
60
65
76

RB1

O O OFr O

Proorproow

(@)

; apply high to port b bit 1
; apply high to port b bit 0, set bit 1 low

; toggle bit 1, then...
! ...toggle bit 0.

After the word CYCLE in the first line of the file are the pin names for the
PICmicro MCU pins that will receive the high and low stimulus values. In this
example pins RB1 and RBO, two inputs on Port B, will receive stimulus inputs.

Note: For backward compatibility with earlier versions of the simulator,
the first line must always start with the word CYCLE or STEP. The
first column specifies the CYCLE (as determined by MPLAB IDE’s
Stopwatch window) where the values in the other columns will be
applied.

In this file, the second column contains values that will be applied to RB1
(PortB bit 1) and the third column has values for RBO (PortB bit 0). These
names must match the Microchip PICmicro MCU pin names for the processor
being simulated. To see a list of all supported pins, right-click on a stimulus
button and look at the pin assignment pull-down list for the Asynchronous
Stimulus.

2. Select File > Save Asto save as tutor84.sti.

3. Select Debug > Simulator Stimulus > Pin Stimulus > Enable to enable
the pin stimulus file.

Select Pin Stimulus File ]|
File Hame: Directories: | 1] 4 I
|tutur84.sti | | c:\progra™1implab
Cancel |
tutor4_sh = e\ -
[ PROGRA™1 Help |
= MPLAB —
1 EXAMPLE
1 LKR
= 3 TEMPLATE *
Ligt Files of Type: Drnives:
Pin Stimulus (~st) x| | |[E e =]

Figure 2.11: Pin Stimulus Enable
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4. Open the Stopwatch window by selecting Window > Stopwatch. Also
select Window > Special Function Registers. Watch Portb. Or, simply
add Portb to a Watch window.

The Stopwatch window will also show the elapsed time at each instruction,
as determined from the CYCLE value and the clock frequency. If the Stop-
watch is reset to 0, the pin stimulus file will also be effectively reset.

5. Reset and single step until you execute 41 cycles. Portb will change its
value as set in the second line of the stimulus file.

i Stopwatch
Cycl 41
Zero vcles |
—l Time | 8.20 us

Proceszor Frequency | 20.000000 MHz

Help |

Figure 2.12: Stopwatch Window (41 Cycles)
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+| Clear On Reset

Special Function Register Window

SFR Hame Hex Dec Binary Char -
tmra FF 255 11111111 .

pcl a7 7 gaeaei11

option_reg FF 255 11111111

status 1F a1 aae11111

fsr FF 255 11111111

porta 5[5} a gaaAAoan

trisa 1F B h aag11111

portb a2 2 gaaAAp1n

trisb FF 255 11111111

eedata FF 255 11111111

eecond an a appaBoen

eeadr FF 255 11111111

eecon2 an a appaBoen

pclath 5[5} a gaaAAoan

intcon i g] 1 aaepana1

w a9 9 gaeA1061 .

tépre 29 1 aa181081 )

1| | bl

Figure 2.13: Special Function Registers Window
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2.9.3 Register Stimulus Files

A Register Stimulus file consists of a single column of values that will be sent
to a register when the program memory address reaches the location set in
the Register Stimulus Dialog. This is useful for simulating an A/D conversion
operation.

2.9.3.1 Creating a Register Stimulus file

1. Select File > New File. An Untitled window will appear on your desktop.
You will create the Register Stimulus file in this window.

2. In the Untitled window, type the list of values you wish to insert in a reg-
ister. Be sure to type them in the order you wish to have them inserted
into the register.

3. Select File > Save As to save your file. Select the drive and folder in
which the file is to be stored, and enter the file name you would like to
assign it. Give the file a . reg extension.

2.9.3.2 Using a Register Stimulus file

1. Select Debug > Simulator Stimulus > Register Stimulus > Enable to open
the Register Stimulus dialog.

2. Inthe Program Memory Address box, enter the address in the program
where the stimulus values are to be injected.

3. In the Register Address box, select the file register address where the
values are to be injected.

4. Select Window > File Registers to open the File Registers window and
see the effect of your stimulus.

5. Reset and then single step the processor. Every time you reach the pro-
gram memory address, the value in the file register at the register
address you specified will change. The list of values in your register stim-
ulus file will be sequentially injected into the selected file register.

After the last value in your Register Stimulus file is injected, the first value
will be used again. The list will cycle as long as the MPLAB SIM simulator
executes.
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2.9.3.3

Register Stimulus example

Note:

This example assumes that you have completed the simple project
tutorial in Chapter 3.

1. Create a new file with File > New File and type in the following list of
numbers:

10
2E
38
41
50
TA
99
A0
FD

2. Select File > Save As to save the file and name it tutors4 .reg. This
file will be used to sequentially inject these values into a register.

3. Select Debug > Simulator Stimulus > Regqister Stimulus > Enable, then
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set "loop" to be the place in the program when values are injected, and
for demonstration purposes let’s inject them into the file register at
address 0x0d. After you set 1oop and 0d in the appropriate boxes, click
Browse to bring up the file dialog, and then select tutors84 . reg as the
register stimulus file.

Regqister Shmulus
Selected File: oK
Program Memory Address: LCancel |

loo
| d | Browse. . |

Register Address:

[od <] Hew

Figure 2.14: Register Stimulus Dialog
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294

4. Select Window > File Registers to open the File Registers window and
see the effect of this stimulus.

File Register Window

geae FF FF o7 1F FF 88 82 -—- FF FF 08 81 19 38 090 @8 j
g818 68 FF FF 68 08 82 80 68 82 24 FF FF 80 88 FE F¥
9828 00 84 FF FF 00 08 FF FF 80 88 FF FF 80 88 BF FF
g838 08 88 FF FF 68 88 FF FD0 80 82 FF FF 80 88 FF FF
ge48 08 88 FF FD 68 8a FF FF 90 68 FF FF 80 88 DF 7F

Al |

Figure 2.15: File Register Window

5. Reset and then single step the processor. Every time you get to loop the
value in the file register at address 0x0D will change. The list of values
in tutors4.reg will be sequentially injected into the selected file reg-
ister. Values of 0x10, 0x2E, etc. will be injected into the register selected
in the Debug > Simulator Stimulus > Register Stimulus dialog every time
loop is executed.

After the last value is injected (0xFD in tutor84 . reg), the first value will
be used again (0x10). The list will cycle as long as the MPLAB SIM simu-
lator executes.

Clock Stimulus

The clock stimulus generates a regular waveform on a pin with a duty cycle
that is specified in terms of the processor clock cycles.

i Clocked Stimulus Dialog
Stimulus Pin: --- Clock Sequence -

RB1 j High: | 3| Low: | 3| _ | Invert
Pin: --- Clock Sequence ---

RED 4H BL

RB1 8H 8L

I Deletel Dpen...l Save...l Cloze | Apply | Help |

Figure 2.16: Clock Stimulus
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Select Debug > Simulator Stimulus > Clock Stimulus and enter clock
sequences for various stimulus clocks in the Clocked Stimulus dialog. These
settings will repeat until you exit MPLAB IDE or delete them using the Clocked
Stimulus dialog.

When you step or run using the settings of Figure 2.16, RBO will be high for 4
clock cycles, then go low for 6 clock cycles. RB1 will go high for 8 clock cycles
then low for 8 clock cycles.

To add a stimulus, select the pin in the Stimulus Pin pull down list, set the high

and low clock sequence, and click Add. m
To delete a stimulus, highlight it by clicking on it and then click Delete.

Buisn
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2.10 12-Bit Core Device Simulator Issues

This section discusses I/O pins, interrupts, registers, peripherals, modes, and
conditions for using 12-Bit Core devices.

2.10.1 12-Bit Core Devices

See the file README . SIM for a list of devices supported by the MPLAB SIM
simulator.

2.10.2 /0 Pins

When modifying pins either manually or via the stimulus file, use the following
pin names only. These are the only ones that the MPLAB SIM simulator

recognizes as valid I/O pins. Because the pinout is device-specific, some pins
(for example RCO on a PIC16C54) are not available on all parts in this family.

* MCLR
TOCKI
RAO-RA3
RBO0-RB7
RCO0-RC7

These pin names can be used in the Modify window (Window > Modify) and in
stimulus files.

2.10.3 CPU Model

2.10.3.1 Reset and Sleep Conditions

All RESET conditions are supported by the MPLAB SIM simulator.

A MCLR Reset during normal operation or during SLEEP can easily be
simulated by driving the MCLR pin low (and then high) via the stimulus file or
by using Debug > Run > Reset.

A WDT Time-out Reset is simulated when WDT is enabled and proper
prescaler is set (by initializing OPTION register appropriately) and WDT
actually overflows. WDT Time-out period (with prescale = 1) is approximated
at 18 ms (to closest instruction cycle multiple).

The Time-out (TO) and Power-down (PD) bits in the Status register reflect
appropriate RESET condition. This feature is useful for simulating various
power-up and time out forks in the user code.
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2.10.3.2 Watchdog Timer

The Watchdog timer is fully simulated in the MPLAB SIM simulator. Because it
is configuration bit-selectable on the device, it must be enabled from the
Configuration tab of the Development Mode dialog, accessed by Options >
Development Mode in the MPLAB SIM simulator. The period of the WDT is
determined by the prescaler settings in the OPTION register. The basic period
(with prescaler = 1) is approximated at 18 ms (to closest instruction cycle
multiple).

2.10.4 Peripherals

Along with providing core support, the TIMERO timer/counter module is fully
supported in both internal and external clock modes. The prescaler is made
readable and writable as the “TOPRE’ symbol.

Note: Because the MPLAB SIM simulator executes on instruction cycle
boundaries, resolutions below 1 Tcy cannot be simulated.
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2.11 14-Bit Core Device Simulator Issues

2.11.1

2.11.2

This section discusses I/O pins, interrupts, registers, peripherals, modes, and
conditions for using 14-Bit Core devices.

14-Bit Core Devices

See the file README . SIM for a list of devices supported by the MPLAB SIM
simulator.

I/0 Pins

The 14-Bit Core devices have I/0O pins multiplexed with other peripherals (and
therefore referred by more than one name). When modifying pins either
manually or via the stimulus file, use the following pin names only. These pin
names are the only ones that the MPLAB SIM simulator recognizes as valid
I/O pins. (Pins are available only as described in the data sheet of the specific
device.)

« MCLR

RAO-RA5
RBO-RB7
RCO0-RC7
RDO-RD7
* REO-RE7

These pin names can be used in the Modify window (Window > Modify) and in
stimulus files.
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2.11.3 Interrupts

The MPLAB SIM simulator supports all interrupts of 14-Bit Core devices.
(Peripherals are available only as described in the data sheet of the particular
device.)

e Timer0 overflow

e Timer1 overflow

¢ Timer2

e CCP1

* CCP2

* SSP (in SPI mode ONLY)

¢ Change on Port RB <7:4 >

e External interrupt from RBO/INT pin
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¢ Parallel Slave Port
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e Comparators

¢ A/D complete
¢ EEPROM write complete

2.11.4 CPU Model

2.11.4.1 Reset Conditions

All RESET conditions are supported by the MPLAB SIM simulator.

A MCLR Reset during normal operation or during SLEEP can easily be
simulated by driving the MCLR pin low (and then high) via the stimulus file or
by using MPLAB IDE Debug > Run > Reset.

The Time-out (ﬁ) and Power-down (ﬁ) bits in the Status register reflect
appropriate RESET condition. This feature is useful for simulating various
power-up and time-out forks in the user code.

2.11.4.2 Sleep

The MPLAB SIM simulator simulates the SLEEP instruction, and will appear
“asleep” until a wake-up from sleep condition occurs. For example, if the
Watchdog timer has been enabled, it will wake up the processor from sleep
when it times out (depending upon the prescaler setting in the OPTION
register).

Another example of a wake-up-from-sleep condition would be Timer1 wake-
up from sleep. In this case, when the processor is asleep, Timer1 would
continue to increment until it overflows. If the interrupt is enabled, the timer
will wake the processor on overflow and branch to the interrupt vector.
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2.11.5

2.11.4.3 Watchdog Timer

The Watchdog timer is fully simulated in the MPLAB SIM simulator. Because
it is configuration bit-selectable on the device, it must be enabled from the
Configuration tab of the Development Mode dialog, accessed by Options >
Development Mode in the MPLAB SIM simulator. The period of the WDT is
determined by the prescaler settings in the OPTION register. The basic period
(with prescaler = 1) is approximated at 18 ms (to closest instruction cycle
multiple).

Special Registers

To aid in debugging this device, certain items that are normally not
observable have been declared as “special” registers. Prescalers and
postscalers cannot be declared in your code as “registers,” so special labels
appear in the Special Function Registers window.

The following are special symbols that are available for the processors in the
14-bit core family. (Consult the data sheet for the particular device you are
using to see which symbols are implemented.)

e TOPRE — Prescaler for timerQ
T1PRE — Prescaler for timer1
T2PRE — Prescaler for timer2
T2POS — Postscaler for timer2
CCP1PRE — Prescaler for CCP1
SPIPRE — Prescaler for SPI
SSPSR — SSP Shift register
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2.11.6

Peripherals

2.11.6.1 Peripherals supported

Along with providing core support, the following peripheral modules (in
addition to general-purpose 1/0O) are supported. (Consult the data sheet for
the particular device you are using to see which symbols are implemented.)

e TimerQ

e Timer1

¢ Timer2

e CCP1

e CCP2

¢ Parallel Slave Port

e SSP (in SPI Mode only)
e Comparators

e A/D (Limited)
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2.11.6.2 TIMERO

TimerO0 (and the interrupt it can generate on overflow) is fully supported by the
MPLAB SIM simulator, and will increment by the internal or external clock.
Clock input must have a minimum high time of 1 Tcy and a minimum low time
of 1 Tcy due to stimulus requirements. The prescaler for Timer0 is made
accessible as TOPRE.

2.11.6.3 TIMER1

Timer1 in its various modes is supported by the MPLAB SIM simulator, except
when running in counter mode by an external crystal. The MPLAB SIM
simulator supports timer1 interrupts generated on overflow, and interrupts
generated by wake-up from sleep. The prescaler for Timer1 is viewable as
T1PRE in the Special Function Registers window. The external oscillator on
RCO/RC1 is not simulated, but a clock stimulus can be assigned to those pins.

2.11.6.4 TIMER2

Timer2 and the interrupt that can be generated on overflow are fully
supported by the MPLAB SIM simulator, and both the prescaler and
postscaler for Timer2 are viewable as T2PRE and T2POS.

2.11.6.5 CCP1 and CCP2

CAPTURE

The MPLAB SIM simulator fully supports capture and the interrupt generated.
The prescaler for the CCP module is viewable CCP1PRE.

© 2001 Microchip Technology Inc.
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COMPARE

Compare mode, its interrupt, and the special event trigger (resetting Timer1
by CCP1) are supported in this version of the MPLAB SIM simulator.

PWM

PWM output (resolution greater than 1 TcY only) are not supported in this
version of the MPLAB SIM simulator.

2.11.6.6 SSP

The Synchronous Serial Port is supported in SPI™ mode only. The shift
register (SSPSR) can be added to the view screen, observed, and modified.
The MPLAB SIM simulator currently does not support the 1°C™ mode.

2.11.6.7 A/D Converter

All the registers, timing function, and interrupt generation are implemented.
However, the simulator does not load any meaningful value into A/D result
register (ADRES) at the end of a conversion.

2.11.6.8 EEPROM Data Memory

The EEPROM data memory (for PIC16F8X devices) is fully simulated. The
registers and the read/write cycles are fully implemented. The write cycle time
is approximated to 10 ms (to nearest instruction cycle multiple).

The simulator simulates the functions of WRERR and WREN control bits in
the EECONT1 register.
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2.12 16-Bit Core Device Simulator Issues

This section discusses I/O pins, interrupts, registers, peripherals, modes, and
conditions for using 16-Bit Core devices.

2.121 16-Bit Core Devices

See the file README . SIM for a list of devices supported by the MPLAB SIM
simulator.

2.12.2 1/O Pins

The 16-Bit Core devices have I/0O pins multiplexed with other peripherals (and
therefore referred by more than one name). When modifying pins either
manually or via the stimulus file, use the following pin names only. These are
the only ones that the MPLAB SIM simulator recognizes as valid I/O pins:

* MCLR

RAO-RA5
RBO0-RB7
RCO0-RC7
RDO0-RD7
* REO-RE2

These pin names can be used in the Modify window (Window > Modify) and in
stimulus files.
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2.12.3 Interrupts

The MPLAB SIM simulator supports all interrupts on 16-Bit Core devices:

e External interrupt on INT pin

¢ TMRO overflow interrupt

e External interrupt on RAO pin

e Port B input change interrupt

* Timer/Counter1 interrupt

¢ Timer/Counter2 interrupt

¢ Timer/Counter3 interrupt

e Capture1 interrupt

* Capture2 Interrupt
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2.12.4 CPU Model

2.12.4.1 Reset Conditions

All RESET conditions are supported by the MPLAB SIM simulator.

A MCLR Reset during normal operation or during SLEEP can easily be
simulated by driving the MCLR pin low (and then high) via the stimulus file, by
clicking the Reset button on the toolbar or by selecting Debug > Run > Reset.

A WDT Time-out Reset is simulated when the WDT is enabled (Options >
Development Mode dialog, Configuration tab), the proper prescaler is set, and
the WDT actually overflows. WDT time-out period is approximated at 12 ms
(to closest instruction cycle multiple) but can be changed by using the dialog.

The Time out (TO) and Power-Down (PD) bits in the ALUSTA register reflect
appropriate RESET condition. This feature is useful for simulating various
power-up and time-out forks in the user code.

2.12.4.2 Sleep

The MPLAB SIM simulator simulates the SLEEP instruction and will appear
“asleep” until a wake-up from sleep condition occurs. For example, if the
Watchdog timer has been enabled, it will wake up the processor from sleep
when it times out. Another example of a wake-up-from-sleep condition would
be an input change on Port B. If the interrupt is enabled and the GLINTD bit is
set, the processor will wake-up and will resume executing from the instruction
following the SLEEP command. If the GLINTD = 0, the normal interrupt
response will take place.

2.12.4.3 Watchdog Timer

The Watchdog Timer is fully simulated in the MPLAB SIM simulator. Because
it is configuration bit-selectable and configuration bit-configurable on the
device, it must be enabled from the Configuration tab of the Development
Mode dialog, accessed by Options > Development Mode in the MPLAB SIM
simulator. The basic period of the WDT (with prescaler = 1) is approximated
at 12ms (to closest instruction cycle multiple).

2.12.5 Special Registers

To aid in debugging this device, certain items that are normally not
observable have been declared as “special” registers. Prescalers cannot be
declared in user code as “registers,” so the following special symbols are
available in the Special Function Registers window:

e TOPRE (Prescaler for Timer0)
e WDTPRE (Prescaler for WDT)
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2.12.6

Peripherals

2.12.6.1 Peripherals Supported

Along with providing core support, the following peripheral modules (in
addition to general-purpose 1/O) are supported:

e TimerO0 in both internal and external clock modes

e Timer1 and Timer2 (and their respective period registers)
* Timer3

¢ Two Capture Modules

Two PWM Modules

2.12.6.2 TIMERO
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TimerO0 (and the interrupt it can generate on overflow) is fully supported by the
MPLAB SIM simulator, and will increment by the internal or external clock.
Delay from external clock edge to timer increment has also been simulated,
as well as the interrupt latency period. Clock input must have a minimum high
time of 1 Tcy and a minimum low time of 1 Tcy due to the stimulus file
requirements. The prescaler for Timer0 is made accessible as TOPRE. It can
be watched and modified.
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2.12.6.3 TIMER1 and TIMER2

Timer1 and Timer2 in its various modes is fully supported by the MPLAB SIM
simulator. Delay from clock edge to increment (when configured to increment
from rising or falling edge of external clock) is simulated as well as the
interrupt latency periods. Clock input must have a minimum high time of 1 Tcy
and a minimum low time of 1 Tcy due to the stimulus file requirements.

2.12.6.4 TIMERS3 and Capture

The MPLAB SIM simulator fully supports Timer3 and the Capture module in
all of its modes. Delays from clock edge to increment (when configured in
external mode), delay for capture, and interrupt latency periods are fully
supported. Clock input must have a minimum high time of 1 Tcy and a
minimum low time of 1 TCcy due to the stimulus file requirements.

2.12.6.5 PWM

Both PWM outputs are supported (resolution greater than 1 Tcy only) are
supported in this version of the MPLAB SIM simulator.
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2.12.7 Memory Modes

The following memory modes are supported by the MPLAB SIM simulator:
¢ Microcontroller Mode
¢ Extended Microcontroller Mode
¢ Microprocessor Mode

The default is Microcontroller mode. If you would like to use any of the other
modes, you must use the Configuration tab of the Development Mode dialog,
accessed by Options > Development Mode in the MPLAB SIM simulator.

The extended memory is only available on PIC17CXXX devices.
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2.13 Enhanced 16-Bit Core Device Simulator Issues

This section discusses I/O pins, interrupts, registers, peripherals, modes, and
conditions for using Enhanced 16-Bit Core devices (PIC18CXXX).

2.13.1 16-Bit Core Devices

See the file README . SIM for a list of devices supported by the MPLAB SIM
simulator.

Note that this family of PICmicro MCU devices has a byte-organized program
memory space rather than word addressed as in the other PICmicro MCU
families. There are some restrictions in the silicon on how the program
memory space can be accessed, especially when using long writes to
program memory. The simulator may not show the same restrictions in all
situations. Consult the data sheet for proper operation.
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2.13.2 /0 Pins

The Enhanced 16-Bit Core devices have I/O pins multiplexed with other
peripherals (and therefore referred to by more than one name). When
modifying pins either manually or via the stimulus file, use the following pin
names only. These are the only ones that the MPLAB SIM simulator
recognizes as valid I/O pins:

« MCLR

RAO-RA5
RBO-RB7
RCO0-RC7
RDO-RD7
* REO-RE2

These pin names can be used in the Modify window (Window > Modify) and in
stimulus files.

3dl 9vidin
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2.13.3

2.13.4

Interrupts

The MPLAB SIM simulator supports all interrupts on Enhanced 16-Bit Core
devices:

e External interrupt on INT pin
¢ TMRO overflow interrupt

e External interrupt on RAO pin
e Port B input change interrupt
* Timer/Counter1 interrupt

* Timer/Counter2 interrupt

» Timer/Counter3 interrupt

e Capture1 interrupt

e Capture2 Interrupt

CPU Model

2.13.4.1 Reset Conditions

All RESET conditions are supported by the MPLAB SIM simulator.

A MCLR Reset during normal operation or during SLEEP can easily be
simulated by driving the MCLR pin low (and then high) via the stimulus file, by
clicking on the Reset button on the toolbar or selecting Debug > Run > Reset.

A WDT Time-out Reset is simulated when the watchdog timer is enabled in
hardware (Options > Development Mode, Configuration tab) or disabled in
hardware and enabled in software through the WDTCON register. When the
Watchdog timer actually overflows during normal operation, the chip will either
Reset and continue execution or will break (Options > Development Mode,
Configuration tab). The Watchdog timer time-out period depends on the
postscaler settings and is approximated at 18 ms (to closest instruction cycle
multiple) when configured with no postscaler.

2.13.4.2 Sleep

The MPLAB SIM simulator simulates the SLEEP instruction and will appear
“asleep” until a wake-up from sleep condition occurs. For example, if the
Watchdog timer has been enabled, it will wake the processor up from sleep
when it times out. Another example of a wake-up-from-sleep condition would
be an input change on Port B. If the interrupt is enabled and the GLINTD bit is
set, the processor will wake-up and will resume executing from the instruction
following the SLEEP command. If the GLINTD = 0, the normal interrupt
response will take place.
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2.13.4.3 Watchdog Timer

The Watchdog timer is fully simulated in the MPLAB SIM simulator. Because
it is configuration bit-selectable and configuration bit-configurable on the
device, it must be enabled from the Configuration tab of the Development
Mode dialog, accessed by Options > Development Mode in the MPLAB SIM
simulator. The basic period of the WDT (with prescaler = 1) is approximated
at 12 ms (to closest instruction cycle multiple).

2.13.5 Special Registers

To aid in debugging this device, certain items that are normally not
observable have been declared as “special” registers. Prescalers cannot be
declared in user code as “registers,” so the following special symbols are
available in the Special Function Registers window:

e TOPRE (Prescaler for Timer0)
* WDTPRE (Prescaler for WDT)
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2.13.6  Peripherals

2.13.6.1 Peripherals Supported

Along with providing core support, the following peripheral modules (in
addition to general-purpose 1/O) are supported:

e TimerO0 in both internal and external clock modes

e Timer1 and Timer2 (and their respective period registers)
e Timer3

¢ Two Capture Modules

¢ Two PWM Modules

The delays are implemented on all peripherals, but the interrupt latency is not.
2.13.6.2 TIMERO

TimerO0 (and the interrupt it can generate on overflow) is fully supported by the
MPLAB SIM simulator, and will increment by the internal or external clock.
Delay from external clock edge to timer increment has also been simulated,
as well as the interrupt latency period. Clock input must have a minimum high
time of 1 Tcy and a minimum low time of 1 Tcy due to the stimulus file
requirements. The prescaler for Timer0 is made accessible as TOPRE. It can
be watched and modified.
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2.13.6.3 TIMER1 and TIMER2

Timer1 and Timer2 in its various modes is fully supported by the MPLAB SIM
simulator. Delays from clock edge to increment (when configured to
increment from rising or falling edge of external clock) is simulated as well as
the interrupt latency periods. Clock input must have a minimum high time of 1
Tcy and a minimum low time of 1 Tcy due to the stimulus file requirements.

2.13.6.4 TIMER3 and Capture

The MPLAB SIM simulator fully supports Timer3 and the Capture module in
all of its modes. Delays from clock edge to increment (when configured in
external mode), delay for capture, and interrupt latency periods are fully
supported. Clock input must have a minimum high time of 1 Tcy and a
minimum low time of 1 Tcy due to the stimulus file requirements.

2.13.6.5 PWM

Both PWM outputs are supported (resolution greater than 1 Tcy only) are
supported in this version of the MPLAB SIM simulator.
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Chapter 1. MPLAB IDE Toolbar and Menu Options

1.1 Introduction

This chapter gives detailed information on using the MPLAB IDE desktop
toolbars and menu options. The chapter organization follows the entries on
the pull-down menus.

1.2 Highlights

This chapter will discuss the following:
* MPLAB IDE Desktop
* File Menu
¢ Project Menu
¢ Edit Menu
¢ Debug Menu
* Programmer Menu
* Options Menu
* Tools Menu
¢ Window Menu
e Help Menu
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1.3 MPLAB IDE Desktop

The MPLAB IDE desktop is a resizable window that operates independently
of the rest of the menu items.

To reduce the size of the MPLAB IDE window on your desktop, click the
Maximize button in the upper right corner of the desktop. To maximize the size
of the MPLAB IDE window again, click the Maximize button again. The next
time you start MPLAB IDE, the MPLAB IDE window will automatically open in
the size you last set it to. When not using MPLAB IDE, you can iconize the
window by clicking the Minimize button. MPLAB IDE will remain in your
computer's memory, but the desktop will be free for you to use.

Figure 1.1 shows a maximized desktop.

— MPLAB [ (O] x|
File  Project Edit Debug PICSTART Plus  Options  Tools  window Help

[=lafa] b ]e]B]a] B

[511.02 ] |PIC1EFa4 Bk On [EQ (4 MHz [User

|pe:0x00  [we0x00 |-~z dce

Figure 1.1: MPLAB IDE Desktop

MPLAB IDE dialog boxes behave as normal Windows applications and allow
you to access standard Windows functions (as well as MPLAB IDE-specific
functions) through the Microsoft Windows system button in the upper left hand
corner. Other standard Windows features include window size buttons, icon
buttons, vertical and horizontal scroll bars, and elevator buttons.

All MPLAB IDE functions are accessible through the menu bar located across
the top of the desktop. MPLAB IDE menus that pull down from the menu bar
allow you to access the emulator functions. Underlined characters on the pull-
down menus are keyboard shortcuts. To use a shortcut, press and hold down
the <Alt> key and press the shortcut key. For example, press and hold down
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1.3.1

the <Alt> key and press <F> to display the file menu. With the File menu
displayed and the <Alt> key still held down, press <O> to display the Open
File dialog.

Toolbars

For your convenience, MPLAB IDE contains four toolbars to provide you with
shortcuts for performing routine tasks. The four toolbars are:

e Edit Toolbar

¢ Debug Toolbar

¢ Project Toolbar

e User Defined Toolbar

Click the button at the far left of the toolbar to display the desired toolbar.
Refer to “Appendix 2: MPLAB IDE Toolbar and Status Bar Definitions” for
complete descriptions of all four toolbars.

The buttons on each toolbar can be reconfigured for your specific needs.
Refer to Section 1.9.5.1.2 for information.

G2 =1 N =Y 6 o i e 2= 4 o ] gl =TS 4

1.3.2

Figure 1.2: MPLAB IDE Debug Toolbar

Status Bar

The figure below shows the status bar (Figure 1.3) that appears at the bottom
of the MPLAB IDE desktop. Refer to “Appendix 2: MPLAB IDE Toolbar and
Status Bar Definitions” for a description of the symbols on the status bar.

[5.11.02 | [ ] | |PIC1EFE4  [pe0<00  |we000 |-~ zdee  [BkOn [ED [4MHz [User |

Figure 1.3: Status Bar
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1.3.3

System Menu

MPLAB IDE provides windows for viewing various information.

Note:
the window.

system window control

A

B watch_1

e ESTOTE
Move
Size

Use the system window control to change how data is displayed in

Minimize

I aximize

Cloze Ctel+F4
MNext Chl+FE

Toagle Line Mumbers

AddWatch...
Delete Watch
Edit Watch...
Save Watch...

Ing
Del

1.4 File Menu

Options under the File menu are:

* New

* Open...

e View...

e Save

e Save As...
e Save All

* Close

* Close All
e Import

e Export

¢ Print

¢ Print Setup
o Exit

(Most-Recently-Used File List)
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1.4.1 New File

The File > New command opens a new, empty window in which you can type.
The window does not initially have a file name. To save the new file’s
contents, select File > Save As.

When the MPLAB Editor creates the window, it applies the set of modes that
are defined for new files.

The tab size and other settings are set for new files in the Editor Modes tab
after selecting Options > Environment Setup.

1.4.2 Open Existing File

To edit one or more existing files, select File > Open. It opens a standard
dialog from which you select the files to edit. If a selected file is already open,
MPLAB Editor activates the window that is currently showing the file.

Open Existing File EE
File name: Folders: -m
I*.c;*.asm o hprogra™ 1 hmplab
Cancel
12c508a. asm - = ;I —l
12c503a2 asm FROGRA™
DEMOET? A5 %E‘ MPLAR Help |
IDASHIE.ASM
IDASMT7 ASM (0 ExAMPLE - -
RULEE ASM £ LkR Read only =
README A5 TEMPLATE - =h
SAMPLE ASM =] = [ Metwark. . | %
List files of pe; Dirives: g
Saource files [*.c;* azm) j I = s j o

Figure 1.4: Open Existing File

1. Use the Drives and Folders list boxes to select the disk drive and the
folder.

2. Select the files you want to open in the File Name list box.

To add multiple single files from the list, hold down the <Ctrl> key and click
on the desired files.

To add a list of files, either hold the <Shift> key and click on the first and
last file in the desired range, or click on the first file and drag down to the
last file.

You can also type the name of the file(s) to open in the File Name field.

3. Ifyou wantto open the files in read only mode, check the Read Only box.
This affects all the files you open in this operation.

4. Click OK to open the files.
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1.4.3

The “List Files of Type” list at lower left allows you to restrict the files shown in
the list to those matching specific filename patterns. For example, “*.ASM” will
list all files with the suffix “.ASM.”

Whether you close the dialog with the OK or the Cancel buttons, MPLAB
Editor makes its current working folder the one in the dialog.

If a file is selected that is already being edited, MPLAB Editor activates the
window showing the file.

View File

The File > View command opens one or more existing files in read only mode.
You can examine their contents, but not alter them. The File > View action is
exactly as if you used the File > Open command and checked the Read Only
box.

View Existing File EHE
File narme: Falders: -m
I*.c;*.asm c:hprogra™1hmplab

Cancel

12ch508a.azm “ ot ;I —l
12ch08a2. azm PROGRA™T

DEMOETT ASHM %E’ MPLAR Help |
IDASHIEASM

IDASM17.A5M 0 EXAMPLE Metwork |
FLILEE A5 CJ LKR i
README.ASM TEMPLATE -

SAMPLE ASM =l c [

Lizt files af type: Dirives:

Source files [*.c;*.asm) j I =N j
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1.4.4 Save File

To save files to disk you have three options:

Select File > Save to save the contents of the current window to disk. The
MPLAB Editor replaces the file with the contents of the current window. If the
current file is unnamed, MPLAB Editor prompts for a new filename. If a file of
the same name exists, MPLAB Editor makes that the backup copy and saves
the current file.

Select File > Save As to save the contents of a file to disk, allowing you to
specify the file name. The MPLAB Editor confirms overwrites of existing files.

1. Use the Drives and Directories list boxes to select the disk drive and the
folder where you want to save the file.

2. Eithertype the name of the file into in the File Name edit control, or select
the name of an existing file you want to overwrite from the list box.

3. Click OK to save the data to the file. If you specify the name of a file that
already exists, MPLAB Editor confirms the overwrite.

4. Use the List Files of Type list at the lower left to restrict the files shown
in the list to those matching specific filename patterns.

Save File As E
File Mame: Directories:
|tulur84.asm | c:wprogra™1implab
Cancel |
IDASM16.ASH - et a %
IDASM17 ASM PROGRA~1
MULEX8.ASM % MPLAR Help | o
README.ASH )
SAMPLE ASM 1 EXAMPLE S
SAMPOBJ ASH £ LER " UNIX format 8
TUTHF#7.ASH — TEMPLATE ~| ¥ Keep back
TUTOR.ASM - | I Keep backup
Lizt Files of Type: Drives: ml
Iﬁuun::e filez [*.c;=.asm] ﬂ I = o j

Select File > Save Allto save all altered files, stores all altered templates into
template files, and saves all altered template files in a single operation.

Note: Clicking Cancel in any of the dialogs that occur in this process can-
cels the entire Save operation.
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1.4.5 Close File

To close the file being shown in the current window, select File > Close.
Select File > Close Allto close all the open files that you're working on.

If you have changed any of the files and haven’t saved the changes to disk,
MPLAB Editor prompts you to save the changes, discard them, or cancel the
entire operation.

1.4.6 Import

The File > Import functions allow you to move data from a PC file to the
emulator and into target memory or into the simulator memory. This function
also allows you to transfer data from the target into emulator memory for
debugging.

1.4.6.1 Import to Memory

Select File > Import > Import to Memory to display the dialog box for selecting
a file to import (download). The file you select is imported to the emulator
memory or simulator memory. The file must be a valid HEX file. If you have a
HEX file (ex; code . hex) ready for programming the PICmicro MCU device,
use this option to load your HEX code into the MPLAB IDE Program Memory
window. The file can be created by building an MPLAB IDE project or my
exporting program memory.

Import Emulation Memory Ei |
File Hame: Directones: | (1] .4 I
= hex | | c:hprogra™~1implab

Cancel |
12ch08a hex - = e\ .
12ch08a2 hex — .
HC552000.HEX %Tg&';ﬁ ! Help |
MPL876.HEX
PIC52010.HEX O EXAMPLE
PSF20100.HEX | 3 LKR
SAMPLE HEX £ TEMPLATE ¥
SEES2010.HEX =
Lizt Filez of Type: Drives:
Hex Files [*_hex] j I = j

Figure 1.5: Import Emulation Memory Dialog
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1.4.6.1.1. PIC17CXXX and PIC18CXXX Devices

If the current target processor belongs to the PIC17CXXX or PIC18CXXX
device family, then the file should be in the Intel extended hex file format
(INHX32). If the object file is successfully imported, then the symbols are
loaded automatically from the file *.COD. The default extension for the object
code file is .HEX.

If you do not have a *.COD file, you may want to turn off source tracking.
Select Options > Environment Setup, click the General tab, and locate the
source tracking setting in the Global Switches section of the dialog.

Note: Use INHX32 if your application addresses memory beyond 64 KB
(32K words for the PIC17CXXX) or contains configuration bit infor-
mation.

1.4.6.1.2. All Other PICmicro® MCU Devices

If the current target processor belongs to a PICmicro MCU family other than
the PIC17CXXX or PIC18CXXX device family, then the file should be in the
Intel 8-bit hex file format (INHX8M) or the Intel extended hex file format
(INHX32). If the object file is successfully imported, then the symbols are
loaded automatically from the corresponding .COD file if it exists. The default
extension for the object code is .HEX.
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1.4.6.2 Import to Target Memory

For PIC17CXXX or PIC18CXXX devices (that support extended memory)
operating with an emulator in either microprocessor or extended
microcontroller mode, you may select off-chip memory from a target board.
Select Options > Development Mode and click the Configuration tab to
access the Processor Mode. Select Options > Development Mode and click
the Memory tab to access Off-Chip Memory.

To import (download) a data file to target memory, select File > Import >
Import to Target Memory to display the dialog box for selecting a file to import
through the emulator to target memory. The file must be a valid HEX file in the
Intel extended hex file format (INHX32). The file can be created by building an
MPLAB IDE project or by exporting program memory.

Import Target Memory E
File Hame: Directories: | oK I
= hex | | c:\progra™1implab

Cancel |
d877 hex D =AY -
pm50017.hex ~q —
psf20100. hex = o Help |
sample_hex {24 mpla
tutor_hex (1 example
tutorB4_hex L3 help -
- L3 oldfirm -
List Files of Type: Drives:
IHEH Files [*.hex] j I = c: j

Figure 1.6: Import Target Memory Dialog (MPLAB ICE 2000)

Downloading data to off-chip memory on a target board does not
automatically update that memory range in the Program Memory window. To
perform this function, use the Window > Modify > Read Range feature. See
Section 1.11.14.
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1.4.7 Export

1.4.7.1 Export Trace Buffer

Select File > Export > Export Trace Buffer to display a dialog box that will
allow you to save the emulator or simulator trace buffer to the selected file.

Note: If you have a full trace buffer with maximum length labels, saving
the trace for the MPLAB ICE 2000 emulator could require over 7
MB. Saving the complete trace buffer as it appears in the Trace
Window (address, data, disassembled code and external logic
probe lines) can exceed 1 MB for the MPLAB SIM simulator.

1.4.7.1.1. MPLAB ICE 2000 Trace Buffer

Save Tab Delimted Trace Data EHE
File name: Folders:
trace._txy c:vprogra~1\mplab

Cancel |
readme. txt - e -
suppork_txt a progra~1
£ mplab &l
[ example
23 help [~ Read only
t lat ¥
e 3 template Hetwork |
Save file as type: Drives:
[Text File (=.TXT) R ET: =l

s
o
—ry
(1}
=
(1}
=)
0
(1

Figure 1.7: Export Trace Buffer Dialog (MPLAB ICE 2000)

File name Type the name of the file into in the File Name box or select the
name of an existing file you want to overwrite from the list.

Save file as Specify the type of file the trace buffer will be saved as. The list
type of files shown will be restricted to those of the type you specify.

Folders Select the folder where you want to save the file.
Drives Select the disk drive where you want to save the file.

OK Click OK to save the data to the file. If you specify the name of
a file that already exists, MPLAB Editor confirms the overwrite.

Cancel Note: Clicking Cancel cancels the entire Save operation.

Read Only Select Read Only if you wish to prevent the file from being
overwritten later.
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1.4.7.1.1. MPLAB SIM Trace Buffer

Save Trace File !EE
File Hame: Directornies:
|fi|el]l]l]l].trc: | | c:\progra~1\mplab

C |
$pfedoz. exe - b e . ﬂ
_mplink_exe ~1 —
_mplinkd.exe %pm?rz — Help |
12c508. Ikr mpla
12ch0Ba.lkr (1 example
12cH09. lkr [C2 help
12ch09a.lkr x (23 template -
Lizt Filez of Type: Drives:
|All Files (=.7) MR ET: =l
Data Range Filter Data

@ All Al

> Range  Dpcode £ Data Only
Start |1 | End |13 |  Addrezzes Only

Figure 1.8: Export Trace Buffer Dialog (MPLAB SIM)

Range Select the range (0 to 8191) of the trace buffer that you
want to save. Enter the desired value for the Start line
number and for the End line number.

Filter Data: All Writes the complete trace buffer to the selected file.
Filter Data: Saves Opcode / Data only (for PIC17CXXX external
Opcode/ read/write cycles). Available only with the MPLAB ICE
Data Only 2000.

Filter Data: Saves Address only.
Address Only
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1.4.7.2 Export Memory

Select File > Export > Export Memory to display the Export Memory dialog
box and export memory contents to a file.

If you have a programmed PICmicro MCU device that you may wish to copy
to other devices later, you can save the device’s program memory by reading
it into MPLAB IDE (using the Read Device option from the device programmer
menu), then exporting the results of the Read to a HEX file using the File >
Export > Export Memory option. Later, you can program another device by
importing the file into MPLAB IDE and using the Program/Verify option from
the device programmer menu.

Note: Alllocations (including the empty locations) in the range you select
when you export will overwrite program memory when you import
later. In contrast, the Build Project process ignores empty locations
when creating a HEX file.

Export Memory

File Hame: Directories: Memory areas:
|‘_hex | c:\progra™1implab | Program memory: V oK
d877.hex =] [& e =] | Start End [1023
pm30017_hex 5] progra™1 +| Configuration bits
psf20100.hex =4 mplab annceI
zample.hex [:Imp a | v| IDs
tutor.hex example
tutor84_hex 21 help v EE'_BHUP_“ LELTE
(1 oldfirm | fadbaon memang ? Help
|1 template o s
o
- + | Output format: oD
- _  Disassembled code 3
List Fll_es of Type: Drives: % Hex file g
Hex Files (*.hex) == 4 mmxaz o inkxes o®

Figure 1.9: Export Memory Dialog

Memory areas Determine which memory areas you want to save in
the build output file.

Program Memory Select to save program memory. Also state the Start
and End address of program memory to save (entire
range is the default).

Configuration Bits Select to save configuration bit settings.
IDs Select to save ID information, if applicable.
EEPROM Memory Select to save EEPROM memory, if applicable.

Calibration Memory Select to save the calibration memory, if applicable.
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1.4.8

Output format Determine the format of the output file.
Disassembled Code Select to save in disassembled code format.

HEX Code Select either hex code format INHX32 or INHX85
(Intel split hex) format.

Print (Ctrl+P)

Select File > Printto print some or all of the current file on your currently
selected printer.

The Print dialog allows you to specify the details of how the file is to be printed
and on which printer.

By default, MPLAB IDE uses the same printer that you specified the last time
you printed a file. The default details of the printing, such as line wrapping,
page headers, tab size, and line numbering are taken from the window edit
modes set on the current window. You can configure both these settings with
the Options > Current Editor Modes menu command.

The dialog box shows the name of the printer that MPLAB IDE is currently
using—if you haven't specified otherwise, this will be your system default
printer.

1.4.8.1 Print Current File Options

Print Current File Ed |

HF Lazerlet 4Y¥/4MY PostSchnpt on
Print O ptions:
+ Whole File v| Humber lines
o Gedesiad Toud _| Wrap long lines
 Line Range _| Page Headers
|| | to | | Setup printer. .. |
(1] Cancel | Help |

Figure 1.10: Print Current File Dialog

Setup Printer Click Setup Printer to change printers, printer font,
or page margins.

Whole File Click Whole File (the default) to print entire file.
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Selected Text Click Selected Text to print only the text that is
highlighted. This option is available only if you have
text highlighted.

Line Range Click Line Range and fill in the start and end line
numbers to print a range of lines. You can use the
words “start” and “end” to represent the first and last
lines of the file.

Number Lines Select Number Lines to print lines with numbering.

Wrap Long Lines Select Wrap Long Lines to fold lines too long to fit
the page rather than being truncated.

Page Headers Select Page Headers to start each page with a
header giving the file name and other information.

1.4.9 Print Setup

Select File > Print Setup to set up details of the printer that MPLAB IDE will
use, run an individual printer’s setup dialog, and select the font. MPLAB IDE
records the values you set with the Print Setup option for the selected printer.
Thus, you can have different settings for different printers. These values
become the defaults.

T N | 7
—
HP Laseret 4¥/4MV PostScriot on i IIE e 2 o
Microsoft Fax on FAX: 0
QMS 860 Print System on Yhc3-1-p2% Font__. ©
Cancel
Print ophionz 0K
_ | Left Margin | Top Margin
| | Bight Margin | Bottom Margin Help

Figure 1.11: Printer Setup Dialog

File > Print Setup lets you specify:

* Which printer to use
* What page margins are to be applied when you print on this device
e What font to use with this printer
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1.4.10

1.4.11

File > Print Setup also allows you to run the printer's own setup dialog to set
device-specific information.

Available Printers To use a different printer than the one that is high-
lighted in the Available Printers list, scroll the list and
click the left button on the printer name.

Print Options To change the margins used on each page, check
or uncheck the boxes in the Print Options area.

Setup To run the highlighted printer's own setup dialog,
click Setup.

Font To change the printer font that MPLAB IDE will use
for the highlighted printer, click Font.

Because MPLAB IDE is a text editor rather than a word processor, you're
restricted to choosing fixed pitchfonts, where the characters are all the same
width.

If you run your printer's own setup dialog after selecting a font, you may find
that the font is no longer available; some printers offer different fonts in
different operating modes.

Exit (Alt+F4)

Select File > Exit to terminate your MPLAB IDE session.

If any of the files you're working with have changed and you haven’t saved the
changes to disk, MPLAB IDE will prompt you to save each one in turn. You
can choose to save the changes, discard them, or cancel the exit operation.
You will also be prompted to save the current project.

Most-Recently-Used File List

The MPLAB Editor adds the Most-Recently-Used (MRU) Files list to the end
of the File Menu. Whenever you open a file, MPLAB Editor records the file
name in the list, arranging the list so that the files that have been most
recently used appear at the top. Any file in the list can be reopened simply by
clicking on the menu item. This is a user configurable option. See

Section 1.9.5.3.
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1.5 Project Menu

The following options are available on the Project menu:
¢ New Project: Creates a new project
* Open Project: Opens an existing MPLAB IDE project
* Close Project: Closes the currently open MPLAB IDE project
* Save Project: Saves the MPLAB IDE project
e Edit Project: Allows you to adjust many settings, add files, etc.
* Make Project: Builds all changed nodes in the project
¢ Build All: Builds all nodes in the project
¢ Build Node: Builds the selected node

¢ Install Language Tool: Allows you to configure MPLAB IDE to recognize
a language tool

¢ (Most Recently Used Projects): Displays the most recently used
projects

For detailed information on Project menu items, refer to "Chapter 3. Getting
Started with MPLAB IDE — A Tutorial."

s
o
-t
(1}
-
(1}
=)
0
(1

© 2001 Microchip Technology Inc. DS51025E-page 117



MPLAB® IDE User’s Guide

1.6 Edit Menu

1.6.1

General Edit Options

MPLAB Editor inserts text in either insert or strikeover mode. MPLAB Editor
shows the mode as either “INS” or “OVR” on the status bar.

1.6.1.1 Undo - Ctrl+Z

Select Edit > Undo to undo the last edit action. When there is no edit action to
undo, the menu command shows Can’t Undo, and you cannot select the
command.

You can configure the number of recent edit actions that can be undone. See
Section 1.9.5.4.

1.6.1.2 Cut-Cirl+X

Deletes the highlighted text in the current window, placing it on the clipboard.
After this operation, you can paste the deleted text into another MPLAB Editor
window or into another Windows application.

1.6.1.3 Copy - Citrl+C

Copies the highlighted text in the current window onto the clipboard. After this
operation, you can paste the copied text into another MPLAB Editor window
or into another Windows application.

1.6.1.4 Paste — Ctrl+V

Pastes the contents of the clipboard into the current window at the position of
the cursor. You can only perform this operation if the clipboard contains data
in text format. MPLAB Editor does not support pasting of bitmaps or other
clipboard formats.

1.6.1.5 Select All

Highlights the entire contents of the current window.

1.6.1.6 Select Word — Left Mouse Button Double-Click
Double-click the left mouse button to highlight the word that the cursor is on.

1.6.1.7 Delete Line — Ctrl+Shift+K

Deletes the entire line containing the cursor and moves the cursor to the start
of the next line.
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1.6.1.8 Delete EOL - Ctrl+K

Deletes the text from the position of the cursor to the end of the line. If the
cursor is at the start of a line that is completely empty, the next line is moved
up to close the gap.

1.6.1.9 Goto Line - Ctrl+G

Moves the cursor to the start of a specific line.

This menu command allows you to specify either an absolute or a relative line
number.

1.6.1.10 Find -F3

This command searches the current window for the text string using the
search parameters you specify. If there is highlighted text in the current
window, the Find operation uses it as the search string.

To search for text in a window, place the cursor at the start point of the
search, and select Edit > Find.

Find | X]

Find What: |I¥Y ~] |__Find Next I

_ | Match Case Cancel | g

| Select Matching Text Direction T

_ | Extend Selection > Up *+ Down Help | §
(2}
(]

Figure 1.12: Find Dialog

In the Find dialog you can search for special characters by using the escape
sequence for the character. You can use “\n” for carriage returns, “\t” for tabs,
and “\V’ for backslashes.
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1.6.1.11 Replace - F4

This command searches the current window for a text string, and optionally
replaces occurrences with another string. This command lets you specify
search parameters. If there is highlighted text in the current window, the
Replace operation uses it as the search string.

i[5 5
Replace With: Igutu j Replace

Replace All

Undo Last

Cancel

il

Help

Figure 1.13: Replace Dialog

To replace text or special characters in a window, place the cursor at the start
point, and select Edit > Replace. In the Replace dialog you can replace
special characters by using the escape sequence for the character. You can
use “\n” for carriage returns, “\t” for tabs, and “\\” for backslashes.

1.6.1.12 Repeat Find — Shift+F3

To repeat a search without using the Find Dialog, select Edit > Repeat Find.

1.6.1.13 Repeat Replace - Shift+F4

To repeat the last replace operation without prompting for details, select Edit >
Repeat Replace.

DS51025E-page 120

© 2001 Microchip Technology Inc.



MPLAB IDE Toolbar and Menu Options

1.6.1.14 Match Brace - Ctrl+B

MPLAB Editor allows the user to manipulate brace characters such as
brackets and parentheses, which often delimit sections of text or program
sources.

The definition of a brace character varies, depending on the language type
set in a window’s window modes. For C, braces are defined as the characters
that have syntactic meaning — opening braces are { [ or (, and closing
bracesare } 1 or).

For the language type “none,” brace characters are defined as those
commonly used in text or many other languages — opening braces are
{ [ (or<,andclosingbracesare} ] ) or> .

To locate matching braces, place the cursor on one of the braces and use Edit
> Match Brace. The cursor moves to the matching brace, respecting the level
of nesting in the code.

1.6.2 Template Options

1.6.2.1 Attach Template File

The Edit > Template > Attach File command attaches an existing template
(.TPL) file, loading it into memory so the templates within it can be used.
Select the file you wish to attach, and click OK.

X
o
—ry
(1]
Attach Template File EE3 3
=2
File name: Folders: 0K Q
= = ()]
|new.tpl c:progra™1hmplab -
Cancel
= cn ;l —l
= PROGRA™
= MPLAE &I
3 ExaMPLE
£ LKR [ Bead arly
LI £ TEMPLATE ;I Metwork... |
List files af lype: Drrives:
ITemplate files [*.tpl) j I = e j

Figure 1.14: Attach Template File Dialog
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1.6.2.2 Detach Template File

Use the Edit > Template > Detach File command to remove a template file
from memory. Once a template file is detached, you cannot use the templates
it contains.

Select Edit > Template > Detach File, select the template file you wish to
detach, and click OK. You cannot detach the file if you’re editing one of its
individual templates.

Detach Template File |

Attached template files:
c:\progra™1\mplab\new_tpl s 0K
Cancel
~| Help

Figure 1.15: Detach Template File Dialog
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1.6.2.3 Create Template File

The first step in preparing MPLAB IDE templates for application developers’
use is to create the file that will contain the templates.

Use the Edit > Template > Create File command to have MPLAB Editor create
the template (.TPL) file that will contain the individual templates. A template
(*.TPL) file is a binary file that must be created before storing a template.
Supply the filename, drive and folder. Click OK.

If you want this template file to automatically be available for all MPLAB IDE
projects, name the file auto. tpl. The templates in auto.tpl are always
available while you are editing source files in MPLAB IDE.

Create Template File EHE2
F‘I_lfplname: E:C'lxls?u:r;ra”'l Ymplab
I e = ==
See T e |
g E?:MF’LE Metwork. . |
LI (O TEMPLATE LI

Save file as type: Dirives:

Template files [*.tpl) j I BHec j
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o
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(1}
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Figure 1.16: Create Template File Dialog

1.6.2.4 Save Template File

When you edit, create, or delete a template, MPLAB Editor changes a copy of
the template in memory, which will be erased when you exit MPLAB IDE.
These changes are not saved to disk until you use the Edit > Template > Save
File command.

If you attempt to exit MPLAB IDE without saving the template file, you will be
prompted if you wish to save changes to the template (.TPL) file. Answer Yes.
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1.6.2.5 Insert Template

The Edit > Template > Insert command inserts an existing individual template
into a source file so that it can be used in application development. Before you
can insert the template, the file in which it resides must already be attached in
MPLAB IDE (see Section 1.6.2.1).

Position the cursor at the location in your source file where you want to insert
the template text. Select Edit > Template > Insert, select the template file that
contains the template, select the individual template you wish to insert, and
click OK.

Inzert Template

Template Files: Template Hame:
c:Aprogra™1implabinew._tp
c:hprogra™1implab\zam

(1] 4 Cancel Help |

Figure 1.17: Insert Template Dialog
1.6.2.6 Edit Template

To change a template in a template file, use the Template > Edit command,
select the template file and individual template you wish to modify, and click
OK. The template file must already be attached in MPLAB IDE (see
Section 1.6.2.1) in order for you to edit one of the files it contains.

When you select a template, MPLAB Editor places it in an edit window. The
window is the same as for a normal text file, but the caption shows that it is
actually a template. After editing the template use the Edit > Template > Store
command to update the template.

Edit Template

Template Files: Template Hame:

c:Aprogra~1\mplab\new._tpl & ' -

1] 4 Cancel Help ¥

Figure 1.18: Edit Template Dialog
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1.6.2.7 New Template

Once you have created the .TPL file that will contain your templates, create
the source and/or text content for the individual templates. You may wish to
use the MPLAB IDE “canned” templates instead of creating your own from
scratch.

Use the Edit > Template > New command to create a template. MPLAB Editor
opens an edit window whose caption displays that it is a template.

To create your own source, simply type the text in the untitled template
window.

To use one of the MPLAB IDE template files, open the MPLAB IDE template
file in MPLAB\Templates\Code or MPLAB\Templates\Object. Select the
text you wish to copy (or use Edit > Select All), and then copy and paste it into
the untitled template window using the Edit > Copy and Edit > Paste
commands.

You may wish to insert marks into your template to indicate any custom
source code or text that developers will have to complete (see

Section 1.6.2.11). When you are through creating your template, be sure to
save it using the Edit > Template > Store or Edit > Template > Store Template

As commands (see Sections Section 1.6.2.8 and Section 1.6.2.9).
1.6.2.8 Store

Select Edit > Template > Store to store a template in the template file. This
command overwrites the previous version of the template in the template file.

Note: Because the Store command only writes to memory, the changes
will be discarded when you exit MPLAB IDE. To save your template
changes for future use, use Edit > Template > Save File. When you
exit MPLAB IDE, you may be prompted if you wish to save changes
to the template (.TPL) file. Answer Yes.

© 2001 Microchip Technology Inc.
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1.6.2.9 Store As

Once you are through creating the template and inserting marks, use the Edit
> Template > Store As command to store the individual template source
code/text in the template file. You can also use this command to save the
changes to a new individual template file with a different name (for example,
to create a variation of the original template source/text).

Select Edit > Template > Store As, select the template file, specify the
template name, and click OK. If you select the name of an existing template,
this command overwrites the previous template’s contents. MPLAB Editor
confirms before executing this command.

Note: Because the Store As command only writes to memory, the
changes or additions will be destroyed when you exit MPLAB IDE.
To save your template changes for future use, use Edit > Template
> Save File. When you exit MPLAB IDE, you may be prompted if
you wish to save changes to the template (.TPL) file. Answer Yes.

Store Template in Template File |
Template Files: Template Hame:
c:\progra™1implabinew._tpl “||sample2 |

samplet ﬂ

]84 Cancel Help j

Figure 1.19: Store Template Dialog
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1.6.2.10 Delete Template

To delete a template from a template file, use the Edit > Template > Delete
command. Select the template file containing the individual template you wish
to delete, select the individual template, and click OK. The template must
already be attached in MPLAB IDE (see Section 1.6.2.1) in order for you to
select it for deletion.

Note: The Delete command only deletes the template from memory. To
permanently remove the template from the template file, use Edit >
Template > Save File. When you exit MPLAB IDE, you may be
prompted if you wish to save changes to the template (.TPL) file.

Answer Yes.
Delete Template |
Template Filesz: Templates in File:

c:\progra™1 \mplab\new. tpl D -

Delete Cloze

Figure 1.20: Delete Template Dialog
1.6.2.11 Insert Template Mark

While you are creating your template, you may wish to insert marks to indicate
locations where developers will have to customize or insert special code for
their application.

Position the cursor at each location in the template that developers will need
to add their code and select Edit > Template > Insert Mark to insert marks
(<???>) at these locations. These marks will appear in their source file to
facilitate the developers’ work.

1.6.2.12 Find Template Mark

After you have inserted the template as described in Section 1.6.2.5, use the
Edit > Template > Find Mark command to search for template marks. As
described in the previous section, template marks identify locations where
you will want to customize or insert special code for your application. Enter
the desired text in place of each mark.

© 2001 Microchip Technology Inc.
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1.6.3

Text Options

This menu shows a list of text-related commands.

1.6.3.1 Transpose — Ctrl+T

Select Edit > Text > Transpose to transpose the character to the right of the

cursor and the character to the left of the cursor. This command has no effect
if the cursor is positioned at the start or end of a line.

1.6.3.2 Uppercase

Select Edit > Text > Uppercase to change all lowercase characters in the
currently highlighted text to uppercase characters.

1.6.3.3 Lowercase

Select Edit > Text > Lowercase to change all uppercase characters in the
currently highlighted text to lowercase characters.

1.6.3.4 Indent

To indent a single line, place the cursor anywhere within it and select Edit >
Text Indent. The MPLAB Editor moves the entire text of the line to the right by
one tab stop. The MPLAB Editor indents all highlighted lines. If no lines are
highlighted, the MPLAB Editor indents only the line that the cursor is in.

1.6.3.5 Unindent

To un-indent a single line, place the cursor within it and select Edit > Text
Unindent. The MPLAB Editor moves the text left by one tab stop. The MPLAB
Editor does not alter a line that does not start with either a tab or a space.
Lines that do not start with white space are not affected.

DS51025E-page 128

© 2001 Microchip Technology Inc.



MPLAB IDE Toolbar and Menu Options

1.7 Debug Menu

The Debug menu contains all the options you would use when debugging
your code.

1.7.1 Run

The Run menu options allow you to control the execution of your firmware in
the target processor.

1.7.1.1  Run (F9)

Debug > Run > Run takes the processor out of the halt state and puts the
processor into execution until a break point is encountered or until you halt the
processor.

Execution starts at the current program counter (as displayed in the status
bar). The current program counter location is also highlighted in the Program
Memory window. While the processor is running, the Step and Run buttons
are disabled.

1.7.1.2 Reset (F6)

Debug > Run > Reset issues a RESET sequence to the target processor. This
issues a MCLR to reset the Program Counter to the RESET vector. If the
processor is running it will continue running from the RESET vector address.

1.7.1.3  Halt (F5)

Debug > Run > Halt forces the processor into the halt state. The Program
Counter is stopped and the processor status information is updated.
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1.7.1.4 Halt Trace (Shift+F5)

Debug > Run > Halt Trace halts the trace buffer from capturing data but
allows the processor to continue running. Refer to your emulator
documentation for more information on Halt Trace.

1.7.1.5 Animate

Debug > Run > Animate causes the simulator to actually execute single steps
while in run mode, updating the values of the registers as it runs.

Use Animate mode to view the changing registers in the Special Function
Register window or in the Watch windows. Animate mode runs slower than
the Run function, but allows you to view changing register values.
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1.7.1.6 Step (F7)

Debug > Run > Step single steps the processor. This command executes one
processor instruction (single or multiple cycle instructions) and then puts the
processor back into halt state. After execution of one instruction, all the
windows are updated with the current state of the processor. When the
processor runs in real-time, MPLAB IDE ignores the Step button.

1.7.1.7 Step Over (F8)

Select Debug > Run > Step Over to execute the instruction at the current
program counter location. At a call instruction, Step Over executes the called
subroutine, and halts at the address following the call.

1.7.1.8 Update All Registers

Debug > Run > Update All Registers updates all registers for the current
instruction.

1.7.1.9 Change Program Counter

Debug > Run > Change Program Counter allows you to change the current
program counter.

i Change Program Counter

BC jl Change Cloze Help |

Figure 1.21: Change Program Counter Dialog

PC Enter desired Program Counter address.

Change Click Change to change to the new program counter address.
The processor must be halted for the change to take effect.

Close Exits from the Change Program Counter dialog box.
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1.7.2

Execute

The Execute menu options allow you to control the polled execution of your
firmware in the target processor.

1.7.2.1 Execute an Opcode

Select Debug > Execute > Execute an Opcode to execute a single instruction
or a series of instructions without modifying the object code or program
memory. After executing the instruction, you may resume executing from the
current program memory location. Executing an opcode is not like single
stepping through code; executing an opcode doesn’t increment timers, cause
cycle counts to occur, etc.

Note: Two-word instructions in the PIC18CXXX family cannot be exe-
cuted in this manner.

i Execute an Opcode

Opcode jl Execute Closze | Help |

Figure 1.22: Execute an Opcode Dialog

Opcode Enter the instruction as an opcode (in HEX digits) or enter a
symbolic instruction (such as ADDWF 0x19). Click the Opcode
list to display the last eight commands. After executing a com-
mand, MPLAB IDE highlights the command so you can type in a
new instruction. (MPLAB IDE tracks the instructions you enter so
you don't get two copies of the same instruction in the opcode
list.)
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Execute Click Execute to execute an instruction without modifying the
current location of the program counter.

1.7.2.2 Conditional Break

Select Debug > Execute > Conditional Break to display a dialog box that
performs an automated single stepping of the processor. Execution starts
when you click Start and continues until the condition presented in the dialog
is met or until you click Halt.

Note: The Conditional Break dialog is not available in MPLAB ICE 2000
or MPLAB ICD development modes. For MPLAB ICE 2000, refer
to the Complex Trigger dialog for this functionality.

For additional information on conditional breaks, see Section 2.8.
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Conditional Break

 Single Cycles
< Multiple Cycles

0056
056

0056

EDSA
E0SA
EQGA

call
call

Reduce -
Reduce

Loop
Loop

Feduce

| Update Display

Conditions:
MNumber of Cycles j
Reg[| ]
v Trace Data i Stait il Break Settings |
Holt | SayeBuffer |
Add Bemove | Reset | Close |
Bemove all | Help |

Single Cycle

Multiple
Cycles

Update
Display

Conditions

Figure 1.23: Conditional Break Dialog

Checks condition at every instruction. The Single Cycle
option samples conditions after every instruction, allowing
you to catch a particular condition.

Checks condition only at user-defined break points. The
Multiple Cycles option runs at real time except for the halt at
break points. This option allows interrupts to be serviced.

Executes the conditional break but does not update the dis-
assembled code in the window. MPLAB IDE stores the last
1000 lines.

The condition that you set up is tested on any register loca-
tion and an 8-bit constant value that you enter. You can test
for the following conditions:

User Halt When processor is running, click Halt to stop the
processor.

Number of Cycles Enter the number of cycles in the Value
box.

Reqister Value Conditions

RAM Addr Data Value == Equals Value Entered

RAM Addr Data Value < > Not Equals Value Entered

RAM Addr Data Value > Greater Than Value Entered
RAM Addr Data Value < Less Than Value Entered

RAM Addr Data Value >= Greater or Equal Value Entered
RAM Addr Data Value <= Less or Equal Value Entered
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If the tested condition is true, execution stops before exe-
cuting the next instruction. The next instruction in the Pro-
gram Memory window will be highlighted.

Caution: All register values are treated as 8-bit unsigned
values. Therefore, the condition <0 will never be true.

Reg Register Condition. Enter a RAM address location
where you want to test against the data value at that loca-
tion. The location that you enter must be a file register loca-
tion.

Value Enter an 8-bit value in the Value box that you want to
test against.

Trace Data Trace Data samples specific registers at each time the pro-
cessor is halted and displays the register data in the list.

Add, Remove, Edits the list of data variables sampled at each break point.
Remove All

Start Starts execution and continues to execute single steps until
the condition is met or until you press the Halt button.

Halt Halts execution of the Conditional Break.
Reset Resets the processor.

Break Opens the Break Point Settings dialog.
Settings

Save Buffer Opens the Save File dialog to save information from the list g

box in a *.TB file. o
=
(1]
=2

c:\progra~1\mplab\tutor.th [_ (O] x| 8

b396 3FFF addlw Bxff -

8858 BOFF Start movlw BxFF

8851 8128 clru

8852 BaM movlw tmr@

aes3 o1 clru

aesy  BBA7 movlw Bx7

aess @122 clru

8856  EBGA Loop call Reduce

8858 BOFF Start movlw BxFF

ags1 @128 clru

8852 BemM movlw tmr@

aes3 o1 clru

2 oz

Figure 1.24: +.TB File

Close Exits the Conditional Break dialog.
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1.7.3

1.7.4

1.7.5

Simulator Stimulus

MPLAB SIM simulator functions allow you to set up regular clock stimulus
signals and allow the simulator to respond to events from files on your PC.
The files can be written with the MPLAB Editor or any other suitable text editor
or word processor and should be saved in the same folder as the current
project.

Simulator functions are:
¢ Asynchronous Stimulus
e Pin Stimulus
¢ Clock Stimulus
* Register Stimulus
For a detailed discussion of simulator stimulus, see Section 2.9.

Center Debug Location

Select Debug > Center Debug Location to move the current program counter
to the middle of the debugging window.

This function works on the Source Code Window, the Program Memory
Window, and the Absolute Listing Window.

Break Point Settings

Select Debug > Break Settings to set break points and break point qualifiers.

For more functional information on break points, see Section 2.7.

Note: If execution doesn’t halt at the break point, select Options > Devel-
opment Mode and click the Break Options tab. Make sure that
Global Break Enable is selected (check marked).

i Break Point Settings M= B

Title |break3 | _ > Add |
| Askhess w aebier
Start - B |
| J' Pazz Count D Siet —emove

E"d| j' Remove All |
v breakl START LoOP -
| +| q break2 o5 25 Dizable All |

Cloze |
Help |

Figure 1.25: Break Point Settings Dialog
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Operational Notes

¢ If execution doesn’t halt at the break point, select Options>Develop-
ment Mode and click the Break Options tab. Make sure that Global
Break Enable is selected (checkmarked).

¢ When using MPLAB ICD, only one address can be set to a break point
in the Break Point Settings dialog.

* If a software break point is set, then checksums calculated on program
memory at run time will be incorrect. Programmer checksums are not

affected.

¢ Manually resetting the timestamp when using software break points will
cause the timestamp to be incorrect.

1.7.5.1 General Break Point Settings

You can define up to 16 named break point ranges. After entering a break
point title, start address, and end address (optional), click Add to accept the
break point range definition.

1.7.5.2 Saving Break Point Settings

Break points are saved as part of the project.

Title

Start, End

Enter a unique title (up to 32 characters) for each break
point range. MPLAB IDE accepts the underscore character
but does not allow spaces. MPLAB IDE automatically enters
a default, unique title if you choose not to enter a title. The
break point range requires a title.

Enter a Start and End address in HEX or as a label for the
break point range. The address range is restricted to the
valid address range of the target processor. You can enter
the start address and MPLAB IDE will fill in the same end
address for a break point on a single location (rather than a
range).

You can enter the Start and End values as addresses or
labels. If you use labels, MPLAB IDE allows you to modify
the labels by using offsets: “MAIN+2” or “EXECTIMR-10.”
When you use labels and recompile a project (and the label
moves due to the compilation) MPLAB IDE assigns the
break points to the new address range.

You can use an existing break point range item as the start-
ing point for entering a new break point range. Click on a
desired item in the list box. Type in a new title. Then click
Add to accept the defined break point range.

© 2001 Microchip Technology Inc.

DS51025E-page 135

s
o
-t
(1}
-
(1}
=)
0
(1




MPLAB® IDE User’s Guide

Break Point The list box allows you to enter up to 16 break point ranges.
List On selecting a range, the break point Settings dialog box
displays Start, End, and Title to allow you to edit the start
and end address. The list box contains the following ele-
ments:
Title Start End
Enabm/DiS&bb\@ break]l start start
E break3 ReduceADoubleB
(qpnd break 65 65

//ﬂ middle break start+2 loop-2
Qualifier:

Add

Remove

Remove All
Disable All
Enable All

Close

Help

Figure 1.26: Break Point List

Enable/Disable This switch enables/disables the break point
range in program memory.

Qualifier Qualifier point designator. When a range item dis-
plays the letter g, the address range is a Pass Count
address.

Title, Start, End Click an item in the list box to display the
title, start, and end data. You can then edit the start and end
address or change the title to enter a new break point range.

Click Add to accept the selected range and add the range to
the list of ranges. Entering a range enables break points in
that range in program memory. Disabled break point ranges
will not clear break points included in other ranges.

Removes the selected break point range. If an item is not
selected, Remove does nothing.

Removes all break point ranges from the list.
Disables all break point ranges.
Enables all break point ranges.

Accepts your break point ranges and closes the Break Point
Settings dialog.

Displays this information.
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1.7.5.3 Break Point Qualifiers

This function applies only to the PICMASTER Emulator and Simulator
development modes.

1. Select a break point qualifier from the drop-down list.
2. Enter a pass count qualifier for the break point.

MPLAB IDE has a 16-bit Pass Counter that decrements by one on any
address match in program memory.

When the processor is in a Halt state, you can modify the count value in
the Break Point Settings dialog box. To set up the Pass Counter, first set
the desired address ranges and then load the counter with a desired count
value (up to 16 bits). When the counter decrements to zero, the emulator
will halt.

Note: The pass counter does not automatically reset. You must select Set.

The Pass Counter decrements each time an event occurs. You can use
this feature to count the number of times an event happens.

Address is You can assign a Pass Count qualifier address to either
Qualifier break logic or trace logic. You must have an element in the
list selected. With an element selected, the dialog will
enable the Address is Qualifier check box.

When you check Address is Qualifier, you are assigning the
pass counter to all addresses in the selected range. Usually
it is useful to set only a single address for the pass counter.
After selecting Address is Qualifier, MPLAB IDE enables the
Pass Count Edit Box and the Set button. With the Pass
Count Edit Box enabled, you can set the pass counter to a
desired value (up to 65,534).
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Pass Count Type in a pass count value. The pass count value defines
the number of times the program can pass a qualifier
address before halting the processor. Each time the pro-
gram encounters an address that has been set as a quali-
fier, it decrements the pass count. When the pass count
reaches 0, it halts the processor.

Set Click Set to enter a pass count value. The displayed Pass
Count value does not download the value to the emulator’s
pass counter until you click Set.
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1.7.6 Trace Settings

Select Debug > Trace Settings to display the Trace Point Settings dialog box
for defining up to 16 named trace point ranges. The Trace Point Settings
dialog is not available in MPLAB ICE 2000 or MPLAB ICD development
modes.

For more functional information on trace points, see Section 2.7.

Title |“E"::E=3 | | Addebeas v Guaibie Add
Start | j| Pazz Count D Lt Remove |
Em:l| j| @ Fimes A
o Fraon Frst Deole Only Remove All |
o Eiaown Data Dpole Hads
Dizable All |
| q lracel START LOOP
| trace2 25 30 Enable All |
Help |

Figure 1.27: Trace Point Settings Dialog

Note 1: The pass counter qualifier address can be assigned to trace
logic or break logic.

2: The Trace Point Settings dialog is not available in MPLAB ICE
2000 or MPLAB ICD development modes. The MPLAB ICE
2000 trace may be configured through the Complex Trigger dia-
log.

1.7.6.1 General Trace Settings

You can define up to 16 named trace point ranges. After entering a trace point
title, start address, and end address (optional), click Add to accept the trace
point range definition.

Note: MPLAB ICD does not have trace capability.
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1.7.6.2 Saving Trace Point Settings

Trace points are saved as part of the project.

Title

Start, End

Enter a unique title (up to 32 characters) for each trace point
range. MPLAB IDE accepts the underscore character but
does not allow spaces. MPLAB IDE automatically enters a
default, unique title if you choose not to enter a title. The
trace point range requires a title.

Enter a Start and End address in HEX or as a label for the
trace point range. The address range is restricted to the
valid address range of the target processor. You can enter
the start address and MPLAB IDE will fill in the same end
address for a trace point on a single location (rather than a
range).

You can enter the Start and End values as addresses or
labels. If you use labels, MPLAB IDE allows you to modify
the labels by using offsets: “MAIN+2” or “EXECTIMR-10.”
When you use labels and recompile a project (and the label
moves due to the compilation) MPLAB IDE assigns the
trace points to the new address range.

You can use an existing trace point range item as the start-
ing point for entering a new trace point range. Click on a
desired item in the list box. Type in a new title. Then click
Add to accept the defined trace point range.

© 2001 Microchip Technology Inc.
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Trace Point The list box allows you to enter up to 16 trace point ranges.
List On selecting a range, the Trace Settings dialog box displays
Start, End, and Title to allow you to edit the start and end
address. The list box contains the following elements:

Title Start End
Qualifier —La@yracet START Loop
frace? 2% 0

Enable/DisabIe/

Figure 1.28: Trace Point List

Enable/Disable This switch enables/disables the trace point
range in program memory.

Qualifier Qualifier point designator. When a range item dis-
plays the letter g, the address range is a Pass Count
address.

Title, Start, End Click an item in the list box to display the
title, start, and end data. You can then edit the start and end
address or change the title to enter a new trace point range.

Add Click Add to accept the selected range and add the range to
the list of ranges. Entering a range enables trace points in
that range in program memory. Disabled trace point ranges
will not clear trace points included in other ranges.

Remove Removes the selected trace point range. If an item is not
selected, Remove does nothing.

Remove All Removes all trace point ranges from the list.
Disable All Disables all trace point ranges.
Enable All Enables all trace point ranges.

Close Accepts your trace point ranges and closes the Trace Point
Settings dialog.

Help Displays this information.
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1.7.6.3 Trace Point Qualifiers

This function applies only to the PICMASTER Emulator and Simulator
development modes.

1. Select a trace point qualifier from the drop-down list.
2. Enter a pass count qualifier for the trace point.

MPLAB IDE has a 16-bit Pass Counter that decrements by one on any
address match in program memory.

When the processor is in a Halt state, you can modify the count value in
the Trace Point Settings dialog box. To set up the Pass Counter, first set
the desired address ranges and then load the counter with a desired count
value (up to 16 bits). When the counter decrements to zero, the trace will
start.

Note: The pass counter does not automatically reset. You must select Set.

The Pass Counter decrements each time an event occurs. You can use
this feature to count the number of times an event happens.

Address is You can assign a Pass Count qualifier address to either
Qualifier break logic or trace logic. You must have an element in the
list selected. With an element selected, the dialog will
enable the Address is Qualifier check box.

When you check Address is Qualifier, you are assigning the
pass counter to all addresses in the selected range. Usually
it is useful to set only a single address for the pass counter.
After selecting Address is Qualifier, MPLAB IDE enables the
Pass Count Edit Box and the Set button. With the Pass
Count Edit Box enabled, you can set the pass counter to a
desired value (up to 65,534).
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Pass Count Type in a pass count value. The pass count value defines
the number of times the program can pass a qualifier
address before halting the processor. Each time the pro-
gram encounters an address that has been set as a quali-
fier, it decrements the pass count. When the pass count
reaches 0, it halts the processor.

Set Click Set to enter a pass count value. The displayed Pass
Count value does not download the value to the emulator’s
pass counter until you click Set.
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1.7.6.4

Global Trace Point Environment Options

Trace All applies to the PICMASTER emulator and the simulator (MPLAB
SIM). Trace First Cycle Only and Trace Data Cycle Only apply to the
PICMaster emulator only.

Trace All

Trace First
Cycle Only

Trace Data
Cycle Only

Valid for all PICmicro MCU devices. Lets you trace each
enabled trace address location. This option displays the
trace buffer exactly the way the processor fetches and exe-
cutes instructions at each clock cycle.

Valid for all PICmicro MCU devices. Filters cycles from the
trace buffer of all extra forced NOP cycles (or data cycles)
of two-cycle instructions. This allows the trace buffer to dis-
play only the exact instruction flow sequence. Eliminating
extra cycles also conserves valuable trace buffer space and
provides more room to capture meaningful data.

Valid for PIC17CXXX devices only. Captures only the data
cycle (second cycle) of the two-cycle table write (TABLWT)
and table read (TABLRD) instructions. Use this feature to
read an array of tables, or to capture data memory values
from a desired RAM location and table write the values to
an unused program memory location in real-time for debug-
ging purposes.

To save captured data cycles into a file for plotting or analysis, use File >
Export > Export Trace Buffer.

A simulator trace memory buffer looks like Figure 1.29. For information on
emulator display, see the documentation for that emulator.

Trace Memory Window M= E3
1 GALL Reduce H Perform the inner portion of 117688 . 88us <
2 Bp56 EG5A Loop call Reduce ; 117608.00us 58804
3 DECFSZ OuterLoop,f ; the loop. 117612.88us
4 @857 1722 decfsz Bx22 ; 117612 _00us 58806 |[ 57 ]

5 GOTO Loop 117642 .00us
6 6058 CO56 goto Loop ; 117642 _80us 58821 [22:81 64:
7 CALL Reduce H Perform the inner portion of 117646 . 80us
8 8856 EB5A Loop call Reduce ; 117646.88us 58823

9 DECFSZ OuterLoop,f ; the loop. 117650.00us
18 6857 1722 decfsz Bx22 ; 117650.80us 58825 |[ 57 ]

11 GOTO Loop 117682 . 88us
12 058 CO56 goto Loop ; 117682.00us 58841 |22:00 04:
13 CALL Reduce H Perform the inner portion of 117686 . BBus
14 8656 EB5A Loop call Reduce ; 117686.00us 58843

15 DECFSZ OuterLoop,F ; the loop. | 117688 . 80us
16 oe57 1722 decfsz Bx22 ; 117688.00us 58844 |OACFF

17 GOTO Loop 117690.00us
18 86858 C856 qoto Loop ; 117698.88us 58845 |28:FF B4:
19 CALL Reduce H Perform the inner portion of 117692 . 0Bus
20 Be56 E@5A op call Reduce ; 117692.80us 58846 | BA: 01

21 DECFSZ OuterLoop,f ; the loop. 117694 . BBus
22 857 1722 decfsz Bx22 ; 117694.88us 58847 |21:81 B4:
23 GOTO Loop 117782 .080us
24 BOSE COS6 goto  Loop ; 117782_@0us 58851 |[ 57 ]

25 GALL Reduce H Perform the inner portion of 117732 . 88us
26 0856 EO5A Loop call Reduce ; 117732.00us 58866 |22:06 O4:
27 ; the loop.

DECFSZ OuterLoop,f

117736.00us +|
A

Figure 1.29: Trace Memory Window
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1.7.7 Trigger In/Out Settings

Select Debug > Trigger In/Out Settings to set trigger input and output. This
dialog applies to the MPLAB ICE 2000 and PICMASTER emulators.

Trigger InfOut Settings | ]
Trigger Out Source
; ; / oK
> Pulsed on final trigger event
# Pulsed on filtered trace
v| Enable break on external trigger input xcancel
 Rising edge @ OF with intemal Presk
> Falling edge > AND with iInternal Hrenk ? Help

|J Freeze trace buffer on rising edge of trigger input

Figure 1.30: Trigger In/Out Settings Dialog — MPLAB ICE 2000

Trigger InfOut Settings | ]
Trigger Out Source
Seto g on B ; : / oK
o Palsed on Hoal goer svent
@ Puisad on Hlered dnce
v| Enable break on external trigger input xcancel
“ Rising edge “+ OR with Internal Break
~ Falling edge ~ AND with Internal Break ? Help -
(1]
|J Fraeze race buller on rising edgs of ngoer mpu C-Dh
-
1]
=)
(2]
o

Figure 1.31: Trigger In/Out Settings Dialog — PICMASTER Emulator

For more information on setting these emulator options, see either the
MPLAB ICE In-Circuit Emulator User’s Guide (DS51159) or the PICMASTER
User’s Guide (DS51037).
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1.7.8 Trigger Output Points

Select Debug > Trigger Output Points to set trigger output for the
PICMASTER emulator.

+ Trigger Out Point Settings [_ (O] ]

Title [trigger] | Ad

Start | j| Bemove
End | ﬂ| Remowve All

Disable All

Enable All

ML

Close

Help

Figure 1.32: Trigger Out Point Settings Dialog

For more information on setting these emulator options, see the PICMASTER
User’s Guide (DS51037).

1.7.9 Clear All Points

Select Debug > Clear All Points to clear all break and trace points.

Clear All Points |

@ Do pou want to clear all break, trace, and trigger pointz?

Mo |

Figure 1.33: Clear All Points Message Box
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1.7.10

1.7.11

Complex Trigger Settings

Select Debug > Complex Trigger Settings to set a complex trigger for the
MPLAB ICE 2000 emulator.

Complex Trigger Settings =[O
“ Program Memory “ Fetch | Logic Probes |:|
» Data Memory > Yabis Baad @ Finsry by
o Tabbe Wils Pass Counter I:I
Address | j
Opcode | | Load Event... |
| > Symbolic > Binary * Hex Clear Event | Save Event... |
“ Sequential Trigger Position |Center j
> All Events Cycles Traced After Trigger 157334
G
 Time Between Events _| Halt on Trigger Load All |
> Filter Trace _| Halt on Trace Buffer Eull —
v| lgnore FNOP Cycles Elzar Al | e Al |
OK | Apply | | (Trigger Status) Help | Cancel |

Figure 1.34: Complex Trigger Settings Dialog
For more information on setting these emulator options, see the MPLAB ICE
In-Circuit Emulator User’s Guide (DS51159).
Code Coverage

Select Debug > Code Coverage to enable/disable code coverage for the
MPLAB ICE 2000 emulator.

Code Coverage =[O

 Enabled{Reset on Bun
» Enabled{Manual Reset

+ Disabled

OK | Reset | Cancel | Help |

Figure 1.35: Code Coverage Dialog

For more information on setting these emulator options, see the MPLAB ICE
In-Circuit Emulator User’s Guide (DS51159).
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1.7.12  Clear Program Memory (Ctrl+Shift+F2)

Select Debug > Clear Program Memory to set all program memory bits to
one.

Clear Program Memory |

Do you want ta fill all program
memory with 0x3FFF?

o

Figure 1.36: Clear Program Memory Message Box

1.7.13  System Reset (Ctrl+Shift+F3)

Select Debug > System Resetto reset the entire emulator system including
the MPLAB ICE 2000 emulator hardware (if connected), software and the
target processor. System Reset performs the same initialization that is
performed when MPLAB IDE is first entered.

Note 1: To perform a processor Reset (MCLR), select Debug > Run >
Reset.

2: Always power down the emulator pod when changing probes or
processor modules, and then perform a system Reset. If you do
not perform a system Reset, MPLAB IDE will not be properly
configured for the new probe or processor module.
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1.7.14 Power-On-Reset (Ctrl+Shift+F5)

Select Debug > Power-On-Reset to display the Power-On-Reset dialog box
for selecting a POR option.

Power On Reset Emulation |

“* ‘Randomize all BAM Locations:

=+ Fill all BAM Locations with ¥alue

b avi Yakeey

» Yalues from File Select File |

| Power On Hesetl Cancel | Save &sl Help |

Figure 1.37: Power-On-Reset Dialog

Power-On-Reset allows you to fill RAM locations with random or determined
values.

Often, uninitialized registers can lead to a program malfunction that is hard to
track down. POR will simulate the action of randomizing registers when the
application first starts up. If the application misbehaves sometimes, the
Power-On-Reset function may help you isolate the problem.

Note: Power-On-Resetis implemented on a device by tying the MCLR pin
to VDD. The POR does not necessarily reset all SFRs, especially
for the emulator.
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The Power-On-Reset dialog can be used for the following functions:
* Randomize registers that have an unknown value at POR.
* Fill registers with a value, or clear registers.

* Set registers to the POR Condition shown in the Microchip Databook for
the respective part (MPLAB SIM simulator only). The Fill with Value
POR function will not affect the registers that have specifically defined
reset values.

¢ Save current POR values to a file.
¢ Load POR values from a file.

Note: Program memory and break points are undisturbed when using the
POR dialog.
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Randomize

Fill with Value

Last Values

Power-On-Reset

Cancel

Save As

Values from File

Select Randomize to enter random values into registers
that have an unknown value at POR.

Type a fill value in the Enter Value box that you want to
enter into registers at POR.

Select Last Values to enter the last randomized or filled
values into the device at POR.

Click Power-On-Reset to reset and set selected register
values.

Click Cancel to close the Power-On-Reset dialog box
without performing a POR.

Opens a dialog box to enter the name of a file (*.POR) to
save Power-On-Reset settings.

To load data values from a file, click Values from File
and then click Select to open a dialog box to enter the
name of an *.POR file containing values to load at
power-on-reset.
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1.8 Programmer Menu

To select a programmer, open the Select Programmer dialog from the
Options > Programmer Options > Select Programmer menu item. Once you
change programmers, MPLAB IDE will shut down. The programmer change
will take effect when you restart MPLAB IDE. A menu specific to the
programmer you selected will appear on the menu bar.

For more information on the operation of individual programmers, refer to the
documentation for that programmer.

PICSTART Plus Programmer Menu

Enable/Disable Enable or disable the programmer. Once the program-
Programmer mer is enabled, this menu item changes to Disable
Programmer.

Program/Verify Opens the Program/Verify dialog which allows you to
program the device selectively (e.g., program part of
program memory, or only configuration bits) or to verify
that the device was programmed properly.

Read Device Opens the Read Device dialog which allows you to read
the device selectively (e.g., part of program memory, or
only configuration bits of the device).

Blank Check All Checks that the device is completely blank (all bits are
set to a “1”). This will also check that all configuration
bits are set to a “1” (unprogrammed state).

Blank Check OTP This function is intended for use with OTP devices that
come with factory programmed configuration bits.
Before using this function, set the displayed configura-
tion bits to match the factory programmed settings. The
function verifies that all program memory bits are set to
“1” and that the configuration bits match the settings dis-
played in the Configuration Bits window.

s
o
-t
(1}
-
(1}
=)
0
(1

Display Error Log Displays the error log on the screen if any errors occur.
The error log is generated when programming or verifi-
cation results in a mismatch of device data and data in
the Program Memory window and the Programmer Sta-
tus dialog.

Erase Program Sets all bits in the MPLAB IDE Program memory, Cali-
Memory bration memory, and Data memory (if applicable) to “1.”
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Erase
Configuration Bits

Reset
Programmer

Sets all available configuration bits and ID location bits
to “1.” If you then reload your HEX file which has config-
uration data or your project which has configuration bits
defined, these values will change in the Programmer
Status dialog. You can use this to override the values in
your code by selecting this after you have loaded your
HEX file or rebuilt your project.

Resets the PICSTART Plus hardware and reestablishes
RS-232 communications. Use this option if power has
been disconnected from the programmer. This option
does not reset programming information in the Program
Memory window, configuration bits, or IDs.

PRO MATE Programmer Menu

Enable/Disable
Programmer

Program/Verify

Read Device

Blank Check All

Blank Check OTP

Display Error Log

Enable or disable the programmer. Once the program-
mer is enabled, this menu item changes to Disable
Programmer.

Opens the Program/Verify dialog which allows you to
program the data as shown in the Program Memory win-
dow or verify that the data in the device in the

PRO MATE socket matches data in the Program Mem-
ory window. You can select to program or verify only the
program memory or other memory areas on the target
device.

Opens the Read Device dialog which allows you to read
the program and configuration bits of the device. You
can set the program memory range and the other read
options.

Checks that the device is completely blank (all bits are
set to a “1”). This will also check that all configuration
bits set to a “1” (unprogrammed state).

This function is intended for use with OTP devices that
come with factory programmed configuration bits.
Before using this function, set the displayed configura-
tion bits to match the factory programmed settings. The
function verifies that all program memory bits are set to
“1” and that the configuration bits match the settings dis-
played in the Configuration Bits window.

When you have programmed a device or verified a
device, an error window will show you data from mem-
ory in the device that do not match the corresponding
memory in MPLAB IDE.

DS51025E-page 150

© 2001 Microchip Technology Inc.



MPLAB IDE Toolbar and Menu Options

Erase Program Sets all bits in the MPLAB IDE Program memory, Cali-
Memory bration memory, and Data memory (if applicable) to “1.”

Erase Sets all available configuration bits and ID location bits
Configuration Bits 1o “1.” If you then reload your HEX file which has config-
uration data or your project which has configuration bits
defined, these values will change in the Programmer
Status dialog. You can use this to override the values in
your code by selecting this after you have loaded your
HEX file or rebuilt your project.

Reset Voltages Sets VDDMIN, VDDMAX, and VPP to their default values
for the selected device.

Transfer to Transfers device information to the PRO MATE pro-
PRO MATE grammer.

Transfer from Transfers device information from the PRO MATE pro-
PRO MATE grammer.

Generate Generate an SQTP file for device serialization.
SQTP File

Load SQTP File Load an SQTP file from disk.

Download Download the latest version of the operating system to
PRO MATE the programmer.
Operating System
Establish Establishes or reestablishes RS-232 communications

Communications with the device programmer. Use this if power has been
disconnected from the programmer. This does not reset
programming information in the Programmer Status Dia-
log, configuration bits, or IDs.
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1.9 Options Menu

1.9.1

Development Mode Options

Select Options > Development Mode to open a dialog box that allows you to
change settings in the following areas:

* Tools

* Ports

¢ Clock

e Memory

» Configuration
e Power

¢ Pins

¢ Break options

1.9.11 Tools

Select Options > Development Mode and click the Tools tab to change the
current Development Mode setting and select a processor module or device.

Click Details and double-click the highlighted item in the list area to view
complete information on the inherent limitations for your selected device.

If you want to see which device your emulator is currently configured for,
make sure that the correct tool (MPLAB ICE 2000 or PICMASTER emulator)
is selected and click Inquire. The device will appear in the Processor box.

If you would like to save all of the changes you have made in the
Development Mode dialog so far, click Apply.
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Development Mode
Configuration ] Power ] Pins ] Break Options 3
Tools ] Ports ] Clock ] M emory b

~ None (Editor Only) | Processor: [ITs MR SISIE M = |

~ MPLAB-SIM Simulator | [Fyternal crystal ozcillator loading. [«
‘+ MPLAB-ICE Emulator | |Click 'Details’ for additional

information on PIC1GCYY.
» PICMASTER Emulator
MR

~|
 MPLAB-ICD Debugger Inquire | Details__ |
1].4 I Cancel | Apply | Help |

Figure 1.38: Development Mode Dialog

None (Editor Selects the Editor Only mode and displays EO on the Sta-
Only) tus Bar. In Editor Only mode, all emulator and simulator
functions are disabled. You can only edit, compile, and
perform project management operations.
Processor: Selects the processor that you are using for
development.

MPLAB SIM  Selects the MPLAB SIM simulator mode.
Simulator Processor: Selects the processor that you are simulating.

MPLAB ICE Selects the MPLAB ICE 2000 Emulator mode (if con-
Emulator nected) and displays Ice on the Status Bar.
Processor: Selects the processor that you are emulating.
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PICMASTER Selects the PICMASTER Emulator mode (if connected)
Emulator and displays Em on the Status Bar.
Processor: Selects the processor that you are emulating.

ICEPIC Selects the ICEPIC Emulator (if connected).
Emulator Processor: Selects the processor that you are emulating.

MPLAB ICD Selects the MPLAB ICD in-circuit debugger (if connected)
Debugger and displays ICD on the Status Bar.
Processor: Selects the processor that you are debugging.

Cancel Click Cancel to cancel your selection and exit this display.

OK Click OK to accept your selection and exit this display.
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1.9.1.2

Device Ports

Select Options > Development Mode and click the Ports tab to set the port for

current Development Mode tool operation.

If you would like to save all of the changes you have made in the
Development Mode dialog so far, click Apply.

(Development Mode)

Select the port over which the tool will communi-

Port cate with the PC in this development mode. The

items in this box are specific to the development
mode you have selected on the Tools tab of the
Development Mode dialog.

MPLAB ICE 2000 Emulator:

Development Mode E3 |

Configuration ] Power
Tools ] P

. ] Pins

] Memory

LPT Port: LPT1

] Break Options 3
E

_ | Force LPT compatibility mode | Bidirectional Mode

LPT Port Information:

Address Type
LPT1 0378 P5/2
LPT2 0000 MHone
LPT32 0000 Hone

Query Port Lnlul

ok ]

Cancel Apply Help

Figure 1.39: Ports Dialog — MPLAB ICE 2000

LPT Port

Force LPT
Compatibility Mode

Choose the LPT port you will use to communicate
with MPLAB ICE 2000 (e.g., LPT1). The LPT port
is also called the parallel or printer port. We recom-
mend that your LPT port be configured for bidirec-
tional operation (ECP preferred; EPP or PS/2 if no
ECP). This may require changing the LPT configu-
ration in your BIOS.

Check this item to force the MPLAB ICE 2000 to
communicate in compatibility mode rather than the
usual bidirectional mode. The current operational
mode appears to the right of this item.
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LPT Port Information Click Query Port Info to view complete informa-
tion on your PC’s LPT port configuration.

For more information on MPLAB ICE 2000 communications, refer to the
MPLAB ICE In-Circuit Emulator User’s Guide (DS51159).

WARNING Do not select the MPLAB ICE emulator mode if
any other device (e.g., printer, scanner, zip drive)
is installed on the parallel port or permanent
damage to that device may result. See the
MPLAB ICE In-Circuit Emulator User’s Guide
(DS51159) for more details.

PICMASTER Emulator:

Development Mode
Configuration ] Power ] Pins ] Break Options N
Tools : ] Memory b

1/0 Port: 300 =]
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1] 4 I Cancel Apply Help

Figure 1.40: Ports Dialog — PICMASTER Emulator

I/O Port Select the I/O Port address that matches the base
address your PICMASTER PC Interface Card.

For more information on PICMASTER emulator communications, refer to the
PICMASTER User’s Guide (DS51037).
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ICEPIC Emulator:

Development Mode E

Configuration ‘| Power ] Pinz ] Break Options b
1 Clock ] Memory b

Tools

Com Port: coMt =]

Baud R ate: 57600 j

oK I Cancel Apply Help

Figure 1.41: Ports Dialog — ICEPIC Emulator

Com Port Select the Com Port that the ICEPIC emulator is
connected to.

Baud Rate Select the baud rate at which data will travel over the
com port.

For more information on ICEPIC emulator communications, refer to the
ICEPIC User’s Guide (DS511083).
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1.9.1.3 Clock Frequency

Select Options > Development Mode and click the Clock tab to set the clock
frequency. You can set the frequency in MHz, kHz, and Hz. Refer to the
specific device’s data sheet to determine the supported frequency range.

If you would like to save all of the changes you have made in the
Development Mode dialog so far, click Apply.

Development Mode |

Configuration ] Power ] Pinz ] Break Options 3
Tools ] Porks ‘ Clock 'I Memory 4
Oscillator Type:
RC LI' | baw §avget Beard Dok
Deszired Frequency: |4.l]l]l]l]l]l] | # MHz
> kHz
Actual Frequency: | 4 000000 “ Hz

0K I Cancel | Apply I Help |

Figure 1.42: Processor Clock Dialog

1. Select the type of oscillator for an emulation system. The available oscil-
lator selections are dependent on the selected processor.

2. Select Use Target Board Clock if appropriate for your MPLAB ICE 2000
application.

3. Enter the desired frequency and select MHz, kHz, or Hz. Refer to the
specific device's data sheet to determine the supported frequency
range.
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Note: The Actual Frequency is for use with MPLAB ICE 2000 only.

4. Click Apply to accept the new setting.

© 2001 Microchip Technology Inc. DS51025E-page 157



MPLAB® IDE User’s Guide

1.9.1.4 Memory

Select Options > Development Mode and click the Memory tab to set the

memory configuration being used.

Note: This option is not available for all processors.

If you would like to save all of the changes you have made in the
Development Mode dialog so far, click Apply.

Development Mode Ed

Configuration \I Power ] Pinz ] Break Options 4
] Ports ] Clock ] Memory 3

Tools

__| Enable

Memory Mapped Peripheral Range | frieabie s wiites

[ 0] Start Address High Byte [xx00)
[ 0] End Address High Byte (xxFF)

OH-Chip Memory:

< From Target Board

> Supplied by Emulator

OK I Cancel Apply Help

Memory Mapped
Peripheral Range

Off-Chip Memory

Figure 1.43: Memory Dialog

Enable/Disable the memory mapped peripheral range,
and specify the starting and ending high byte address. If
the End Address High Byte is set to OxFF, the program
counter in the MPLAB IDE will get stuck at OxFFFE
while operating in external microcontroller mode. The
highest value that can be entered for the high byte is
OxFE. To recover, change the high byte from OxFF to
OxFE or lower, power the emulator pod off and on, and
select Debug>System Reset.

Select off-chip memory From Target Board or Supplied
By Emulator.

Note: The Processor Mode (Options> Development
Mode, Configuration tab) must be set to Microprocessor
or Extended Microcontroller in order for off-chip memory
to be used.

DS51025E-page 158

© 2001 Microchip Technology Inc.




MPLAB IDE Toolbar and Menu Options

Disable Long Disable/enable long writes. It is possible to use the table
Writes  write instructions to trace values in Data RAM with the
PIC17C42; however, if the table write is to internal mem-
ory, you should select Disable Long Writes. If this is not
selected, then MPLAB IDE will wait for an interrupt to
exit the long write. These table write instructions should
be removed before a device is programmed.

1.9.1.5 Configuration

Select Options > Development Mode and click the Configuration tab to
change the settings for the watchdog timer and processor mode.

If you would like to save all of the changes you have made in the
Development Mode dialog so far, click Apply.

Development Mode |
Tools ] Porks ] Clock ] Memory 3
: Conhiguration ’I Power ] Pins ] Break Options 3
Watch Dog Timer Processor Mode:
<+ Mone s Microcontroller
 WDT Chip Reset Enable  Microprocessor
WY Break Faables  Extended Microcontroller

WDT Postscale:
P A T B

@ o B4 D oxpg 256+ O
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1] I Cancel | Apply Help

Figure 1.44: Configuration Dialog

Watchdog Timer Enable/disable the Watchdog Timer.
None: Disables the Watchdog Timer.
WDT Chip Reset Enable: Resets the processor when
the Watchdog Timer times out.
WDT Break Enable: Halts the processor when the
Watchdog Timer times out.
In addition to setting the Watchdog Timer, be sure to set
the OPTIONS register according to the device’s data
sheet.
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WDT Prescale

Processor Mode

For PIC17CXXX and PIC18CXXX processors: If you are
using the Watchdog Timer, remember to set its pres-
caler. This option is used for selecting the prescaler
value.

For all other processors, the WDT prescaler is set under
software control. For PIC12CXXX, PIC14000 and
PIC16CXXX devices, this is set in the OPTIONS regis-
ter. See your device data sheet for more information.

Select the processor mode, if available for the selected
processor. The processor mode must be set to Micro-
processor or Extended Microcontroller in order for off-
chip memory to be used. Refer to individual data sheets
for more information on each mode.

Microcontroller: Accesses internal program memory
only.

Microprocessor: Accesses external program memory
only.

Extended Microcontroller: Accesses internal and exter-
nal program memory.
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1.9.1.6 Power

Select Options > Development Mode and click the Power tab to set the
processor’s power source and voltage.

If you would like to save all of the changes you have made in the
Development Mode dialog so far, click Apply.

Development Mode |

Tools ] Ports ] Clock ] Memory 3
Configuration ];Puwer Pinsz ] Break Options

Proceszzor Power
<+ From Emulator

 From Target Board

| Low Yoltage Dizabled

1] 4 I Cancel Apply Help |

Figure 1.45: Power Dialog

Processor Power For an emulator system, state whether the proces-
sor gets its power From Emulator or From Target
Board.
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Low Voltage This line indicates whether low voltage is enabled
Enabled/Disabled or disabled. The emulator determines whether low
voltage is enabled or disabled.
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1.9.1.7 Pins

Select Options > Development Mode and click the Pins tab to adjust pin
settings.

If you would like to save all of the changes you have made in the
Development Mode dialog so far, click Apply.

Development Mode |

Tools ] Ports ‘I Clock ‘I Memorny 4
Configuration ‘I Power i Pins ] Break Options b

| MLLE Enablis
| £8P F mawed wih BED

Ok I Cancel | Apply I Help

Figure 1.46: Pins Dialog

MCLR Enable Enable or disable Master Clear.
CCP2 muxed with RB3 Mux CCP2 with RB3 or RB3 as 1/O.

OSC switch enable Enable or disable oscillator switch.

These options are only available for some devices. If they are not available,
they will be grayed-out.
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1.9.1.8 Break Options

Select Options > Development Mode and click the Break Options tab to
change the global break and trace point environment options.

If you would like to save all of the changes you have made in the
Development Mode dialog so far, click Apply.

Development Mode Ed

Tools ] Ports ] Clock ] M emory 3
Configuration ] Power ] Pinz ]EBreak Uptions 1

| Clear Breakpointz on Download
+| Global Break Enable

| Dizable Stack Overflow Warning
+| Ereeze Peripherals On Halt

| Break on Trace Buffer Full

| Stack Overflow Break Enable

1].4 I Cancel Apply Help |

Figure 1.47: Break Options Dialog

The following options apply to all development modes except Editor Only,
except as otherwise indicated.
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Clear Break When selected, removes all break points, trace points, trig-
Points on ger points, and pass count addresses on download to the
Download emulator.

Global Break When selected, enables all break points. If Global Break
Enable Enable is not selected, then all break points are disabled.
Global Break Enable is also available from the Status Bar

Disable Stack When selected, prevents a warning message from appear-
Overflow ing if a stack overflow or underflow occurs. If you want to
Warning see a warning in the event of a stack overflow or underflow,
clear this switch.
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Freeze
Peripherals
on Halt

This option freezes peripherals (timers, ports, PWM, etc.)
on a halt operation. By default, this option is on so that you
will get a true picture of the status. When Freeze Peripher-
als on Halt is on, you can write to a port after a halt, but you
cannot read from the port until you perform a single-step.
You may wish to turn this option off if a peripheral must con-
tinue to run after a halt. This option facilitates troubleshoot-
ing of timers in situations when timers are continuing to get
set/reset and cleared after a halt.

Note: If Freeze Peripherals On Halt is selected, the 1/O port bits in the
SFR or the watch windows will not update when single stepping.

Break on
Trace Buffer
Full

Stack Over-
flow Break
Enable

This option is not available for the MPLAB ICE 2000 or the
ICEPIC emulator.

When selected, causes the processor to halt when the trace
buffer is full. The trace buffer is full when it captures 8K
instructions/cycles. For MPLAB ICE 2000, this function is
available through the Complex Trigger dialog.

When selected, causes the processor to halt as soon as a
stack overflow or underflow occurs. If you do not wish to
stop processing specifically for a stack overflow or under-
flow, clear this switch. The setting of Disable Stack Overflow
Warning determines whether a message will be displayed
due to the overflow or underflow.
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1.9.2 Window Setup

1.9.2.1 Save Setup

Select Options > Window Setup > Save Setup to save the current
configuration to a file. The default extension of the configuration file is *.CFG.

S ave Configuration E3 |

@ Do pou want to zave the cument caonfiguration az the default?

Mo | Cancel |

Figure 1.48: Save Setup as Default Message Box

Save Setup only saves the currently open windows—not the break, trace, and
trigger points.

Yes If you answer Yes to the question, “Do you want to save the cur-
rent configuration as the default?” MPLAB IDE will save the cur-
rent configuration as the default user configuration that MPLAB
IDE loads during start-up.

No If you answer No, MPLAB IDE displays the Save Configuration
dialog box. At this point, enter the name and path where you
want to save the setup.
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Cancel Select Cancel to exit the Save Configuration dialog without sav-
ing.

© 2001 Microchip Technology Inc. DS51025E-page 165



MPLAB® IDE User’s Guide

1.9.3

1.9.2.2 Load Setup

Select Options > Window Setup > Load Setup to load a configuration setup
from a file previously stored by the Options > Window Setup > Save Setup
command. Select the file that you want to read from the dialog box and press
Enter. The default extension of the setup file is *.CFG.

Load Configuration E

File Hame: Directornies: | (0] 4 I
= cfgl | | c:Aprogra™1\mplab
Cancel |
MPLAB.CFG - [= e\ -
SETUP.CFG [ PROGRA™1 Help |
= MPLAB —
CJ EXAMPLE
1 LKR
= £ TEMPLATE e
List Files of Type: Drives:
Config Files [* cfa) =] | = e =]

Figure 1.49: Load Setup Dialog

Note: Setup.cfg is a configuration file used by the PRO MATE Il pro-
grammer when programming Secure Data Product devices. Do not
overwrite this file.

1.9.2.3 Default Configuration

Select Options > Window Setup > Default Configuration, to load the default
user configuration the next time you start MPLAB IDE.

Current Editor Modes

Select Options > Current Editor Modes to configure the editor modes that
apply to the current window.
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Current Editor Modes E

c:\progra™1\mplab\filename. asm

Current wWindow:

Dizplayfinput M

odes: Screen Formatting:

| Auto Indent

| Dverwrite

Current File:

| Strip Trailing Spaces
| Show Line Humbers

L -
Language ([GRSCME -] | o icoders

ing Tab Size | Soft Tab:
_ | Wrap Enabled

Wiap Lolumn

Printing:

_ | Wrap Long Lines

__ | Read Only

| Backup when zaving | No EOLN after last line

114 I Cancel Help

_ | Add Ctil+Z on save

Figure 1.
Display/Input Modes

50: Current Editor Modes Dialog

These settings control how text is displayed in the window and any special
actions MPLAB Editor takes as you type.

Auto Indenting
Strip Trailing Spaces
Show Line Numbers

Overwrite

Language

Indents new lines to the same level as the preced-
ing line.

Removes white space from the end of a line when-
ever you press Enter.

Displays line numbers in the window.

Overwrites the characters under the cursor with the
characters you type. Otherwise MPLAB Editor
inserts characters at the cursor.

Select from this list to associate a language (such
as C or Pascal) with the file type. This associates
certain formatting settings (like indenting) with files
of the type you are setting modes for.
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Screen Formatting

These settings affect tabs and text wrapping.

Tab Size
Soft Tabs

Wrap Enabled
Wrap Column

Printing

Defines the width of a tab character.

Inserts spaces instead of tabs when Soft Tabs is
checked.

To use line wrapping, place a checkmark to the left
of Wrap Enabled. In the Wrap Column box, specify
the column at which you want lines to wrap. Clear
the checkmark if you do not want lines to wrap.

These settings affect how MPLAB Editor prints the file. These settings
become the defaults for the Print File command, but can be overridden at the

time of printing.

Page Headers

Wrap Long Lines

Current File

Prints each page headed with the file name, the
page number and the date.

Wraps lines that are too wide to fit the page to the
next line during printing.

These settings are the file modes that apply to file.

Read Only

Backup When
Saving

Add Ctrl+Z On Save

No EOLN after
last line

1.9.4

Prevents users from saving files of this type.

Makes a backup copy of any existing file of the
same name when you write the file to disk.

Automatically adds a Ctrl+Z character to the end
of the file on disk when it saves the file.

Writes an end-of-line terminator (CR-LF or LF)
after the last character of the last line when it
saves the file.

Reset Editor Modes

Select Options > Reset Editor Modes to reset the modes that apply to the

current window to the default values.
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1.9.5 Environment Setup

Select Options > Environment Setup to open a dialog box that allows you to
change settings in the following areas:

¢ General Options

¢ Project Template Options
* Files

Default Editor Modes
Key Mappings

Colors
1.9.5.1 General Options
When you select Options > Environment Setup and click the General tab, a

dialog displays settings for screen font, toolbar setup, symbol display width,
and global switches.

If you would like to save all of the changes you have made in the Environment
Settings dialog so far, click Apply.

Environment Setup

1 Project ] Files ] Default Editor Modes ] Key Mappings ] Colors ]

Screen Font

“ ANSI > OEM “ System  Other Select. |

Toolbar

/| Enable Layout... |

Position: * Top > Bottom > Left > Right - Float
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Symbol Display Width

Data memory: chars
Program memory: chars

Global Switches

| Status Bar Enable ¢| Track Source Code
| Clear Memory on Download _ | Load Default Configuration

OK I Cancel | Apply Help

Figure 1.51: General Dialog
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1.9.5.1.1. Screen Font

When you select Options > Environment Setup and click the General tab, the
Screen Font area allows you to select a fixed point font for MPLAB IDE
screen displays.

1. Select ANSI, OEM, System or Other in the Screen Font area of the Envi-
ronment Settings dialog.
2. If you select Other, click Select to display the Font dialog.

3. Inthe Font dialog, select the desired screen font, then click OK to return
to the Environment Settings dialog.

If you would like to save all the changes you have made in the Environment
Setup dialog so far, click Apply.

1.9.5.1.2. Toolbar Setup

Select Options > Environment Setup and click the General tab to set up the
MPLAB IDE toolbars.

On this tab you can:

* Select a location for the toolbar on the screen and change other display
settings. Available locations are: Top, Bottom, Left, Right, and Float.

¢ Select the Enable checkmark to have MPLAB IDE display the toolbar.

Click Layout in the General tab of the Environment Setup dialog to display
the Toolbar Setup dialog:

Toolbar
(]IS B3 A i o e B e = e

Toolbar |Edil Toolbar j| Button Button Size
Operation “ Automatic ﬂl
|FileSave ﬂ| i I':‘aldg-e Defaults |

edium
> Small Help |

lcon

BITHAP_2 j‘ Disable Button |

_ | Gap Before Button

Figure 1.52: Toolbar Setup Dialog

From the Toolbar Setup dialog you can:
¢ Add a button to the toolbar or edit an existing button’s operation
* Remove a button from the toolbar
¢ Group toolbar buttons
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Toolbar Selects which toolbar to edit: Edit, Debug, Project, or
User.

Button Selects a toolbar button location. The toolbar has 16
available locations.

Operation Selects the operation that MPLAB IDE will perform for
the selected button location.

Icon Selects a button to display in the selected button loca-
tion.

Disable Button Disables the toolbar button at the selected location on
the toolbar.

Gap Before Button Inserts a small gap before the toolbar button.

Button Size Changes the toolbar button size. Button size options
are: Automatic, Large, Medium, and Small.

Ok Defines the toolbar as currently shown.
Cancel Returns the toolbar to its previous state.

Defaults Restores ALL toolbars to their default settings, undo-
ing any changes you have made to any toolbar.

If you would like to save all the changes you have made in the Environment
Setup dialog so far, click Apply.

Adding and Editing Toolbar Buttons

If you wish to be able to perform an operation from the Toolbar for which there
is no toolbar button (such as FileSave), you can either add a button and
associate it with the desired operation, or modify an existing button.
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1. Select Options > Environment Setup and click the General tab to view
the existing toolbar button setup. Click Layout to display the Toolbar
Setup dialog.

2. Inthe Toolbar drop-down list, select the toolbar to which you wish to add
a button. The toolbar you selected appears in the Toolbar area at the top
of the Toolbar Setup dialog.

3. Inthe Toolbar area at the top of the Toolbar Setup dialog, click the posi-
tion to which you wish to assign the new button.

Note: If there is not currently a red circle with a slash in the position, the
button and operation you select in the following steps will replace
the current button and operation. To preserve the currently
assigned buttons, add the desired button to the right of the cur-
rently assigned buttons. You cannot add a button beyond the 17th
position on the toolbar.
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4. From the Icon drop-down list, select the button you wish to display on the
toolbar.

5. From the Operation drop-down list, select the operation you wish to have
performed when users click on the button (e.g., EditTextindent).

6. Click OK to save your changes (or click Cancel to discard them) and
return to the Environment Setup dialog.

Disabling (Removing) a Toolbar Button

If you do not wish a certain operation to be available from a toolbar you can
disable its toolbar button position. This removes it from the toolbar.

1. Select Options > Environment Setup and click the General tab to view
the existing toolbar button setup. Click Layout to display the Toolbar
Setup dialog.

2. In the Toolbar drop-down list, select the toolbar that contains the button
you wish to disable (remove). The toolbar you selected appears in the
Toolbar area at the top of the Toolbar Setup dialog.

3. Inthe Toolbar area at the top of the Toolbar Setup dialog, click the button
you wish to disable (remove). As you select the toolbar button, the oper-
ation that is performed when the user clicks the button appears in the
Operation drop-down list.

4. Click Disable Button to the right of the Icon drop-down list. A red circle
with a slash appears in the button’s position, replacing the button.

5. Click OK to save your changes (or click Cancel to discard them).

When you return to the MPLAB IDE desktop, the position where the button
was located will be blank.

Grouping the Buttons on a Toolbar

You can group several buttons on a together to make it easier to perform
logically related operations. For example, you may wish to group the file
operation buttons together on the Edit toolbar, and separate the other buttons
from them by a small space. Groups of buttons are separated from other
buttons by a small space on the toolbar.

1. Select Options > Environment Setup and click the General tab to view
the existing toolbar button setup. Click Layout to display the Toolbar
Setup dialog.

2. In the Toolbar drop-down list, select the toolbar you wish to customize.
The toolbar you selected appears in the Toolbar area at the top of the
Toolbar Setup dialog.

3. In the Toolbar area at the top of the Toolbar Setup dialog, click the first
(left most) button in each group, and select Gap Before. Click the
remaining buttons in the group and deselect (clear) Gap Before.

4. Click OK to save your changes (or click Cancel to discard them).
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1.9.5.1.1. Symbol Display Width

When you select Options > Environment Setup and click the General tab, the
Symbol Display Width area allows you to specify how many character spaces
MPLAB IDE allocates when displaying symbolic information.

Register Allows you to select a width of 6 characters wide to 32
Variables characters.

Address Labels Allows you to select a width of 6 characters wide to 32
characters.

1.9.5.1.2. Global Switches

When you select Options > Environment Setup and click the General tab, the
Global Switches area allows you to turn the following user selections on or off:

Status Bar Enable Turns the status bar on and off.

Clear Memory on When selected, this global switch clears memory before
Download MPLAB IDE downloads to the emulator. This function
sets all program memory bits to one.

Load Default When selected, MPLAB IDE loads the default user con-

Configuration figuration at start-up. To change the default window
setup, open the windows you want to load at start-up,
select Options > Window Setup > Save Setup and click
Yes. The MPLAB IDE window setup may contain any
available MPLAB IDE window. MPLAB.CFG is the
default user configuration file.
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Track Source  When selected, MPLAB IDE updates the current line in
Code the source code when single stepping. You may wish to
turn this feature off if you have a *.HEX file, but no
*.COD file.

If you would like to save all the changes you have made in the Environment
Setup dialog so far, click Apply.
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1.9.5.2 Project Template Options

Select Options > Environment Setup and click the Project tab to display and
edit the project language and path default options. The defaults you set here
will be used in new projects you subsequently create. Existing projects will not
be affected.

Note: To change the settings for an individual MPLAB IDE project, select
Project > Edit Project and follow the instructions in Section 1,
Chapter 3: Getting Started with MPLAB IDE — A Tutorial.

If you would like to save all of the changes you have made in the Environment
Settings dialog so far, click Apply.

Environment Setup x|

General ] Pmiect] Files ] Default Editor Modes ] Key Mappings ] Colors ]

Project Template

Default Language Suite: |Micmchip jl
Default Project Type: . Linked < Absolute

Default Include Path: | |

Default Library Path: | |

Default Linker Script Path: | |

Add Hode._
Delete Hode |

Default
Project Nodes:

Project Options

Size of Most Recently Used Projects List: Ijlil

Build Timeout Length: Seconds

114 I Cancel | Apply | Help

Figure 1.53: Project Template Dialog

DS51025E-page 174 © 2001 Microchip Technology Inc.



MPLAB IDE Toolbar and Menu Options

Default Language Suite

Default Project Type

Default Include Path

Default Library Path

Default Linker Script
Path

You can select a Language Tool Suite (e.g.,
assembler, compiler) from the drop-down list at the
top of the Project Templates tab of the Environ-
ment Setup dialog. You may need to install the lan-
guage tools for this suite. You can select a suite
that is not installed on your PC, but the project will
not build.

If you installed your language tool before installing
MPLAB IDE, you must give MPLAB IDE informa-
tion about the language tool in the Install Lan-
guage Tool dialog.

If you selected Microchip as the default language
suite, indicate whether your projects will consist of
multiple linked files or a single, absolute file.

In the Include Path box, enter the path to the
default folder of included project files, e.g., Header
files.

If the include path is not set for an individual
project, Make Project will not be able to find the
include files and will proceed to build the entire
project. The build will be successful since the
assembler/compiler will find the files via the
MCC_INCLUDE variable in the AUTOEXEC.BAT
file. However, this is an inefficient way to make a
project.

In the Library box of the Edit Project dialog, enter
the path to the default project library file folder.
This path may be set only if you have selected the
Linked project type.

In the Linker Script box of the Edit Project dialog,
enter the path to the default folder of project linker
script files. This path may be set only if you have
selected the Linked project type.

Each Path box can contain one or more absolute
or relative paths separated by semicolons. For
example:

c:\mplab\projects\mpproj\include;
c¢:\include\h;..\sys

© 2001 Microchip Technology Inc.
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Default Project Nodes

Size of Most Recently
Used Projects List

Build Timeout Length

Indicate any non-compiled (object, library, and
linker script) nodes you wish to include in your
project template. Click Add Node to specify the
drive, folder and filename of each node you wish to
add. To remove an existing node from your project
template, select the node and click Delete Node.
The folder from which you choose your files
defaults to the project template’s default browse
folder. To select files from a different folder, select
the drive from the Drives drop-down list at the bot-
tom right of the Add Node dialog, double-click the
folder in the Folders hierarchy at the top right of the
Add Node dialog, and be sure that Source Files is
selected in the Show files of type box below the list
of files.

The Size of Most Recently Used Projects List
allows you to select the length of the most recently
used project list at the bottom of the MPLAB IDE
Project menu. When you decrease this value, file
names will be removed from the list. These names
will not be remembered (redisplayed) when you
increase this value later. File names that you use
after you increase this value will appear in this list.
The default size of this list is five.

Set the maximum time allowed for a build. If a build
takes longer than the alotted time, a timeout will
occur and no new HEX file will result.

If Build Timeout is set to “off,” no timeout will occur.
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1.9.5.3 File Options

Select Options>Environment Setup and click the Files tab to set the default
browse folder for MPLAB IDE and adjust the number of files displayed in the
Most Recently Used File List. If you would like to save all of the changes you
have made in the Environment Settings dialog so far, click Apply.

Environment Setup x|

General ] Project ] 1 Default Editor Modes ] Key Mappings ] Colors ]

Default File Browse Directory:
< Last Used [Sticky]
> Project Directory
> Other [Specify]: |E:\PHDEHA"'1 \MPLAB

Size of Most Recently Used Files Lizst: EH
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oK I Cancel | Apply | Help

Figure 1.54: File Options Dialog
1.9.5.3.1. Default File Browse Directory
The Default File Browse Directory is the directory (folder) in which MPLAB

IDE starts a file browse window.

To start from the last location a file was added, select Last Used. If the
directory no longer exists, MPLAB IDE will use the MPLAB IDE directory.

To start in the root of the project directory, select Project Directory. If this
directory doesn’t exist, MPLAB IDE will use the highest parent directory that
exists. If no project is open, MPLAB IDE will use the MPLAB IDE directory.

To specify a directory from which to start browsing, select Other, then enter
the desired directory. This setting defaults to Project Directory.
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1.9.5.3.2. Size of Most Recently Used Files List

The Size of Most Recently Used Files List allows you to select the length of
the most recently used file list at the bottom of the MPLAB IDE File menu.
When you decrease this value, file names will be removed from the list. These
names will not be remembered (redisplayed) when you increase this value
later. File names that you use after you increase this value will appear in this
list. The default size of this list is five.

1.9.5.4 Default Editor Modes

MPLAB Editor associates a set of Window Modes with every edit window for
existing and new files. The modes can be set with the Default Editor Modes
tab from Options > Environment Setup. If you would like to save all of the
changes you have made in the Environment Settings dialog so far, click

Apply.

Environment Setup x|

General ] Project ] Files ] Default Editor Mudes?l Key Mappings ] Colors ]

> File Type < Other Types  Mew files
[elete Tuvpe |

Screen Formatting

Tab Size: _ | Wrap Lines at Column

| Soft Tabs

Dizplay/Input Modes

_ | Auto Indent _ | Show line numbers
| Strip trailing spaces _| Dverwrite

Language m

Printing
_ | Page Headers
_ | Wrap Long Lines

File Modes
| Read Only _ | Strip Ctr+Z on load
| Backup when saving _ | Add Cul+Z on save

_ | No EOLN after last line

114 I Cancel | Apply | Help

Figure 1.55: Editor Modes Dialog

To set the default editor modes for a given type of files, click the File Type
button and either select the file type from the adjoining list or type a new one

(with a leading “.”) into the edit control. This mode is applied when you use the
File > Open Source, File > View, and File > Save As commands.
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1. To set the default editor modes for files created with the New File com-
mand, select New Files.

Or, click the Other Types button to set default modes for file types not in
the File Type list.

2. Check the mode boxes in the dialog to specify screen formatting, dis-
play/input, printing, and file save modes.

3. Click Apply Settings to save the settings for this file type.
4. Repeat steps 1 through 3 to set editor modes for other file types.

The modes you can set in the dialog are:
Screen Formatting
These settings affect tabs and text wrapping.
Tab Size Defines the width of a tab character.

Soft Tabs Inserts spaces instead of tabs when Soft Tabs is checked.

Wrap Lines at Place a checkmark to the left of this option and specify the
Column column at which you want lines to wrap. Clear the check-
mark if you do not want lines to wrap.

Display/Input Modes
These settings control how text is displayed in the window and any special
actions MPLAB Editor takes as you type.

Auto Indent Indents new lines to the same level as the preceding line.

Strip trailing Removes white space from the end of a line whenever you
spaces press Enter.
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Show line Displays line numbers in the window.
numbers

Overwrite Overwrites the characters under the cursor with the charac-
ters you type. Otherwise MPLAB Editor inserts characters at
the cursor.

Language Select from this list to associate a language (such as C or
Pascal) with the file type. This associates certain formatting
settings (like indenting) with files of the type you are setting
modes for.
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Printing

These settings affect how MPLAB Editor prints the text in the current win-
dow. These settings become the defaults for the File > Print command, but
can be overridden at the time of printing.

Page Prints each page headed with the file name, the page num-
Headers ber and the date.

Wrap Long Wraps lines that are too wide to fit the page to the next line
Lines during printing.

File Modes
These settings are the file modes that apply to file.

Read only Prevents users from saving files of this type.

Backup when Makes a backup copy of any existing file of the same name
saving when you write the file to disk.

Strip Ctrl+Z Automatically removes any Ctrl+Z character at the end of
on load the file when it is loaded.

Add Ctrl+Z on Automatically adds a Ctrl+Z character to the end of the file
save on disk when it saves the file.

No EOLN Writes an end-of-line terminator (CR-LF or LF) after the last
after last line character of the last line when it saves the file.
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1.9.5.5 Key Mappings

Select Options > Environment Setup and click the Key Mappings tab to
display and edit the MPLAB IDE key mappings. By mapping keyboard keys to
MPLAB IDE functions, you can perform common operations quickly. You may
use the existing key mappings or modify the key mappings to meet your
specific needs for your current project. MPLAB IDE uses the binary
initialization file, MPLAB.KEY, in the MPLAB IDE folder to record the key
mapping values that will be carried from one session to another. If you would
like to save all of the changes you have made in the Environment Settings
dialog so far, click Apply.

Environment Setup E3

General ] Project ] Files ] Default Editor Modes ] Key Mappings] Colors ]

=] then.. AR+ | Ctl+vlShift+[Fp2 =]

Define Prefix Keys... |

Key Combination

Prefix key: |Ctrl+B

Current Definition

Cul+B Shift+F12

Currently mapped to
[nothing]

New Definition

__| Show this mapping on menu Currently mapped from:

[ —— -] | ;
Add | Deleie | Resetan |
b
Key Map File
Save | SaveAs...l Load... |

Apply | Help

o]

Figure 1.56: Key Mappings Dialog

Cancel |

By default, no prefix keys are enabled. This means that only single keys are
available for mapping.

MPLAB IDE uses the binary initialization file, MPLAB.KEY, in the MPLAB IDE
folder to record the key mapping values that will be carried from one session
to another.

© 2001 Microchip Technology Inc.
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To create a key mapping:

1. To modify an existing key mapping, click Load to select the existing key
mapping file.

2. Define a prefix key (optional).

3. Click the checkboxes below the prefix key to assign the key or key
sequence (e.g., Shift + F2). The Current Definition box displays the cur-
rent function that is mapped to the key or key sequence.

4. Select the “Show this mapping on menu” checkbox if you want this key
mapping shortcut to appear to the right of the menu option on the
MPLAB IDE menu.

5. Select the function that you want this key or key sequence to perform
from the drop-down New Definition list. (Refer to “Appendix A: MPLAB
IDE Key Mapping Functions” for a list of available MPLAB IDE key map-
ping functions.)

6. Click Add to add this mapping to the key mapping file.
To change the function performed by an existing key mapping, select the
key or key sequence, select the desired function, then click Change.
To delete a key mapping, locate the key sequence and click Delete.

7. Click Save or Save As to save your key mapping.
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1.9.5.6 Colors

Select Options > Environment Setup and click the Colors tab to change the
colors assigned to displayed data. If you would like to save all of the changes
you have made in the Environment Settings dialog so far, click Apply.

General ] Project ] Files ] Default Editor Modes ] Key Mappings ]

Colors —>
. . Execution Point Foreground
Break Point Text
. Break + Trace Point Text
Break + Trigger Point Text
. . Break + Qualifier Point Text
Break + Trace + Trigger Point Text
. Break + Trace + Qualifier Point Text

Break + Trace + Trigger + Qualifier Point Text

Trace + Trigger Point Text
. Trace + Qualifier Point Text

Trace + Trigger + Qualifier Point Text

E Trigger + Qualifier Point Text

Qualifier Point Text

Register Window Column Titles
Register Window Data
Register Window Changed Data
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OK I Cancel | Apply Help

Figure 1.57: Colors Dialog

To change the color, select the text that you want to alter by clicking on it.
Next, select the new color.
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1.9.6 Programmer Options

1.9.6.1 Select Programmer

1. Select Options > Programmer Options > Select Programmer to select a
programmer from the list of available programmers.

2. Select the programmer from the drop-down list in the Select Program-
mer dialog.

3. Click OK.

Select Programmer E

Available Programmers:

|F"FII] MATE Device Programmer j|

114 I Cancel Help |

Figure 1.58: Select Programmer Dialog
1.9.6.2 Communications Port Setup

Select Options > Programmer Options > Communications Port Setup to
select the comm port for the programmer you are using.

1. Select Options > Programmer Options > Communications Port Setup
from the menu bar.
2. Select the comm port in the Communications Port Setup dialog.

3. Click OK.

Communications Port Setup Ed |

“ COM1 - COM 3
"~ COM 2 - COM 4

Cancel | Help

Figure 1.59: Communications Port Setup Dialog
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1.10 Tools Menu

1.10.1

DOS™ Command to Window (F11)

Tools > DOS Command to Window allows you to run a DOS program such as
a compiler, or an internal command such as DIR, and capture the output into
an edit window.

The command starts a dialog that prompts you for the command line to be
executed. This can be any DOS command, including built-in ones like DIR.

By clicking the Browse button, you can specify the working directory that the
command is to run in. This affects only the DOS command. MPLAB IDE will
still use its previous working directory.

When you start the dialog, MPLAB IDE sets the command string and the
proposed working directory name to the values you set the last time you used
it.

You may execute only one DOS command at a time. Until the command
completes, MPLAB IDE will reject attempts to start another.

Note: You cannot start a Windows application with this dialog.

Execute DOS Command and Capture Dutput Ed
Current directory: c:\progra™1implab

Command: |[::"tautue:|-:ecl j'
Working
Directory: | jl

| Becord Full Directory Pathname

Options:

Browse.__ | (1] 4

_ | Beep when done

_ | Minimize Editor

| Save changed file

V| Flmuee aulnud wivndow
| Show end of output Help

Cancel

Figure 1.60: Execute DOS Command Dialog

1. Set the various options you want to apply:

Beep when done causes the Editor to sound the standard system beep
when the DOS program finishes.

Minimize Editor causes the Editor to minimize into an icon before running
the DOS program.

© 2001 Microchip Technology Inc.
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Save changed files causes the Editor to see if any of the files you're editing
have changed and gives you the opportunity to save the changes before
running the DOS program. If you agree to save the changes, all the files
you've altered will be written to disk.

Reuse output window causes the Editor to place the DOS program’s out-
put into the window used the last time you used this dialog. If not, a new
output window will be created.

Show end of output causes the Editor to automatically scroll the window
showing the output to show you the end of it rather than the start.

2. Click OK to run the DOS program.

The command line, working directory path, and options are recorded and
become the default the next time you use this dialog.

1.10.2 Repeat DOS Command to Window (Ctrl+F11)

Tools > Repeat DOS Command to Window exactly repeats the last DOS
command you ran with Execute DOS Command To Window and shows the
command output in a window when it completes.

If you have not previously run a command, the Editor will act as if you
selected Execute DOS Command To Window and will open the Execute DOS
Command and Capture Output dialog.

1.10.3  Verify PICMASTER Emulator

If you are using a PICMASTER emulator with MPLAB IDE, select Tools >
Verify PICMASTER to verify that the PICMASTER emulator is operating
properly. Refer to the PICMASTER User’s Guide (DS51037) for detailed
information on verifying the PICMASTER emulator.

1.10.4  Verify MPLAB ICE

If you are using an MPLAB ICE 2000 with MPLAB IDE, you must exit MPLAB
IDE and run VERIFY.EXE, located in the main MPLAB IDE folder, to verify
that the MPLAB ICE 2000 is operating properly. Refer to the MPLAB ICE In-
Circuit Emulator User’s Guide (DS51159) for detailed information.
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1.11 Window Menu

All Window options are available in simulator mode or emulator mode.

In Editor Only mode, Absolute Listing and Show Symbol List are available. In
addition, the window positioning options and the Open Windows selections
are also available.

Available windows are:

Program Memory

Trace Memory

EEPROM Memory (device dependent)
Calibration Data (device dependent)
Absolute Listing

Map File

Stack

File Registers

Special Function Registers

Show Symbol List

Stopwatch

Project

Watch Window

Modify

The following commands affect the arrangement and appearance of windows
in MPLAB IDE.

¢ Tile Horizontal
Tile Vertical
Cascade
Iconize All
Arrange lcons
(Open Windows)
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1.11.1

Program Memory

Select Window > Program Memory to display program memory. The program

memory window can display locations in the range of program memory for the
currently selected processor. You can leave the Program Memory window
open at all times and move and resize the window.

The Program Memory window is only available in Emulator and Simulator

mode.

Program Memory Window [_ (O] x|
82 aes1 8128 movuf  Bx208 -
83 ge52 pem movlw Bx1

84 aas3: a1 movuf  Bx21

85 aec4 Baey movlw Bx7

86 aess @122 movwf Bx22

87 a856 EB5A Loop call Reduce

88 aesy 1722 decfsz Bx22

890 aasg CB56 goto Loop

98 aese Cceso goto Start

21 a85a 1021 Reduce swapf 8x21

92 aase 1Cc21 swapf 8x21,U

oh aesD 8528 subwf Bx28

95 AB5E EBGO call Double

96 d85F B6BO retlw 6x8

97 ag68 1D21 Double swapf 8221

98 aes1  1C21 swapf Bx21,u

09 aes2z 1021 swapf Bx21

188 a863 6rF21 addwf 8x21

101 decs BG6OO retlw 0Ox0

182 8865 FFFF call Bz1FFF

183 @866 FFFF call Bz1FFF

1084 @867 FFFF call 8z1FFF

185 a868 FFFF call B21FFF

186 8869 FFFF call Bx1FFF

187 as6én  FFFF call  Bxz1FFF

168 a86E FFFF call Bz1FFF

189 a86C FFFF call 8z1FFF -
4 | QW

Figure 1.61: Program Memory Window — Machine Code Display

1.11.1.1 System Button Options

Click the system button in the upper left corner of the Program Memory
screen to display the following options:

Toggle Line
Numbers

HEX Code

Toggles field for displaying line numbers and qualifier
points.

Displays program memory information as HEX data.
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Machine Code Displays disassembled HEX code with no symbolic
Display information.

Disassembly Displays disassembled HEX code with symbols.
Display

1.11.1.2 Program Memory Display Modes

The program memory can be displayed three ways. The desired format is
chosen through the system menu.

* HEX Code Display — This displays the program memory as HEX data.
This option is most useful when using a device programmer
(Figure 1.62).

¢ Machine Code Display — This displays the disassembled HEX code
with no symbolic information (Figure 1.61).

¢ Disassembly Display — This displays the disassembled HEX code with
symbols.

When this window is in Machine Code Display mode or Disassembly Display
mode, the instruction at the current program counter address will be
highlighted. Other features of MPLAB IDE can alter the display of the program
memory window.

Bl Program Memory Window _________________________________MEE
0000 [2805 3FFF 3FFF 3FFF 3FFF 1683 3007 009F  ........ fi
0008 1283 0186 01A8 O1AS 1683 0186 1283 3008 ........

0010 90A3 20A9 2079 2079 201C 0824 1903 2812  ..yy.$..
0018 00AY4 1283 207D 2812 01A4 ©8AS 1DO3 2835 ..}....5
0020 1003 ODA3 1C03 2826 3010 POA3 0186 1683  ...&....
0028 300F 0086 1283 0823 0086 300F 0506 1903  ...H....
0030 2845 0186 0423 00A4 0OAS O1AG 2079 0186 E.#...y.
0038 1683 300F 0086 1283 0823 0086 0825 0606  ....H.%.
0040 1903 2845 0186 O1A4 01AS 0186 1683 0186 .E......
0048 1283 0828 0086 300F 0524 0OA® 1903 2867 .(..$..g
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0050 30FF 3EQ01 OCAOD 1C03 2851 OOAG BE24 390F ....0.%.
0058 00A6 30FF 3EO01 OCAG 1CO3 285A 0OAG 1003  ..... Z..
0060 ODA6 ODAG 0826 0720 2068 OOA4 DOAES OOOB & h.o..

0068 0782 3446 3442 3430 3441 3445 3439 3438 .FBBAE9S
0070 3437 3444 3436 3435 3434 3443 3433 3432 TDe54C32
0078 3431 0000 OBAOD 2879 OOO8 DOA1 2093 0821 1..y...1
0080 0088 1105 1485 0000 1585 OOOO 1185 GOO8 ........
0088 0OA1 2093 0821 0088 1105 1085 DOOO 1585 R R
0090 0OOO 1185 DDOE 0188 1683 30FF D088 1283 ........
0098 1085 1505 0000 1585 OOCOO DOOO 0808 1185 ........
00A0 OGAD 1BAG 2893 1105 1683 3000 0088 1283 ........
00A8 0008 1283 0185 0188 1683 3000 0088 3000 ........

00BO 0085 1283 0185 3038 0088 0000 1585 0000  ...8....
0OB8 1185 3000 OOAD 2079 2079 2079 2079 2079 . ..yyyyy <
| 4

Figure 1.62: Program Memory Window — HEX Code Display
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1.11.1.3 Program Memory Field Descriptions

MPLAB IDE displays data in the Program Memory window that it reads
directly from emulation memory. Program Memory fields contain the following
information:

Field One Address in HEX.
Field Two Opcode (or data) in HEX.

Field Three Program Label in symbolic format. You can increase the dis-
play width of labels by selecting Options > Environment
Setup and clicking the General tab.

Field Four Machine code, disassembled code, or source code.

Highlight Bar Current location of the program counter.

Program Memory locations display break, trace, and trigger out status at each
memory location as follows:

1.11.1.3.1. Selecting Points

Symbol | Point Type (RMB T%T;h?ﬂiﬁtslg Bution)
B Break Points RMB > Break Point(s)
T Trace Points RMB > Trace Point(s)
0] Trigger Output RMB > Trigger Point(s)
Q Pass Count Address | Set from Break or Trace Point Settings Dia-
log

Available options depend on the development tool in use.

MPLAB IDE uses a combination of color and notations in the Program
Memory window to show break, trace, and trigger points. If no points have
been set at a particular address, the text will display normally. If a point is set,
the color of the text will change and the width of the line number window will
increase to show the active points. Unset points are displayed as periods.

1.11.1.4 Creating a Temporary Real-Time Break Point

To set up a temporary real-time break point from the Program Memory
Window, double-click the left mouse button anywhere on a valid address line.
The processor runs in real time until one of the following occurs:

* The line containing the temporary break point is executed
* A break point is encountered
¢ You click on Halt
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1.11.2 Trace Memory

Select Window > Trace Memory to display the contents of the trace buffer.
This window can be left open at all times, moved around, and resized.

The trace memory window takes a “snapshot” of your program’s execution.
For emulators that have a trace buffer, this shows how your program runs at
full speed.

Some applications, such as motor control systems, cannot be halted. Some
bugs may appear only when the application is running; i.e., they don’t occur
when single-stepping through the code. The trace buffer gives you another
tool for testing such applications. Check your emulator user’s guide for more
information on the information collected in its hardware trace buffer.

In the simulator, the trace buffer is useful for collecting a long record of
program execution so you can analyze it later. The simulator will show slightly
different information than the emulator’s trace.

To use the simulator’s trace buffer, first you must select code to trace. If you
click and drag across the program memory window you can select
instructions to trace, then press the right mouse button. This will bring up a
shortcut menu where you can select “Trace Point(s).” Now reset and run the
code, then halt it after it runs for a few seconds. Select Window > Trace to see
the collected trace:

El Trace Memory Window N =1F3
1 0000 32804 reset goto start ; 4.00us 2 |wW:00 = m
2 0004 3009 start movlw  Ox9 ; 6.00us 3 |W:09
3 0005 00BC movaf  Oxc ; 8.00us 4 |DOCc:09 03:18 2
4 0006 OFBC loop inefsz Oxc ; 10.00us 5 |0c:0A 03:18 m
5 0007 26806 goto loop ; 14.00uws 7 |w:09 -
6 0006 OFBC loop incfsz OxC ; 16.00us 8 |0C:0B 03:18 m
7 0007 2806 goto loop ; 20.00us 10 |w:09 . :
g e - - . P SO D _I_I o
(1

Figure 1.63: Trace Memory Window

The simulator puts a time stamp on each line and also shows any registers
that were changed along with their values.

Field One Address in HEX.
Field Two Opcode (or data) in HEX.

Field Three Program Label in symbolic format. You can increase the dis-
play width of labels by selecting Options > Environment Setup
and clicking the General tab.

Field Four Machine code, disassembled code, or source code.

Field Five Emulator: Status on External Logic Probe Lines. The status
fields are shown on the extreme right-hand side of the window.
Simulator: Time stamp and changed register information.

To save the contents of the trace buffer to a file, select File > Export > Export
Trace Buffer.
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1.11.3

1.11.4

EEPROM Memory

Select Window > EEPROM Memory to display the EEPROM data memory
window for a microcontroller device that has EEPROM data memory. The
PIC16F84 is an example of a device that supports EEPROM memory.

The EEPROM window can be left open at all times, moved around, and
resized. This window is for information only and you cannot change values
from this window. To change the EEPROM values, select Window > Modify
and use the Modify dialog.

EEPROM Window =l E3

-——- 60 61 02 63 04 65 66 07 08 09 OA OB OC 6D OF OF |«
8080 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
@610 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
8020 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
8830 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

< | Ay

Figure 1.64: EEPROM Memory Window

The EEPROM window displays the data/opcode HEX information of the
particular processor being emulated. When an EEPROM register value
changes or the processor is halted, the data in the EEPROM window is
updated.

System Button Options
Click the system button in the upper left corner of the EEPROM Memory
screen to display the following options:
Toggle Line Numbers Toggles field for displaying line numbers.
HEX Display Displays program memory information as HEX data.

ASCII Display Displays the ASCII character at each memory loca-
tion.

Calibration Data

If the emulated device contains calibration memory, the calibration memory
can be viewed by selecting Window > Calibration Data. The appearance of
this window will depend on the emulated device.

The Calibration Data dialog is for use with the PIC12CXXX or PIC14000
device families. It displays the floating point data in the Emulator Probe for
alteration by the user.

Saved calibration data may be loaded into MPLAB IDE using File>Import.
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Calibration Constants E
‘ Dscillator Trim

Cancel | Help |

Figure 1.65: Calibration Constants Dialog — PIC12CXXX

OK Closes the dialog and modifies the calibration value as specified.

Cancel Closes the dialog and does not modify the values in the memory
area.

Calibration Data B

Kref
Kbg
Ythrm

Restore

Kk
< Lancel

Fosc

Twdt

1111
a4

Help

Figure 1.66: Calibration Data Dialog — PIC14000

Update Takes the information from calibration data dialog, converts it from
the IEEE 754 format to the Microchip version of IEEE 754, and
stores it in the memory area for use in the embedded code. Only
the first four numbers KReF, KBG, VTHRM, and KTcC are in floating
point format. The last two, Fosc and TwDT, are 8-bit, unsigned
numbers with values from 0 to 255.
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Restore Takes the original calibration data uploaded from the probe during
system Reset and resets the values in the memory area for use in
the embedded code.

Cancel Closes the dialog and does not modify the values in the memory
area.
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1.11.5

Absolute Listing

Select Window > Absolute Listing to display and single step through the list
(*.LST) file generated by the MPASM assembler or a compatible C compiler.

Use this function to display both C code and the assembly code that
corresponds to the C code. The Absolute Listing gives you a better idea how
the C compiler implemented your code. If you are not using C, an assembler

(e.g., MPASM) will generate a similar listing file.

The Absolute Listing Window shows the list file generated by the assembler
or compiler. The Absolute Listing displays source code with the generated

object code.

00678 B
aae71 ;
006872 ; HMain Program
00873 ;
a0e7y
aa58 00875 ORG H'58"
00876
aa58 00877 start
0850  36FF 00078 HOULW 255 ;  Initialize the variables to
1515 L% I i s 1515 A HOUWF  CountDown ; their starting values.
a@s2 3881 [ Ls1500 ) HOULW 1
15158 ST aaag1 HOUWF  Doubler
a@sy 38687 s 16150 HouLw 7
@55 @eaz 151 HOUWF  OuterLoop
0056 BOO8Y Loop b
0056  265A 00685 CALL Reduce ;  Perfornm the inner portion DFJ
8@57  @BAZ 1815011 DECFSZ OuterLoop,f ; the loop.
ges8 2854 18150 GOTO Loop
1510 E
Bes0  285@ BapR0 GOTO Start ;5  Repeat the whole thing.
Ls1510 )
Boege ;
5151 ] 88892 Reduce
8e85na BEA1 80893 SUAPF Doubler,f H Reduce CountDown by the
8858 BE21 8089y SUAPF Doubler,u 5 value of Doubler. Then
8e85C BEA1 88895 SUAPF Doubler,f ; call the doubling routine.
(515131 B s P 1 151501 SUBWF  CountDown,f
BO5E 20868 Bap97 GALL Double
BO5F 3488 Baa9g RETLW @
Bap99 =
A ol

Figure 1.67: Absolute Listing Window
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1.11.6  Map File

A map file shows the used and unused memory regions after linking. To view
the map file, select Window > Map File.

c:A\mchp\projects\17c756\ledstled756 map T[] 3
MPLINK v2.00.81, Linker B

Linker Map File - Created Mon Jan 3 10:54:02 2000 —

Section Info
Section Type Address Location Size(Bytes)

.cinit romdata 0x000028 program  0x08000e

.code_LEDTS56.0 code OxB0EER2F program OxB0001he
.code_DELAY.o code Ox00010e program Ox0BER22
_startup code OxBEE11F program Ox000008

.idata_LED756.0_1 romdata 0x080123 program  8x080000
.romdata_LEDTS56.0 romdata Ox000123 program Ox0000E0
.idata_DELAY.o_i romdata 0x080123 program  8x080000
.romdata_DELAY.o romdata Ox000123 program Ox0000E0

SFR_UNBANKED® udata Ox000000 data Ox000010
SFR_BANKED® udata Ox000010 data Ox000008
SFR_UNBANKED1 udata Ox000018 data Ox000002
.stack udata Ox000020 data Ox000020
.udata_LED756.0 udata Ox000040 data Ox000006
_tmpstore udata Ox000046 data Ox000003 -
Al H 4

Figure 1.68: Map File Window

To generate a map file for a linked project, select Project > Edit Project to
bring up the Edit Project dialog. Then select/highlight the main node [. hex] in
the Project Files section of the dialog. Click Node Properties to bring up the
Node Properties dialog. Select the Map file checkbox to turn on the creation of
the map file.
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For more information on map files, see the MPASM User’s Guide with
MPLINK and MPLIB (DS33014).
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1.11.7

Stack

Select Window > Stack to open a window displaying the contents of the stack.
The number of available levels depends on the processor type being
emulated. The Stack Window can be left open at all times, moved around,
and resized.

Stack Window =] 3
1 Return Address: =
2 007F  § call delay
3 0033 { call Flashlef tToRight )

Figure 1.69: Stack Window

Note: If Stack Overflow Break Enable is set (Options>Development
Mode>Break Options), MPLAB IDE will display stack overflow and
underflow warnings when they occur.

The contents of the stack may be displayed with (shown) or without line
numbers. The desired format is chosen through the system menu.

Note: The system menu is accessed by clicking the top left corner of the
program memory window.

1.11.7.1 Hardware Stack Levels

1.11.7.1.1. 12-Bit Core Hardware Stack — 2-Levels Deep

Devices with a 12-bit core, such as PIC12C5XX and PIC16C5X, have a
2-level deep hardware stack.

1.11.7.1.2. 14-Bit Core Hardware Stack — 8-Levels Deep

Devices with a 14-bit core, such as PIC14000 and PIC16CXXX, have an 8-
level deep hardware stack.

Note: |If you clear Disable Stack Overflow Warning (Options > Develop-
ment Mode, Break Options tab) and push the stack beyond its limit,
MPLAB IDE will display an underflow or overflow message.
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1.11.7.1.3. 16-Bit Core Hardware Stack — 16-Levels Deep

Devices with a 16-bit core, such as PIC17CXXX, have a 16-level deep
hardware stack.

Note: If you clear Disable Stack Overflow Warning (Options > Develop-
ment Mode, Break Options tab) and push the stack beyond its limit,
MPLAB IDE will display an underflow or overflow message.

1.11.7.1.4. 16-Bit Enhanced Hardware Stack — 31-Levels Deep

Devices with an enhanced 16-bit core, such as PIC18CXXX, have a 31-level
deep hardware stack.

Note: If you clear Disable Stack Overflow Warning (Options > Develop-
ment Mode, Break Options tab) and push the stack beyond its limit,
MPLAB IDE will display an underflow or overflow message.

1.11.7.2 Simulator Stack—12-Bit Core Devices

The MPLAB SIM simulator presents an accurate simulation of the hardware
stack on the PIC12C5XX and PIC16C5X devices and additionally provides
warning messages if an underflow or overflow condition occurs. When a
CALL instruction is encountered, or when an interrupt has occurred, the value
of the PC + 1 is pushed to the stack, and the stack is popped when a RETLW
instruction is executed. If more than two values are pushed to the stack before
it is popped, the value will be pushed to the stack, but a warning message will
be issued indicating a stack overflow condition. An error message will also be
generated if the user attempts to pop an empty stack. Popping an empty stack
will cause the last value popped to be put in the PC.

1.11.7.3 Simulator Stack — 14-Bit Core Devices

The MPLAB SIM simulator presents an accurate simulation of the hardware
stack on the PIC14000 and PIC16CXX devices, and additionally provides
warning messages if an underflow or overflow condition occurs. When a
CALL instruction is encountered, or when an interrupt has occurred, the value
of the PC + 1 is pushed to the stack, and the stack is popped when a RETLW,
RETURN, or RETFIE instruction is executed. If more than eight values are
pushed to the stack before it is popped, the value will be pushed to the stack,
but a warning message will be issued indicating a stack overflow condition.
An error message will also be generated if the user attempts to pop an empty
stack. Popping an empty stack will cause the stack pointer to point to the top
of a full stack, and will not generate an error message if another pop is
initiated.

© 2001 Microchip Technology Inc.
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1.11.7.4 Simulator Stack — 16-Bit Core Devices

The MPLAB SIM simulator presents an accurate simulation of the hardware
stack on the PIC17CXXX, and additionally provides warning messages if an
underflow or overflow condition occurs. When a CALL or LCALL instruction is
encountered or when an interrupt has occurred, the value of the PC + 1 is
pushed to the stack. The stack is popped when a RETLW, RETURN, or
RETFIE instruction is executed. If more than sixteen values are pushed to the
stack before it is popped, the value will be pushed to the stack, a warning
message will be issued indicating a stack overflow condition, and the
STAKAVL bit will be cleared until a RESET condition occurs.

1.11.7.5 Simulator Stack — Enhanced 16-Bit Core Devices

The MPLAB SIM simulator presents an accurate simulation of the hardware
stack on the PIC18CXXX, and additionally provides warning messages if an
underflow or overflow condition occurs. When a CALL or LCALL instruction is
encountered or when an interrupt has occurred, the address of the next
instruction following the call is pushed to the stack. The stack is popped when
a RETLW, RETURN, or RETFIE instruction is executed. If more than 31
values are pushed to the stack before it is popped, the value will be pushed to
the stack, a warning message will be issued indicating a stack overflow
condition, and the STAKAVL bit will be cleared until a RESET condition
occurs.
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1.11.8  File Registers

Select Window > File Registers to display a window of all the File Registers of
the particular processor being emulated. When a file register value changes,
or the processor is interrogated, the data in the File Register window is
updated. The File Register window can be left open at all times, moved
around, and resized.

File Register Window
folo]e]e] FEX DEC BINARY CHAR SYMBOL NAME ii
0ee1 FF 255 11111111 . TRHT
0RE2 00 o] [slc]c]c]elelole] . I2C_READ
0EE3 1B 27 eee11011 . STATUS
oEeY 7B 123 01111011 { CCP1Y
0EES 10 16 00E10000 . TOCS
QEEE 00 o] [slc]c]c]elelole] . RP1
0eOT FE 254 11111110 . PSPIE
0eEE 81 129 10000001 . DAT
0EEY9 00 o] [slc]c]c]elelole] . PORTE
0REA 00 o] [slc]c]c]elelole] . PCLATH
QREB 00 o] [slc]c]c]elelole] . INTCON
0EEC 00 o] [slc]c]c]elelole] . PIR1
0EED 00 o] [slc]c]c]elelole] . PIR2
QEEE 00 o] [slc]c]c]elelole] . THRI1L
QROF 00 o] [slc]c]c]elelole] . TMR1H
010 00 o] [slc]c]c]elelole] . T1CON
011 00 o] [slc]c]c]elelole] . TMR2
012 00 o] [slc]c]c]elelole] . T2CON =
2 a7

Figure 1.70: File Registers Window — Symbolic Display
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File register contents can also be modified through this window. To change a
range of registers (i.e., to fill them with a constant value), click the left mouse
button and drag over the values you want to change. To change one register,
simply place the cursor over the register you want to change. Then click the
right mouse button to display the Fill Register pop-up menu. Select Fill
Register to display the Modify dialog (Figure 1.80) with the address range
already entered.
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1.11.8.1 File Registers Window Display Modes

File registers can be displayed three ways. The desired format is chosen
through the system menu.

* HEX Display — This displays the file registers as HEX data
(Figure 1.71).

* Symbolic Display — This displays each file register symbolically with
corresponding data in HEX, decimal, binary and character formats
(Figure 1.70).

* ASCII Display — This displays the file registers as ASCII data.

Note 1: The system menu is accessed by clicking the top left corner of
the File Register window.

2: If Freeze Peripherals On Halt is selected in the Break Options
tab under Options > Development Mode, the I/O port bits in the
SFR or the watch windows will not update when single step-
ping. The pin will be modified, but the read request to retrieve
the new value is blocked by the freeze and cannot be updated
until the next step or run command.

File Register Window
=== b@ 01 02 03 04 05 06 O7 08 09 A OB OC OD OE OF :ﬂ
0EEO C1 FF 00 1B 7B 10 00 FE 81 00 00 00 00 00 00 00
010 00 0O 00 FF 00 EF BF 00 00 00 00 FT TF 00 00 00
0R20 53 04 FB 80 FF 04 FF 91 FB 80 BB 30 DD 20 FF 02
OR300 FF 80 F5 A8 BE 00 F7T F1 EF 40 F8 00 C2 79 FF 00
0040 EF B2 F9 80 GB 00 97 00 9F 84 EF 92 EF 10 TF 00
0ES0 EB 40 D6 09 FB 4C TF 20 CD 20 BF 18 FA 60 TF A8
0E6E0 3C 02 ED 51 FF 23 FD 91 FF 00 EF 06 FA 12 TF 20
0OTO 6B 80 ED A4 FB 00 FF 63 DB 2B EE C1 FF 80 EF 40
0P80 00 FF 00 1B 7B 3F FF FF FF 07 00 00 00 00 00 --
PE9Q -- -- FF 00 00 -- -- -- B2 QO -- -- -- -=- -- 00
OOAO 3D 0O EC 80 FF 40 FF 43 EF 42 BF 00 FF 30 FF @A
OEBO DF 20 9E 00 ET 90 FE 00 FF 10 FD C5 FE 02 FF 10
OECO 1F E8 3F 00 FB OC FF 20 FF 18 BF 8B FB 50 BT 10
QEDO 77 09 F7 10 BB 09 47 A9 BT 44 79 OE FD 50 FD 21
OREQ BE 00 FB 08 DF 00 FD 00 AF 40 FA 58 6D 10 EB 20
OOFQ FE 52 F7 82 FF 23 FE 90 FT7 60 3F 42 FB 10 BF 00

Figure 1.71: File Register Window — HEX Display
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1.11.8.2 System Button Options

Click the system button in the upper left corner of the File Register Memory
screen to display the following options:

Toggle Line Numbers Toggles field for displaying line numbers.
HEX Display Displays file registers information as HEX data.

Symbolic Display Displays data at each memory location in the follow-
ing formats: HEX, Decimal, Binary, ASCII Character,
Symbol, and Name.

ASCII Display Displays the ASCII character at each memory loca-
tion.
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1.11.9

Special Function Registers

Select Window > Special Function Registers to display the contents of the
Special Function Registers (SFR) for the processor being emulated. The
format provided by this window is more useful for viewing the SFRs than the
normal file register window, since each SFR name is included and several
number formats are presented. Whenever a break occurs, the contents of the
SFRs are updated.

This window can be left open at all times, moved around and resized. A
sample of this window is shown below.

SFRs may be displayed with (shown) or without line numbers. The desired
format is chosen through the system menu.

Note 1: The system menu is accessed by clicking the top left corner of
the program memory window.

2: If Freeze Peripherals On Halt is selected in the Break Options
tab under Options > Development Mode, the I/O port bits in the
SFR or the watch windows will not update when single step-
ping. The pin will be modified, but the read request to retrieve
the new value is blocked by the freeze and cannot be updated
until the next step or run command.

Special Function Register Window

1 SFR Name Hex Dec Binary Char ii
2 W 00 0 00000000 .
3 option FF 255 11111111
4 tmro FF 255 11111111
5 pcl 00 0 00000000
B status 1B 27 ©@ee11e11 .
T fsr TB 123 ©1111011 {
8 trisa 3F 63 00111111 ?
9 porta 10 16 00010000
10 trisb FF 255 11111111
11 portb 00 0 00000000
12 trisc FF 255 11111111
13 portc FE 254 11111110
14 trisd FF 255 11111111
15 portd 81 129 10000001
16 trise o7 T 0O0ee111
17 porte 00 0 00000000
18 pclath 00 0 00000000
19 intcon 00 0 00000000
20 piri 00 0 00000000 . -
I H oz

Figure 1.72: Special Function Registers
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Field One Name of SFR.

Field Two Data as a hexadecimal value.
Field Three Data as a decimal value.

Field Four Data as a binary number.

Field Five Data as ASCII characters.

To modify the contents of a particular SFR:

1. Double-click on a register in this window to invoke the Modify dialog box
with the symbol/address and data fields already filled in, or

2. Use the execute Window > Modify menu.

Note: The SFR names and addresses are different for every device. I
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1.11.10 Show Symbol List (Ctrl+F8)

Select Window > Show Symbol List to display all symbols known to MPLAB
IDE. Symbols include constants and labels. Show Symbol List is an
information only dialog box. The symbols displayed in this dialog box
represent the symbols imported from your source code after compiling or
assembling. These symbols are from the *.COD file in your project.

Note: A project must be open and built in order for you to display a sym-

bol list.
Symbol List

VYariable Address Label Address
__17C766 (0x0001) Double [0x0060)
CountDown [0x0020) Loop [0x005E)
Doubler [Dx0021) Reduce [Dx005a)
OuterLoop [Dx0022) Start [0x0050)
ScratchPadRam [0x0020)

ok ] [ new |

Figure 1.73: Show Symbol List

Variable, Address Displays variables from the File Register memory and
the address of each variable.

Label, Address Displays labels from program memory and the address
of each label.

Constants Constants defined in the source code can be used in

executing opcode and as operands for instructions in
Modify.
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1.11.11

Simulator Stopwatch

Select Window > Stopwatch to display the current value of the Cycle counter.
The system Stopwatch counts the number of clock cycles that the processor
executes. The counting occurs with real-time execution and with polled
execution. The timer triggers on every cycle of an instruction. The stopwatch
allows you to measure code execution time. It is not always accurate while
single stepping. The stopwatch calculates time based upon the clock
frequency of the PICmicro MCU device. To set the clock frequency, select
Options > Development Mode and click the Clock tab.

| Cycl 0
Zero pcles |
Time | 0.00 ns

Processor Frequency | 20.000000 MHz

Help |

Figure 1.74: Simulator Stopwatch Dialog Box

| Clear On Reset

Cycles Displays the number of cycles that the processor exe-
cutes.
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Time Displays the stopwatch time in seconds. Computed from
the number of cycles executed and from the processor
frequency.

Zero Click Zero to reset the cycle counter to zero. You can
reset the timer at any time when the processor is halted.

Example 1.1: You can use this timer for precise timing measurements.
If you need to measure the exact time a subroutine takes to execute,
then simply reset the timer before entering the subroutine and put a
break point at the end of the subroutine. The timer displays the total
number of cycles executed in the subroutine and also displays the
execution time.

Processor Displays the selected Processor Frequency. To change

Frequency the frequency, you must select Options > Development

Mode and click the Clock tab.

Note: The stopwatch is not available with MPLAB ICD or MPLAB ICE
2000. For MPLAB ICE 2000, refer to the MPLAB ICE Emulators
User’s Guide (DS51159) for an example of a “Time Between Events”
Complex Trigger.

© 2001 Microchip Technology Inc.
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1.11.12 Project Window

The Project Window is available only when a project is open. It displays the
list of files currently in the project. If the project has been compiled, the project
window displays a list of all included files in the project. Otherwise, the Project
Window only displays the main project file. Double-click on any file displayed
in the Project Window to open that file for editing.

Project Listing =
Path: C:A\TEMP\TUTORIALY

Project Name: TUTOR84.PJT

Target: TUTOR84 . HEX

Tool Suite: Microchip

Processor: PIC16F84

Development Mode: Simulator

Target Data

File List: TUTOR84 .ASH;
Option String: fet; [l /x=; /uB; fo+; /m; frhex;
Build Tool: MPASH
Node : TUTOR84.ASH
Dependency List:
P16F84. INC
I 4

Figure 1.75: Project Window

DS51025E-page 206 © 2001 Microchip Technology Inc.




MPLAB IDE Toolbar and Menu Options

1.11.13 Watch Window

MPLAB IDE allows the contents of file registers to be monitored through a
Watch window. Using either the MPLAB IDE menu or a system menu inside
the Watch window, you can add and remove symbols and change their
display properties. The contents of the Watch window may be displayed with
or without line numbers. To choose the desired format, select Toggle Line
Numbers on the system menu inside the Watch window.

1.11.13.1 New Watch Window

To create a Watch window, select Window > Watch Window > New Watch
Window. Both the Add Watch Symbol dialog (Figure 1.77) and the Watch_1
window (Figure 1.76) will open. Refer to Section 1.11.13.4 for information on
editing Watch windows.

8| watch_1 ISI=] E3
1 Address Symbol Ualue
2 1F ADCONO H'EO"
3 9F ADCON1 H'EO"
4 o6 ADIE H'EO°
5 06 ADIF H'EO’
6 00 ADON  H'C1’
I Jui|

Figure 1.76: Watch Window

1.11.13.2 Load Watch Window
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Select Window > Watch Window > Load Watch Window to load a Watch
window that you previously created and saved to disk. Select a Watch window
file to load and click OK, or double-click the desired file.

In the Load Watch dialog, select the Drive from the Drives pull down list at the
bottom right of the dialog. Double-click the folder in the Folders hierarchy at
the top right of the Load Watch dialog to specify the path on the selected
drive. In the list of files below the File Name box at the left of the Load Watch
dialog, select the Watch window file you wish to open. Click OK. Both the Add
Watch Symbol dialog and the Watch window will open.

Select Add Watch Symbol from the system menu to add symbols to the
Watch window. Refer to Section 1.11.13.4 for information on editing Watch
windows.
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1.11.13.3 Add Watch Window Symbols

You can add symbols to the active Watch window.

Add Watch Symbol =

Symbol:
lc1 | Add

cl Y
DC Delete

eeadr
EEADR - Close

eeconl
EECONM1 :
eecon? Propertiez
EECOM2 -
eedata Hel
EEDATA hd —ce

Figure 1.77: Add Watch Symbol Dialog

Select Window > Watch Window > Add to Active Watch. Select symbols (see
Section 1.11.13.7) to add to the open Watch window by clicking on them in the
Add Watch Symbol list box. Or, you can enter the address of the symbol you
want to watch (e.g., 0x40). Click Add to add them to the Watch window.

To change how a symbol is displayed in the Watch window, select that symbol
and click Properties to open the Properties dialog (see Section 1.11.13.5).

Click Close when you have finished adding symbols. The Watch window will
display the current value of the variables you selected.
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1.11.13.4 Edit Watch Window Symbols

You can use either the MPLAB IDE menu or the system menu inside the
Watch window to change the display properties of symbols that are already in
the Watch window, or delete the symbols from the Watch window.

After creating or opening a Watch window, select Window > Watch Window >
Edit Active Watch from the MPLAB IDE menu to display the Edit Watch
Symbol dialog. Or, select Edit Watch from the system menu inside the Watch
window. The dialog lists all symbols you have added in the Watch window.

Edit Watch Symbol |
Symbol:
|-E|l:|IES| |
::nilc:_un1 = Delete
alusta
Close
Properties
Help

Figure 1.78: Edit Watch Symbol Dialog

In the Symbol list of the Edit Watch Symbol dialog, scroll to the symbol of the
variable you wish to change and highlight it. Click Properties.

To delete a symbol from the Watch window in the Edit Watch Symbol dialog,
scroll to the symbol of the variable you wish to delete and click Delete. Or,
simply place the cursor on the symbol in the Watch window and select Delete
> Watch from the system menu inside the Watch window.
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Once you are through editing or deleting watch symbols, click Close to close
the Edit Watch dialog and return to the Watch window.
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1.11.13.5 Changing Watch Symbol Properties

The Properties dialog allows you to select the format in which the symbols will
be displayed in the Watch window. You may display the Properties dialog box
by clicking Properties from the Add Watch Symbol and Edit Watch Symbol

dialogs.

Properties

Format

|

“ Hexadecimal
> Binary
B MOk Flost

= Decimal
= ASCIH
T HEE fload

Size

< B-bit
= 32-hit

= 16-bit
- bit

 24-bit

Byte Order

Diszplay bitz

Bl o T Lowe bk

@ b
b

S bk
G

PRTH:
PR

S obin
GonEeg

Cancel | Help |

Format

Size

Byte Order

Display Bits

OK

Cancel

Figure 1.79: Properties Dialog

Determines what type of number to display:
Hexadecimal, Binary, Mchip Float, Decimal, ASCII, or
IEEE Float. Mchip Float and IEEE Float are available
only for 24- and 32-bit size selections.

Determines how many bits will be included in the display
of the number.

Determines the display order of each byte. Available for
16-, 24-, and 32-bit numbers.

To display a specific bit, select Bit in the Size area, then
select the bit to be displayed here.

Click OK to accept the changes and return to the Edit
Watch Symbol dialog.

Click Cancel to return to the Edit Watch Symbol dialog
without accepting any changes.
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1.11.13.6 Save Watch Window

Select Window > Watch Window > Save Watch Window to save the Watch

window that you are active in.

In the Save Watch dialog, select the Drive from the Drives pull-down list at the
bottom right of the dialog. Double-click the folder in the Folders hierarchy at
the top right of the Save Watch dialog to specify the path on the selected
drive. In the File Name box at the top left of the Save Watch dialog, replace
the “*” with the name you want to give your Watch window. Click OK to save
the Watch window to disk.

1.11.13.7 Watch Window Symbols Defined

Watch window symbols are represented differently depending on their

application.
Symbol Example Definition
lower case portb Always available; internal to MPLAB IDE

upper case PORTB

Loaded from header file

Note:

The variable W represents an address of ‘0’, where as the variable

w represents the W register value.

© 2001 Microchip Technology Inc.
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1.11.14 Modify

Select Window > Modify to display and/or modify the contents of Data
Memory, Program Memory, the Stack, or EEPROM memory. You can use this
feature to write input pin states.

Modify allows you to Read/Write to a specific address, Read/Write while
incrementing to the next address, or fill an address block. MPLAB IDE allows
you to leave the Modify window open at all times and move it around.

“rodty REE

Address: End Address:
| =li|l |

Data/Opcode: Eill BHange |

Haédmljlex > Decimal | Auto Increment

Memory Area: Write I Read |

“ Data > Program c1 | Hel |
© Stack ~ EEPROM _=°%¢ | T°P

Figure 1.80: Modify Dialog Box

MPLAB IDE provides four ways to open the Modify dialog box:
¢ Select Window > Modify.

* Double-click on an item in the Special Functions Register window.
* Double-click an item in a Watch Window.

* Select an address or range in the File Register Window and click the
right mouse button to display a popup menu which contains the Fill
Register(s) option. Select Fill Register(s) from the popup menu to dis-
play the Modify dialog box.

Address Select a label from the drop-down list or enter the address
at which data is to be read or modified. You can enter a
numeric address or a symbol (label).

Note: Numeric constants must begin with a numeric digit. Therefore, HEX
values may need to be preceded by “0”; e.g. "OFF" instead of "FF."

Data/Opcode Click Read to display data value/opcode at a selected
address and memory area. Click Write to write data
value/Opcode to the selected address and memory area.

Radix HEX or Decimal
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Memory Area Select the Memory Area that you want to modify:
Data Memory:RAM Memory
Program Memory:ROM Memory in the emulator
Stack:Stack Memory on the Device
EEPROM:EE Data Memory

End Address The ending address for Fill Range.

Fill Range Fills the range defined by the two addresses with the value
entered in Data/Opcode.

Read Range Reads the memory range defined by the two addresses.
This is used to read off-chip memory when using devices
that support extended memory, such as the PIC17CXXX.

Auto Select Auto Increment to increment to the next address after
Increment each Read/Write.

Note: Auto increment increments to the next address, displays the next
address, and reads the contents at the address. If you are using
Auto Increment to read a range, enter the address of the memory,
area minus one because the first read will increment the address.

Write Enter new data in the Data/Opcode field, and click Write to
modify the data at the specified address. (You can enter
data in symbolic format.) When data is modified, all the
appropriate windows are updated with the new information.

Read Click Read to read the data at a specified address.

Close Click Close to exit the Modify dialog.
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Caution: The Program Counter should not be changed through the Modify
dialog. Instead, use the Change Program Counter dialog.

1.11.15 Tile Horizontal

The Window > Tile Horizontal command sizes open windows in a horizontal
format making each window as wide as possible to allow you to see as much
of each line in as many windows as possible. The command arranges all open
windows in a tile pattern, placing the windows above one another. Excess
windows are tiled in a horizontal pattern in the lower part of the screen.

Windows containing the output from commands run by the Tools > DOS
Command To Window command are arranged preferentially at the top of the
screen.

© 2001 Microchip Technology Inc. DS51025E-page 213



MPLAB® IDE User’s Guide

1.11.16

1.11.17

1.11.18

1.11.19

Tile Vertical

Window > Tile Vertical command sizes open windows vertically in columns to
allow you to see as many lines as possible in each window.

The Tile Vertical command arranges all open windows in a tile pattern,
placing them side by side so that each window is as deep as possible.

Cascade

The Window > Cascade command arranges all open windows in a cascade
pattern.

Iconize All

Window > Iconize All makes all windows into icons.

Arrange Icons

Window > Arrange Icons arranges all iconized windows so that their icons are
visible in rows at the bottom of the desktop. Open windows are not affected by
this command.

DS51025E-page 214

© 2001 Microchip Technology Inc.



MPLAB IDE Toolbar and Menu Options

1.11.20 Open Windows

Open windows are listed at the end of the Window commands.

Whenever you open a window, MPLAB IDE records the name in the list,
ordering it so that the windows you have used most recently always appear at
the top. Click on a window name to jump to that window.

More When the Windows list contains more files than can be dis-

Windows played on the menu, More Windows is automatically added
to the Windows menu. The command opens a dialog that
displays the entire list of windows. To open a window from
the list, either double-click the window name in the list, or
select the name and press the Open button.
The More Windows dialog box also provides additional
options. The settings of the additional options are remem-
bered and become the default for the next time you use this

dialog.
Select Window E3
c:\progra™1\mplabMtutor84. 1st -

EEPROM Window

Program Memory Window

Project Window

Special Function Register Window
Stack Window

Trace Memory Window

Watch_1

Watch_2?
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Windows showing. ..

+| Named Files
| Unnamed files

| Templates (1] 4 I Cancel Help

+| Command output

| Changed windows only

Figure 1.81: More Windows Dialog

Changed Displays only windows that have been changed since
Windows Only opening.

Named Files Lists all windows having an associated file name.

Unnamed Files Lists all windows that do not have an associated file
name.

Templates Lists all template windows.

Command Output Lists all windows containing command output obtained
by selecting Tools > DOS Command to Window.
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1.12 Help Menu

1.12.1

1.12.2

1.12.3

1.12.4

1.12.5

1.12.6

1.12.7

1.12.8

Release Notes (Shift+F1)

Help > Release Notes opens and displays the recent change history of
MPLAB IDE software. The Release Notes are contained in the file
README . LAB.

Tool Release Notes

If you are using additional tools, there may be an item on the Help menu on
release notes for those tools.

MPLAB IDE Help
Help > MPLAB IDE Help contains help on using MPLAB IDE.

Editor Help
Help > MPLAB Editor Help contains help on using the MPLAB Editor.

Error Help

Help > MPLAB Error Help contains help on selected MPLAB IDE error
messages.

MPASM Assembler Help

Help > MPASM Assembler Help opens an on-line version of the MPASM
User’s Guide with MPLINK and MPLIB (DS33014) with MPASM assembler-
specific information. Click on the green, underlined items to get more
information.

MPASM Assembler Help also contains a Quick Reference Guide that includes
assembly directives and device-specific instruction sets.

MPLINK Linker Help

Help > MPLINK Linker Help opens an on-line version of the MPASM User’s
Guide with MPLINK and MPLIB (DS33014) with MPLINK linker- and MPLIB
librarian-specific information. Click on the green, underlined items to get more
information.

Tool Help

If you are using additional tools, there may be an item on the Help menu on
help for those tools.
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1.12.9 About

Help > About displays:
e MPLAB IDE Version

¢ Microchip’s Address

* Processor Version

¢ Disassembler Version

¢ Information on other registered applications

About MPLAE IDE

MPLAB IDE for Windows/16
h.30.00

Microchip Technology, Inc.
2355 W. Chandler Blvd.
Chandler, A7 85224-6199

Proceszor version 7.3000
Dizaszzembler version 2.0000
Device File verzion 3.37.00

Registered Applications

MPLAB ICE Univerzal Emulator ¥2_30

=

Portions By:
Alan Phillips,
Lancaster Umiversity Computer Centre

Trademark Information

Copyright 2 Microchip Technology Inc. 1997-2001
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Figure 1.82: About Help Dialog
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NOTES:
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Chapter 2. MPLAB IDE Toolbar and Satus Bar Definitions

2.1 MPLAB IDE Toolbars

2.1.1 Edit Toolbar

The Edit toolbar contains buttons that are commonly used when editing
source code.

2]
1 2 3 4 5 6 7 8 9 10

" 12 13 4 15 16 17 18

Figure 2.1: Edit Toolbar

The default buttons are:

Change toolbar
File New
File Open
File Save
Cut
Copy
Paste
Print
Find
. Repeat Last Find
. Replace
. Repeat Last Replace
. Undo Edit
. Indent
. Unindent
. Goto Line
. Toggle Line Numbers
. Help Contents
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2.1.2

Debug Toolbar

The Debug toolbar contains buttons that are commonly used when running
and debugging code.

ielic)

el

T T e[ | Bl | P [

% ] [

IFLAE

3 6 7 8 9 1M1 12 13 14 15 16 17 18

213

Figure 2.2: DebugToolbar

The default buttons are:

Change toolbar

Run Program

Halt Program

Step Through Program
Step Over

Reset System
Change PC
Execute Opcode
New Watch Window
Modify Window
Break Point

Trace Point

Trigger

Clear All Breaks
Conditional Break
Halt Trace

System Reset

Help Release Notes

© N O AN~

9.

10.
11.
12.
13.
14.
15.
16.
17.
18.

Project Toolbar

The Project toolbar contains icons that are commonly used when running and
debugging code.

2]

El1PN L

K

5 &6 i & 9 11

Figure 2.3: Project Toolbar

The default buttons are:
1. Change toolbar
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New Project
Open Project
Close Project
Save Project
Edit Project
Make Project
Build All

. Build Node
0. Install Tools
1. Help

230N AN

2.1.4 User Defined Toolbar

The User Defined toolbar is intended to be customized to contain buttons that
meet the individual user’s needs.

EIEI E1 ESIEN B E EXieiicie =A™

3 1 M1z 13 14 15 16 17 18

Figure 2.4: User Defined Toolbar

It initially contains the following buttons:

Change Toolbar

Open Project

Save Project

Find

Cut

Copy

Paste

Save File

Run

Halt

. Step

. Step Over

. Reset

. Program Memory Window
. File Registers Window

. Special Function Registers Window
New Watch Window

. Make Project
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2.2

MPLAB IDE Status Bar

The Status Bar indicates such current information as cursor position,
development mode and device, and active toolbar.

Ian'IEIEI Cal 2 | 2042 | RO [No'wrap INS |PIC1ECE22 pe0x58  |wi0x00 ~zdcc  [BkOnEm [0 [Debug
Figure 2.5: Status Bar
. Typical - Result from Double
Title Entry Description Clicking
Line No., Column-Windows Ln 1 Col 1 |Displays current line number and column |Opens Goto Line Dialog
Open in file
2.00.00 MPLAB IDE Version Number No Action
Or, displays MPLAB IDE Version
Number when no windows are
open
Lines in File 72 Displays number of lines in current text |No Action
file
File Modified # Displays # Symbol if file has been No Action
changed since opening
Write/Read Only WR Displays Write/Read Only Status. Toggles between write and
WR = Editable File read only for files that you
RO = Read Only File have access to
Text Wrap No Wrap  |Displays current wrap mode and wrap | Toggles between wrap and
column if text wrap is on no wrap
Example 1: NoWrap No Wrap
Example 2: WR 72 Wrap at Column 72
Useful for text files. Use Options >
Current Editor Modes to change wrap
column.
Insert/Strikeover INS Toggles typing mode between insert and | Toggles between INS and
strikeover OVR
INS = Insert Characters
OVR = Type over characters
Current Processor PIC16C61 |Displays the currently selected No Action
processor
Current Program Counter pc:0x5f Displays the current program counter Opens Change Program
Counter dialog
Current w Register Value W:0x00 Displays current w register value No Action
Status Bits ovZdcc |UpperCase=Set (1) No Action
Lower Case = Reset (0)
Global Break Enable Bk On Displays current status of Global Break |Toggles Global Break
Enable Enable On and Off
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Title Téﬁ;fsl Description Resulé{:‘gkrrilngouble
Current Development Mode Sim Displays Current Development Mode. Displays Development
Examples: Mode Dialog
EO = Editor Only
Sim = Simulator —- MPLAB SIM
Si = Simulator — SIMICE
ICE = Emulator — MPLAB ICE 2000
Em = Emulator — PICMASTER emulator
Processor Frequency 4 MHz Displays current processor frequency Opens processor clock
dialog
Current Toolbar Edit Displays current toolbar No Action

© 2001 Microchip Technology Inc.
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Appendix A. MPLAB IDE Key Mapping Functions

A1

INTRODUCTION

This appendix lists the available MPLAB IDE key mapping functions.

A.2 MPLAB IDE KEY MAPPING FUNCTIONS

Key Map Function Definition 2:;?;:“:(:“‘;
CursorBottomOfWindow “Move Cursor to Bottom of Window” Ctrl+PgDn
CursorBottomOfWindowSelect “Move Cursor to Bottom of Window Selecting” Ctrl+Shift+PgDn
CursorDown “Move Cursor Down” Down
CursorDownSelect “Move Cursor Down Selecting” Shift+Down
CursorEndOfFile “Goto End of File” Ctrl+End
CursorEndOfFileSelect “Goto End of File Selecting” Ctrl+Shift+End
CursorEndOfLine “Move Cursor to End of Line” End
CursorEndOfLineSelect “Move Cursor to End of Line Selecting” Shift+End
CursorLeft “Move Cursor Left” Left
CursorLeftSelect “Move Cursor Left Selecting” Shift+Left
CursorLeftWord “Move Cursor Left by Word” Ctrl+Left
CursorLeftWordSelect “Move Cursor Left by Word Selecting” Ctrl+Shift+Left
CursorPageDown “Page Down” PgDn
CursorPageDownSelect “Page Down Selecting” Shift+PgDn
CursorPageUp “Page Up” PgUp
CursorPageUpSelect “Page Up Selecting” Shift+PgUp
CursorRight “Cursor Right” Right
CursorRightSelect “Cursor Right Selecting” Shift+Right
CursorRightWord “Cursor Right by Word” Ctrl+Right
CursorRightWordSelect “Cursor Right by Word Selecting” Ctrl+Shift+Right
CursorStartOfFile “Cursor Start of File” Ctrl+Home
CursorStartOfFileSelect “Cursor Start of File Selecting” Ctrl+Shift+Home
CursorStartOfLine “Cursor Start of Line” Home
CursorStartOfLineSelect “Cursor Start of Line Selecting” Shift+Home
CursorStartOfText “Cursor Start of Text” Alt Home Alt+Home
CursorStartOfTextSelect “Cursor Start of Text Selecting” Alt+Shift+Home
CursorTopOfWindow “Cursor Top of Window” Ctrl+PgUp
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Key Map Function Definition R:;?;:mienyt
CursorTopOfWindowSelect “Cursor Top of Window Selecting” Ctrl+Shift+PgUp
CursorUp “Cursor Up” Up
CursorUpSelect “Cursor Up Selecting” Shift+Up
DebugAnimate “Animate” Ctrl+F9
DebugBreak “Set Break Settings” F2
DebugCenterDebug “Center Debug Location”

DebugChangePC “Change Program Counter”

DebugClearAll “Clear All Qualifiers”

DebugClearMemory “Clear Program Memory” Ctrl+Shift+F2

DebugConditionalBreak “Conditional Break”

DebugExecuteOpcode “Execute an Opcode”

DebugHalt “Halt the Processor” F5

DebugHaliTrace “Halt the Trace” Shift+F5

DebugPerformanceAnalysis “Performance Analysis”

DebugPORReset “Power-On-Reset” Ctrl+Shift+F5

DebugStep “Step” F7

DebugReset “Reset Processor” F6

DebugRun “Run” F9

DebugStepOver “Step Over” F8

DebugStepTrace “Step The Trace Window” Shift+F7

DebugAsyncStim “Asynchronous Stimulus”

DebugClockStim “Clock Stimulus”

DebugPinStim “Pin Stimulus”

DebugRegStim “Register Stimulus”

DebugSystemReset “System Reset” Ctrl+Shift+F3

DebugTrace “Trace Settings”

DebugTrigger “Trigger Settings”

DebugUpdateRegisters “Update Registers”

EditCancelSelection keypad5

EditClearUndo “Forgets details of all stored undo actions”

EditCopy “Copies highlighted text to the clipboard” Ctrl+C
Ctrl+Ins

EditCut “Cuts highlighted text to the clipboard” Ctrl+X
Shift+Del

DS51025E-page 226

© 2001 Microchip Technology Inc.




MPLAB IDE Key Mapping Functions

Key Map Function Definition Ezg?gul:theenyt
EditDeleteBackwards “Delete Character Backwards” Backspace
Ctrl+H
EditDeleteForwards “Delete Forwards” Del
EditDeleteLine “Deletes the entire line containing the cursor” Ctrl+Shift+K
EditDeleteSelection “Delete Selection”
EditDeleteToEndOfLine “Deletes from the cursor to end of line” Ctri+K
EditFind “Searches for a text string” F3
EditGotoLine “Moves the cursor to a specific line” Ctrl+G
EditinsertHardTab “Insert Hard Tab”
EditinsertSoftTab “Insert Soft Tab”
EditinsertTab “Insert Tab” Tab
Ctrl+l
EditMarkUnchanged “Mark File As Unchanged”
EditNewLine “Insert New Line” Enter
Ctrl+M
EditPaste “Pastes the clipboard at the cursor position” Ctrl+V
Shift+Ins
EditRepeatLastFind “Repeats the last search action exactly” Shift+F3
EditRepeatLastReplace “Repeats the last replace action exactly” Shift+F4
EditReplace “Replaces a text string” F4
EditSelectAll “Highlights all the text in the current window”
EditSelectLine “Select Line”
EditSelectWord “Highlights the word containing the cursor”
EditShowCursor “Scrolls the window to bring the cursor into view”
EditShowNexiLine “Show Next Line”
EditShowNextPage “Show Next Page”
EditShowPreviousLine “Show Previous Line”
EditShowPreviousPage “Show Previous Page”
EditSplitLine “Split Line” Ctrl+Shift+O
EditTextIndent “Moves text right by one tab stop”
EditTextinsertASCIlICode “Inserts an arbitrary character code” Ctrl+Q
EditTextLowercaseSelection “Converts the highlighted text to lower case”
EditTextMatchBrace “Moves to a matching brace character” Ctrl+B
EditTextMatchBraceSelect “Moves to a matching brace character and high- | Shift+Ctrl+B
lights”

© 2001 Microchip Technology Inc.
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Key Map Function Definition R:;?;:mienyt

EditTextTransposeCharacters “Swaps the characters to left and right of the cur- | Ctrl+T
sor”

EditTextUnIndent “Moves text left by one tab stop”

EditTextUppercaseSelection “Converts the highlighted text to upper case”

EditTextWidenBraceSelect “Highlights the next largest braced area of text” Shift+Ctrl+W

EditUndo “Undoes the last edit action” Ctrl+z

ExecDosCommand “Runs a DOS command and captures output” F11

ExecRepeatDosCommand “Repeats the last DOS command-with-capture” Ctrl+F11

FileAbandon “Abandon File”

FileClose “Closes the file in the current window”

FileCloseAll “Closes all open files” Shift+F9

FileExit “Ends your MPLAB IDE session” Alt+F4

FilelmportDownloadToMemory “Download A Hex file to the Engine”

FilelmportDownloadToTarget “Download A Hex file to the Target”

FilelmportReadTarget “Copy Engine Memory to Target”

FileInsert “Inserts a file at the position of the cursor”

FileName “Changes the file name for the current window”

FileNew “Creates a new, empty edit window” Ctrl+N

FileOpen “Opens an existing file” Ctrl+O

FilePrint “Prints the current file” Ctrl+P

FilePrintSetup “Changes details of the current printer”

FileSave “Saves the current file to disk” Ctrl+S

FileSaveAll “Saves all open files to disk”

FileSaveAs “Saves the current file to disk”

FileSaveHex “Save Hex File”

FileSaveTrace “Save Trace File”

FileSimulatorStimulus “Load Simulator Stimulus File”

FileView “Opens an existing file in read-only mode”

FileWrite “Writes the current file to disk”

HelpAbout “Gives information about this MPLAB IDE version”

HelpBugs “MPLAB IDE Bug List”

HelpCommands “Gives help on MPLAB IDE commands”

HelpContents “Enters the MPLAB IDE help file at the Contents | F1
screen”

HelpEditor “Editor Help”
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Key Map Function Definition R:;?gu:mKeenyt
HelpMpasm “MPASM Assembler Help”
HelpMpc “MPLAB C Help”
HelpOnHelp “Gives help on using the help system”
HelpPICmicro “PICmicro Users Guide”
HelpReleaseNotes “Release Notes” Shift+F1
OptionsColors “Edit Color Options”
OptionsCommunicationsPort “Set Communications Address”
OptionsCurrent “Sets modes for the current window and file”
OptionsDefault “Sets default modes for files”
OptionsDevelopmentMode “Select Development Mode”
OptionsEnvironmentSetup “Setup Environment” Ctrl+F7
OptionsHardware “Select Hardware Options”
OptionsKeyMapping “Changes the mapping of keys to commands”
OptionsLoadSetup “Load Setup File”
OptionsMultiProcessor “Setup Multi-Processor”
OptionsPreferences “Sets MPLAB IDE configuration options”
OptionsResetModes “Sets the current file/window modes to default val-
ues”
OptionsSaveSetup “Save Setup File”
OptionsScreenFontANSI “Sets the screen font to the standard ANSI fixed-
pitch font”
OptionsScreenFontOEM “Sets the screen font to the standard OEM font”
OptionsScreenFontOther “Selects the screen font from all available fixed-
pitch fonts”
OptionsScreenFontSystem “Sets the screen font to the standard system font”
OptionsSimulatorlOSetup “Setup Simulator 1/0”
OptionsTogglelnsertMode “Toggle Insert Mode” Ins

OptionsToggleLineNumbers

“Toggle Line Numbers”

OptionsToggleStatusBar

“Hides or shows the status bar”

OptionsToolbarBottom

“Moves the toolbar to the bottom of the window”

OptionsToolbarFloat

“Makes the toolbar a floating window”

OptionsToolbarHide “Makes the toolbar invisible”
OptionsToolbarLeft “Moves the toolbar to the left of the window”
OptionsToolbarRight “Moves the toolbar to the right of the window”
OptionsToolbarShow “Makes the toolbar visible”
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Key Map Function Definition R:;?gu:mKeenyt
OptionsToolbarTop “Moves the toolbar to the top of the window”
ProjectBuildAll “Build Full Project” Ctrl+F10
ProjectBuildNode “Build Node” Alt+F10
ProjectCloseProject “Close Project”
ProjectCompileSingle “Compile Single File” Alt+F10
ProjectEditProject “Edit the Project Definition” Ctrl+F3
ProjectMakeProject “Make the Current Project” F10
ProjectMakeSetup “Setup the Project Make”
ProjectNewProject “Create a New Project”
ProjectOpenProject “Open a Project” Ctrl+F2
ProjectSaveProject “Save the Current Project”
SwapToolbar “Swap Toolbar”
SysSetMenuMode “Set Menu Mode”
TemplateDelete “Deletes a template from a template file”
TemplateEdit “Edits a template from a template file”
TemplateFileAttach “Loads a template file for use”
TemplateFileCreate “Creates an empty template file”
TemplateFileDetach “Releases an attached template file”
TemplateFileSave “Saves an altered template file to disk”
TemplateFindMark “Searches for a template marker in the current win-
dow”
Templatelnsert “Inserts a template at the position of the cursor”
TemplatelnsertMark “Inserts a template marker at the position of the
cursor”
TemplateNew “Creates a new window for a template”
TemplateStore “Saves a template into a template file”
TemplateStoreAs “Saves a template into a template file”
ToolsEmulatorConfiguration “Setup Emulator Configuration”
ToolsProgramHeader “Program Emulator Header”
ToolsProgramPod “Program Emulator Pod”
ToolsVerifyEmulator “Verify Emulator Components”
WindowAbsoluteL.isting “Absolute Listing”
WindowArrangelcons “Arranges all iconic windows neatly”
WindowCascade “Arranges windows in a cascade pattern”
WindowClose “Closes the current window” Ctrl+F4
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WindowDuplicate “Makes a duplicate of the current window”
WindowEeprom “EEPROM Memory Window”
WindowFileRegisters “File Register Memory”
Windowlconize “Iconize Window”
WindowlconizeAll “Makes all windows into icons”
WindowlLoadWatch “Load a Watch Window”
WindowMaximize “Maximize Window”
WindowModify “Modify Window”
WindowNewWatch “Create New Watch Window”
WindowNext “Activates the next non-iconic window”
WindowProgramMemory “Program Memory Window”
WindowRestore “Restore Window”
WindowSelect “Chooses a window to activate from a list” Ctrl+W
WindowSpecialFunctionRegisters | “Special Functions Register Window”
WindowStack “Stack Window”
WindowStopwatch “Stopwatch Window”
WindowSymbolList “Symbol List Window” Ctrl+F8

WindowTileHorizontal

“Tiles windows to maximize height”

WindowTileVertical

“Tiles windows to maximize width”

WindowTrace

“Trace Window”

WindowWiden

“Maximizes the width of the current window”
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Appendix B. MPLAB Editor Default Key Commands

B.1 INTRODUCTION

This appendix describes the default key commands specific to the MPLAB
Editor and lists the equivalent menu commands (if any).

The key commands perform the most common operations quickly. These key
commands can be modified to suit individual preferences. By default, no
prefix keys are enabled, so that only single keys are available for mapping.

For a table that lists the keys with the names of the functions used in the key
mapping dialog, see Appendix A: MPLAB IDE Key Mapping Functions.

B.2 HIGHLIGHTS

The categories for the default key commands are:
¢ Function Keys
* Movement Keys
¢ Control Keys
* Formatting and Editing Keys

B.3 FUNCTION KEYS

F1 Displays the appropriate help topic when pressed from a
window (e.g., File Registers Window).
F2 Executes the Debug > Break Settings command to open
the Break Settings dialog.
F3 Executes the Edit > Find command to find strings.
F4 Executes the Edit > Replace command to replace strings. m
F5 Executes the Debug > Halt command to halt debugging.
F6 Executes the Debug > Reset command to issue a reset to
the emulated or simulated processor. >
F7 Executes the Debug > Step command to execute a single g
opcode from program memory. g
F8 Executes the Debug > Step Over command to step over a o
i ion i 0
call instruction in program memory. P
F9 Executes the Debug > Run command to issue a run to the *
emulated/simulated processor.
F10 Executes the Project > Make Project command to initiate a
“make” for the current project.
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F11 Executes the Execute > DOS Command To Window com-
mand to run a DOS command and capture its output in a
window.

Shift+F3 Executes the Edit > Repeat Find command to repeat the
last find operation.

Shift+F4 Executes the Edit > Repeat Replace command to repeat
the last replace operation.

Shift+F5 Executes the Debug > Halt Trace command to halt the
execution trace for the simulated processor.

Shift+F9 Executes the File > Close All command to close all files
and windows.

Ctrl+F2 Executes the Project > Open Project command to open the
Open Project Dialog.

Ctrl+F3 Executes the Project > Edit Project command to open the
Edit Project Dialog.

Ctrl+F7 Executes the Options > Environment Setup to open the
Environment Setup dialog.

Ctrl+F8 Executes the Windows > Show Symbol List command to
open the Symbol List dialog.

Ctrl+F10 Executes the Project > Build All command to build all the
source files for the current project.

Alt+F4 Executes the File > Exit command to end your MPLAB
Editor session.

Alt+F10 Executes the Project > Build Node command to build the

current node.

Shift+Ctrl+F2

Executes the Debug > Clear Program Memory command to
clear all of program memory to an “erased” state.

Shift+Ctrl+F3

Executes the Debug > System Reset command to reset the
entire emulator system.

Shift+Ctrl+F5

Executes the Debug > POR Reset Emulation command to
open the POR Reset dialog.
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B.4 MOVEMENT KEYS

Adding <Shift> to cursor movement keys causes a text selection to be

extended.

Note that where the <Alt> key is combined with either an arrow key, or
<Home>, <End>, <PgDn>, <PgUp>, <Ins> or <Del>, you must use the keys in
the extended key areas, and not those in the numeric keypad.

Up Moves the cursor up by one line

Shift+Up Moves the cursor up by one line, extending the high-
lighting

Down Moves the cursor down by one line

Shift+Down Moves the cursor down by one line, extending the
selection

Left Moves the cursor left by one character

Shift+Left Moves the cursor left by one character, extending the
selection

Ctrl+Left Moves the cursor left by one word

Ctrl+Shift+Left

Moves the cursor left by one word, extending the
selection

Right Moves the cursor right by one character

Shift+Right Moves the cursor right by one character, extending
the selection

Ctrl+Right Moves the cursor right by one word

Ctrl+Shift+Right

Moves the cursor right by one word, extending the
selection

PgDn Moves the cursor down by one page

Shift+PgDn Moves the cursor down by one page, extending the
selection

Ctrl+PgDn Moves the cursor to the start of the last line in the win-
dow

Ctrl+Shift+PgDn Moves the cursor to the start of the last line in the win-
dow, extending the selection

PgUp Moves the cursor up by one page

Shift+PgUp Moves the cursor up by one page, extending the
selection

Ctrl+PgUp Moves the cursor to the start of the first line of the
window

Ctrl+Shift+PgUp Moves the cursor to the start of the first line of the
window, extending the selection

Home Moves the cursor to the start of the line

Shift+Home Moves the cursor to the start of the line, extending the

selection
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Ctrl+Home Moves the cursor to the start of the file

Ctrl+Shift+Home Moves the cursor to the start of the file, extending the
selection

Alt+Home Moves the cursor to the first non-white-space charac-

ter in the current line

Alt+Shift+Home

Moves the cursor to the first non-white-space charac-
ter in the current line, extending the selection

End Moves the cursor to the end of the line

Shift+End Moves the cursor to the end of the line, extending the
selection

Ctrl+End Moves the cursor to the end of the file

Ctrl+Shift+End Moves the cursor to the end of the file, extending the

selection
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B.5 CONTROL KEYS

Ctrl+Shift+B

Moves the cursor to the brace character matching the
brace the cursor is currently on, and highlights all the
text between and including the brace characters

Ctrl+C Executes the Edit > Copy command to copy selected
text to the clipboard

Ctrl+G Executes the Edit > Goto Line command to move the
cursor to a specific line

Ctrl+H Deletes the character to the left of the cursor

Ctri+l Inserts a TAB character, or the required number of
spaces to bring the cursor to the next TAB stop,
depending on whether the current window’s Window
Mode is set for hard or soft tabs.

Ctrl+K Executes the Edit > Delete To End Of Line command

to delete everything from the cursor position to the
end of the line

Ctrl+Shift+K

Executes the Edit > Delete Line command to delete
the entire line that the cursor is in

Ctrl+N Executes the File > New command to create a new,
empty edit window

Ctrl+O Executes the File > Open command to open an exist-
ing file

Ctrl+Shift+O Splits the current line at the position of the cursor,
leaving the cursor unmoved

Ctrl+P Executes the File > Print command to print the file
showing in the current window

Ctrl+Q Executes the Edit > Text Insert ASCII Code com-
mand to insert a character specified by its ASCII
code number

Ctrl+S Executes the File > Save command to save the cur-
rent file to disk

Ctrl+T Executes the Edit > Text Transpose Characters com-
mand to transpose the character under the cursor
with the one to its left

Ctrl+V Executes the Edit > Paste command to paste data
from the clipboard into the current window

Ctrl+W Executes the Window > Select command to let you

choose between many open windows

Ctrl+Shift+W

With the cursor between braces, this command high-
lights the closest (inner-most) pair of braces and all
the text between them

Ctrl+X Executes the Edit > Cutcommand to cut selected text
to the clipboard
Ctrl+Z Executes the Edit > Undo command to undo the last

edit action

© 2001 Microchip Technology Inc.

DS51025E-page 237

saoipuaddy E




MPLAB® IDE User’s Guide

B.6 FORMATTING AND EDITING KEYS

Enter Inserts a new line

BackSpace Deletes the character to the left of the cursor

Del Deletes the character to the right of the cursor

Shift+Del Executes the Edit > Cut command to cut selected text
to the clipboard

Ins Toggles the current window between Insert and Over-
write modes

Shift+ins Executes the Edit > Paste command to paste data
from the clipboard into the current window

Ctrl+Ins Executes the Edit > Copy command to copy selected
text to the clipboard

Tab Inserts a tab character, or the required number of

spaces to bring the cursor to the next tab stop,
depending on whether the current window’s Window
Mode is set for hard or soft tabs.
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Appendix C. File ExtensionsUsed by MPLAB IDE

The default extensions of files used by the MPLAB IDE are listed below:

* ASM  Assembly language source file

*.C C source file

* CFG  Configuration/setup files

* CSV  Trace save files (MPLAB ICE 2000 only)

*COD  Contains symbolic information and object code
* DAT  Simulator data file

* ERR  Error file generated by assembler/compiler

# H C include file

* HEX  PICmicro machine code in hex format

* HLP Help file

* INC Assembly language include file

# INI MPLAB IDE and language tool configuration file
* KEY ~ MPLAB IDE key mappings

* LKR MPLINK linker script

*LST  Absolute listing file generated by assembler/compiler
* MTC  Language tool configuration file

* PJT Contains most of the information related to a project
* REG  Stimulus register file

* STI Stimulus pin file

*TB Conditional break trace file

«*TBR  Toolbar file

* TPL Template file

*TRC  Trace save files

* TXT  Trace save file other than MPLAB ICE 2000
*WAT  Watch window file
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Glossary

Introduction

To provide a common frame of reference, this glossary defines the terms for
several Microchip tools.

Highlights

This glossary contains terms and definitions for the following tools:

* MPLAB IDE, MPLAB SIM Simulator, MPLAB Editor

MPASM Assembler, MPLINK Linker, MPLIB Librarian
MPLAB CXX C Compilers
MPLAB ICE 2000 In-Circuit Emulator, PICMASTER Emulator
MPLAB ICD In-Circuit Debugger
PICSTART Plus, PRO MATE programmer

Terms

Absolute Section

A section with a fixed (absolute) address which can not be changed by the
linker.

Access RAM (PIC18CXXX Devices Only)

Special general purpose registers on PIC18CXXX devices that allow access
regardless of the setting of the bank select bit (BSR).

Alpha Character

Alpha characters are those characters, regardless of case, that are letters of
the alphabet: (a, b, ..., z, A, B, ..., 2).

Alphanumeric
Alphanumeric characters include alpha characters and numbers: (0,1, ..., 9).
Application

A set of software and hardware developed by the user, usually designed to be
a product controlled by a PICmicro microcontroller.

Assemble
What an assembler does. See assembler.
Assembler

A language tool that translates a user’s assembly source code (.asm) into
machine code. MPASM is Microchip’s assembiler.
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Assembly

A programming language that is once removed from machine language.
Machine languages consist entirely of numbers and are almost impossible for
humans to read and write. Assembly languages have the same structure and
set of commands as machine languages, but they enable a programmer to
use names (mnemonics) instead of numbers.

Assigned Section

A section which has been assigned to a target memory block in the linker
command file. The linker allocates an assigned section into its specified target
memory block.

Break Point — Hardware
An event whose execution will cause a halt.
Break Point — Software

An address where execution of the firmware will halt. Usually achieved by a
special break opcode.

Build
A function that recompiles all the source files for an application.
C

A high level programming language that may be used to generate code for
PICmicro MCUs, especially high-end device families.

Calibration Memory

A special function register or registers used to hold values for calibration of a
PICmicro microcontroller on-board RC oscillator.

COFF

Common Object File Format. An intermediate file format generated by the
MPLINK linker that contains machine code and debugging information.

Command Line Interface

Command line interface refers to executing a program on the DOS command
line with options. Executing MPASM assembler with any command line
options or just the file name will invoke the assembler. In the absence of any
command line options, a prompted input interface (shell) will be executed.
Compile

What a compiler does. See compiler.

Compiler

A language tool that translates a user’s C source code into machine code.
MPLAB C17 and MPLAB C18 are Microchip’s C compilers for PIC17CXXX
and PIC18CXXX devices, respectively.
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Configuration Bits

Unique bits programmed to set PICmicro microcontroller modes of operation.
A configuration bit may or may not be preprogrammed. These bits are set in
the Options > Development Mode dialog for simulators or emulators and in
the  CONFIG MPASM directive for programmers.

Control Directives

Control directives in the MPASM assembler permit sections of conditionally
assembled code.

Data Directives

Data directives are those that control the MPASM assembler’s allocation of
memory and provide a way to refer to data items symbolically; that is, by
meaningful names.

Data Memory

General purpose file registers (GPRs) from RAM on the PICmicro MCU
device being emulated. The File Register window displays data memory.

Directives

Directives provide control of the assembler’s operation by telling the MPASM
assembler how to treat mnemonics, define data, and format the listing file.
Directives make coding easier and provide custom output according to
specific needs.

Download

Download is the process of sending data from the PC host to another device,
such as an emulator, programmer or target board.

EEPROM

Electrically Erasable Programmable Read Only Memory. A special type of
PROM that can be erased electrically. Data is written or erased one byte at a
time. EEPROM retains its contents even when power is turned off.

Emulation

The process of executing software loaded into emulation memory as if the
firmware resided on the microcontroller device under development.

Emulation Memory

Program memory contained within the emulator.
Emulator

Hardware that performs emulation.

Emulator System

The MPLAB ICE 2000 emulator system includes the pod, processor module,
device adapter, cables, and MPLAB IDE software. The PICMASTER emulator
system includes the pod, device-specific probe, cables, and MPLAB IDE
software.
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Event

A description of a bus cycle which may include address, data, pass count,
external input, cycle type (fetch, R/W), and time stamp. Events are used to
describe triggers and break points.

Executable Code

See HEX Code.

Export

Send data out of the MPLAB IDE in a standardized format.
Expressions

Expressions are used in the operand field of the MPASM assembler’s source
line and may contain constants, symbols, or any combination of constants and
symbols separated by arithmetic operators. Each constant or symbol may be
preceded by a plus or minus to indicate a positive or negative expression.

Note: MPASM assembler expressions are evaluated in 32-bit integer
math. (Floating point is not currently supported.)

Extended Microcontroller Mode
(PIC17CXXX and PIC18CXXX Devices Only)

In extended microcontroller mode, on-chip program memory as well as
external memory is available. Execution automatically switches to external if
the program memory address is greater than the internal memory space of
the PIC17CXXX or PIC18CXXX device.

External Input Line (MPLAB ICE 2000 only)

An external input signal logic probe line (TRIGIN) for setting an event based
upon external signals.

External Linkage

A function or variable has external linkage if it can be accessed from outside
the module in which it is defined.

External RAM (PIC17CXXX and PIC18CXXX Devices Only)
Off-chip Read/Write memory.

External Symbol

A symbol for an identifier which has external linkage.

External Symbol Definition

A symbol for a function or variable defined in the current module.
External Symbol Reference

A symbol which references a function or variable defined outside the current
module.
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External Symbol Resolution

A process performed by the linker in which external symbol definitions from all
input modules are collected in an attempt to update all external symbol
references. Any external symbol references which do not have a
corresponding definition cause a linker error to be reported.

File Registers

On-chip general purpose and special function registers.

Flash

A type of EEPROM where data is written or erased in blocks instead of bytes.
FNOP

Forced No Operation. A forced NOP cycle is the second cycle of a two-cycle
instruction. Since the PICmicro MCU architecture is pipelined, it prefetches
the next instruction in the physical address space while it is executing the
current instruction. However, if the current instruction changes the program
counter, this prefetched instruction is explicitly ignored, causing a forced NOP
cycle.

GPR
See Data Memory.
Halt

A function that stops the emulator. Executing Halt is the same as stopping at a
break point. The program counter stops, and the user can inspect and change
register values, and single step through code.

HEX Code

Executable instructions assembled or compiled from source code into
standard hexadecimal format code. Also called executable or machine code.
HEX code is contained in a HEX file.

HEX File

An ASCII file containing hexadecimal addresses and values (HEX code)
suitable for programming a device. This format is readable by a device
programmer.

High Level Language

A language for writing programs that is of a higher level of abstraction from
the processor than assembler code. High level languages (such as C) employ
a compiler to translate statements into machine instructions that the target
processor can execute.

ICD

In-Circuit Debugger. MPLAB ICD is Microchip’s in-circuit debugger for
PIC16F87X devices. MPLAB ICD works with MPLAB IDE.
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ICE

In-Circuit Emulator. MPLAB ICE 2000 is Microchip’s in-circuit emulator that
works with MPLAB IDE.

IDE

Integrated Development Environment. An application that has multiple
functions for firmware development. The MPLAB IDE integrates a compiler,
an assembler, a project manager, an editor, a debugger, a simulator, and an
assortment of other tools within one Windows application. A user developing
an application can write code, compile, debug, and test an application without
leaving the MPLAB IDE desktop.

Identifier
A function or variable name.
Import

Bring data into the MPLAB Integrated Development Environment (IDE) from
an outside source, such as from a HEX file.

Initialized Data

Data which is defined with an initial value. In C, int myVar=5; defines a
variable which will reside in an initialized data section.

Internal Linkage

A function or variable has internal linkage if it can not be accessed from
outside the module in which it is defined.

Librarian

A language tool that creates and manipulates libraries. MPLIB is Microchip’s
librarian.

Library

A library is a collection of relocatable object modules. It is created by
assembling multiple source files to object files, and then using the librarian to
combine the object files into one library file. A library can be linked with object
modules and other libraries to create executable code.

Link
What a linker does. See Linker.
Linker

A language tool that combines object files and libraries to create executable
code. Linking is performed by Microchip’s linker, MPLINK.

Linker Script Files

Linker script files are the command files of MPLINK (.LKR). They define linker
options and describe available memory on the target platform.
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Listing Directives

Listing directives are those directives that control the MPASM assembler
listing file format. They allow the specification of titles, pagination and other
listing control.

Listing File

A listing file is an ASCII text file that shows the machine code generated for
each C source statement, assembly instruction, MPASM assembler directive,
or macro encountered in a source file.

Local Label

A local label is one that is defined inside a macro with the LOCAL directive.
These labels are particular to a given instance of a macro’s instantiation. In
other words, the symbols and labels that are declared as local are no longer
accessible after the ENDM macro is encountered.

Logic Probes

Up to 14 logic probes connected to the emulator. The logic probes provide
external trace inputs, trigger output signal, +5V, and a common ground.

Machine Code
Either object or executable code.
Macro

A collection of assembler instructions that are included in the assembly code
when the macro name is encountered in the source code. Macros must be
defined before they are used; forward references to macros are not allowed.

All statements following a MACRO directive and prior to an ENDM directive are
part of the macro definition. Labels used within the macro must be local to the
macro so the macro can be called repetitively.

Macro Directives

Directives that control the execution and data allocation within macro body
definitions.

Make Project

A command that rebuilds an application, re-compiling only those source files
that have changed since the last complete compilation.

MCU
Microcontroller Unit. An abbreviation for microcontroller. Also uC.
Memory Models

Versions of libraries and/or precompiled object files based on a device’s
memory (RAM/ROM) size and structure.

Microcontroller

A highly integrated chip that contains all the components comprising a
controller. Typically this includes a CPU, RAM, some form of ROM, 1/O ports,
and timers. Unlike a general-purpose computer, which also includes all of
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these components, a microcontroller is designed for a very specific task — to
control a particular system. As a result, the parts can be simplified and
reduced, which cuts down on production costs.

Microcontroller Mode (PIC17CXXX and PIC18CXXX Devices Only)

One of the possible program memory configurations of the PIC17CXXX and
PIC18CXXX families of microcontrollers. In microcontroller mode, only
internal execution is allowed. Thus, only the on-chip program memory is
available in microcontroller mode.

Microprocessor Mode (PIC17CXXX and PIC18CXXX Devices Only)

One of the possible program memory configurations of the PIC17CXXX and
PIC18CXXX families of microcontrollers. In microprocessor mode, the on-chip
program memory is not used. The entire program memory is mapped
externally.

Mnemonics

Instructions that are translated directly into machine code. Mnemonics are
used to perform arithmetic and logical operations on data residing in program
or data memory of a microcontroller. They can also move data in and out of
registers and memory as well as change the flow of program execution. Also
referred to as Opcodes.

MPASM Assembler

Microchip Technology’s relocatable macro assembler. The MPASM assembler
is a DOS or Windows-based PC application that provides a platform for
developing assembly language code for Microchip’s PICmicro microcontroller
families. Generically, the MPASM assembler will refer to the entire
development platform including the macro assembler and utility functions.

The MPASM assembler will translate source code into either object or
executable code. The object code created by the MPASM assembler may be
turned into executable code through the use of the MPLINK linker.

MPLAB CXX
Refers to MPLAB C17 and MPLAB C18 C compilers.
MPLAB ICD

Microchip’s in-circuit debugger for PIC16F87X devices. MPLAB ICD works
with MPLAB IDE. The MPLAB ICD system consists of a module, header,
demo board (optional), cables, and MPLAB Software.

MPLAB ICE 2000
Microchip’s in-circuit emulator that works with MPLAB IDE.
MPLAB IDE

The name of the main executable program that supports the IDE with an
Editor, Project Manager, and Emulator/Simulator Debugger. The MPLAB IDE
software resides on the PC host. The executable file name is MPLAB.EXE.
MPLAB.EXE calls many other files.
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MPLAB SIM Simulator
Microchip’s simulator that works with MPLAB IDE.
MPLIB Librarian

MPLIB is a librarian for use with COFF object modules (filename. o)
created using either MPASM v2.0, MPASMWIN v2.0, or MPLAB C v2.0 or
later.

MPLIB librarian will combine multiple object files into one library file. Then the
MPLIB librarian can be used to manipulate the object files within the created
library.

MPLINK Linker

MPLINK is a linker for the Microchip relocatable assembler, MPASM, and the
Microchip C compilers, MPLAB C17 or MPLAB C18. MPLINK linker also may
be used with the Microchip librarian, MPLIB. MPLINK linker is designed to be
used with MPLAB IDE, though it does not have to be.

MPLINK linker will combine object files and libraries to create a single
executable file.

MPSIM

The DOS version of Microchip’s simulator. MPLAB SIM simulator is the
newest simulator from Microchip.

MRU

Most Recently Used. Refers to files and windows available to be selected
from MPLAB IDE main pull down menus.

Nesting Depth

The maximum level to which macros can include other macros. Macros can
be nested to 16 levels deep.

Non Real-Time

Refers to the processor at a break point or executing single step instructions
or MPLAB IDE being run in simulator mode.

Node
MPLAB IDE project component.
NOP

No Operation. An instruction that has no effect when executed except to
advance the program counter.

Object Code

The intermediate code that is produced from the source code after it is
processed by an assembler or compiler. Relocatable code is code produced
by the MPASM assembler or MPLAB C17 and C18 C compilers that can be
run through the MPLINK linker to create executable code. Object code is
contained in an object file.
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Object File

A module which may contain relocatable code or data and references to
external code or data. Typically, multiple object modules are linked to form a
single executable output. Special directives are required in the source code
when generating an object file. The object file contains object code.

Object File Directives
Directives that are used only when creating an object file.
Off-Chip Memory (PIC17CXXX and PIC18CXXX Devices Only)

Off-chip memory refers to the memory selection option for the PIC17CXXX or
PIC18CXXX device where memory may reside on the target board, or where
all program memory may be supplied by the Emulator. The Memory tab
accessed from Options > Development Mode provides the Off-Chip Memory
selection dialog box.

Opcodes
Operational Codes. See Mnemonics.
Operators

Arithmetic symbols, like the plus sign ‘+’ and the minus sign *’, that are used
when forming well-defined expressions. Each operator has an assigned
precedence.

Pass Counter

A counter that decrements each time an event (such as the execution of an
instruction at a particular address) occurs. When the pass count value
reaches zero, the event is satisfied. You can assign the Pass Counter to
break and trace logic, and to any sequential event in the complex trigger
dialog.

PC

Personal Computer or Program Counter.

PC Host

Any IBM® or compatible Personal Computer running Windows 3.1x or
Windows 95/98, Windows NT, or Windows 2000. MPLAB IDE runs on 486 or
higher machines.

PICmicro MCUs

PICmicro microcontrollers (MCUs) refers to all Microchip microcontroller
families.

PICMASTER Emulator

The hardware unit that provides tools for emulating and debugging firmware
applications. This unit contains emulation memory, break point logic,
counters, timers, and a trace analyzer among some of its tools. MPLAB ICE
2000 is the newest emulator from Microchip.
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PICSTART Plus Programmer

A device programmer from Microchip. Programs 8, 14, 28, and 40 pin
PICmicro microcontrollers. Must be used with MPLAB Software.

Pod

The external emulator box that contains emulation memory, trace memory,
event and cycle timers, and trace/break point logic. Occasionally used as an
abbreviated name for the MPLAB ICE 2000 emulator.

Power-on-Reset Emulation

A software randomization process that writes random values in data RAM
areas to simulate uninitialized values in RAM upon initial power application.

Precedence

The concept that some elements of an expression are evaluated before
others; i.e., * and / before + and -. In MPASM assembler, operators of the
same precedence are evaluated from left to right. Use parentheses to alter
the order of evaluation.

Program Counter
A register that specifies the current execution address.
Program Memory

The memory area in a PICmicro microcontroller where instructions are stored.
Memory in the emulator or simulator containing the downloaded target
application firmware.

Programmer

A device used to program electrically programmable semiconductor devices
such as microcontrollers.

Project

A set of source files and instructions to build the object and executable code
for an application.

PRO MATE Programmer

A device programmer from Microchip. Programs all PICmicro microcontrollers
and most memory and Keeloq devices. Can be used with MPLAB IDE or
stand-alone.

Prototype System
A term referring to a user’s target application, or target board.
PWM Signals

Pulse Width Modulation Signals. Certain PICmicro MCU devices have a PWM
peripheral.

Qualifier

An address or an address range used by the Pass Counter or as an event
before another operation in a complex trigger.
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Radix

The number base, HEX, or decimal, used in specifying an address and for
entering data in the Window > Modify command.

RAM

Random Access Memory (Data Memory).

Raw Data
The binary representation of code or data associated with a section.
Real-Time

When released from the halt state in the emulator or MPLAB ICD mode, the
processor runs in real-time mode and behaves exactly as the normal chip
would behave. In real-time mode, the real-time trace buffer of MPLAB ICE
2000 is enabled and constantly captures all selected cycles, and all break
logic is enabled. In the emulator or MPLAB ICD, the processor executes in
real-time until a valid break point causes a halt, or until the user halts the
emulator.

In the simulator real-time simply means execution of the microcontroller
instructions as fast as they can be simulated by the host CPU.

Recursion

The concept that a function or macro, having been defined, can call itself.
Great care should be taken when writing recursive macros; it is easy to get
caught in an infinite loop where there will be no exit from the recursion.

Relocatable Section

A section whose address is not fixed (absolute). The linker assigns addresses
to relocatable sections through a process called relocation.

Relocation

A process performed by the linker in which absolute addresses are assigned
to relocatable sections and all identifier symbol definitions within the
relocatable sections are updated to their new addresses.

ROM
Read Only Memory (Program Memory).
Run

The command that releases the emulator from halt, allowing it to run the
application code and change or respond to I/O in real time.

Section

An portion of code or data which has a name, size, and address.

SFR

Special Function Registers of a PICmicro microcontroller.

Shared Section

A section which resides in a shared (non-banked) region of data RAM.
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Shell

The MPASM assembler shell is a prompted input interface to the macro
assembler. There are two MPASM assembler shells: one for the DOS version
and one for the Windows version.

Simulator

A software program that models the operation of the PICmicro
microprocessor.

Single Step

This command steps though code, one instruction at a time. After each
instruction, MPLAB IDE updates register windows, watch variables, and
status displays so you can analyze and debug instruction execution.

You can also single step C compiler source code, but instead of executing
single instructions, MPLAB IDE will execute all assembly level instructions
generated by the line of the high level C statement.

Skew

The information associated with the execution of an instruction appears on
the processor bus at different times. For example, the executed opcode
appears on the bus as a fetch during the execution of the previous instruction,
the source data address and value and the destination data address appear
when the opcode is actually executed, and the destination data value appears
when the next instruction is executed. The trace buffer captures the
information that is on the bus at one instance. Therefore, one trace buffer
entry will contain execution information for three instructions. The number of
captured cycles from one piece of information to another for a single
instruction execution is referred to as the skew.

Skid

When a hardware break point is used to halt the processor, one or more
additional instructions may be executed before the processor halts. The
number of extra instructions executed after the intended break point is
referred to as the skid.

Source Code — Assembly

Source code consists of PICmicro MCU instructions and MPASM assembler
directives and macros that will be translated into machine code by an
assembler.

Source Code-C

A program written in the high level language called “C” which will be
converted into PICmicro MCU machine code by a compiler. Machine code is
suitable for use by a PICmicro MCU or Microchip development system
product like MPLAB IDE.
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Source File — Assembly

The ASCII text file of PICmicro MCU instructions and MPASM assembler
directives and macros (source code) that will be translated into machine code
by an assembler. It is an ASCII file that can be created using any ASCII text
editor.

Source File-C

The ASCII text file containing C source code that will be translated into
machine code by a compiler. It is an ASCII file that can be created using any
ASCII text editor.

Special Function Registers

Registers that control 1/0 processor functions, 1/O status, timers, or other
modes or peripherals.

Stack — Hardware

An area in PICmicro MCU memory where function arguments, return values,
local variables, and return addresses are stored,; i.e., a “Push-Down” list of
calling routines. Each time a PICmicro MCU executes a CALL or responds to
an interrupt, the software pushes the return address to the stack. A return
command pops the address from the stack and puts it in the program counter.

The PIC18CXXX family also has a hardware stack to store register values for
“fast” interrupts.

Stack — Software

The compiler uses a software stack for storing local variables and for passing
arguments to and returning values from functions.

Static RAM or SRAM

Static Random Access Memory. Program memory you can Read/Write on the
target board that does not need refreshing frequently.

Status Bar

The Status Bar is located on the bottom of the MPLAB IDE window and
indicates such current information as cursor position, development mode and
device, and active toolbar.

Step Into

This command is the same as Single Step. Step Into (as opposed to Step
Over) follows a CALL instruction into a subroutine.

Step Over

Step Over allows you to debug code without stepping into subroutines. When
stepping over a CALL instruction, the next break point will be set at the
instruction after the CALL. If for some reason the subroutine gets into an
endless loop or does not return properly, the next break point will never be
reached.

The Step Over command is the same as Single Step except for its handling of
CALL instructions.
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Stimulus

Data generated to exercise the response of simulation to external signals.
Often the data is put into the form of a list of actions in a text file. Stimulus may
be asynchronous, synchronous (pin), clocked and register.

Stopwatch
A counter for measuring execution cycles.
Symbol

A symbol is a general purpose mechanism for describing the various pieces
which comprise a program. These pieces include function names, variable
names, section names, file names, struct/enum/union tag names, etc.

Symbols in MPLAB IDE refer mainly to variable names, function names and
assembly labels.

System Button

The system button is another name for the system window control. Clicking
on the system button pops up the system menu.

System Window Control

The system window control is located in the upper left corner of windows and
some dialogs. Clicking on this control usually pops up a menu that has the
items “Minimize,” “Maximize,” and “Close.” In some MPLAB IDE windows,
additional modes or functions can be found.

system window control

) watch_1 =]
estole plue
Maove 69
Size
Iinimize
I aimize
Close Ckrl+F4
Mest Ctl+FE

Toggle Line Mumbers

Addwatch... Ing
Delete Watch Del
Edit Watch...

Sawe Watch...

Figure G1: System Window Control Menu — Watch Window

Target

Refers to user hardware.

Target Application

Firmware residing on the target board.

Target Board

The circuitry and programmable device that makes up the target application.
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Target Processor

The microcontroller device on the target application board that is being
emulated.

Template

Lines of text that you build for inserting into your files at a later time. The
MPLAB Editor stores templates in template files.

Toolbar

A row or column of icons that you can click on to execute MPLAB IDE
functions.

Trace

An emulator or simulator function that logs program execution. The emulator
logs program execution into its trace buffer which is uploaded to MPLAB IDE’s
trace window.

Trace Memory

Trace memory contained within the emulator. Trace memory is sometimes
called the trace buffer.

Trigger Output

Trigger output refers to an emulator output signal that can be generated at
any address or address range, and is independent of the trace and break
point settings. Any number of trigger output points can be set.

Unassigned Section

A section which has not been assigned to a specific target memory block in
the linker command file. The linker must find a target memory block in which
to allocate an unassigned section.

Uninitialized Data

Data which is defined without an initial value. In C, int myVar; defines a
variable which will reside in an uninitialized data section.

Upload

The Upload function transfers data from a tool, such as an emulator or
programmer, to the host PC or from the target board to the emulator.

Warning

An alert that is provided to warn you of a situation that would cause physical
damage to a device, software file, or equipment.

WatchDog Timer (WDT)

A timer on a PICmicro microcontroller that resets the processor after a
selectable length of time. The WDT is enabled or disabled and set up using
configuration bits.

Watch Variable

A variable that you may monitor during a debugging session in a watch
window.
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Watch Window

Watch windows contain a list of watch variables that are updated at each
break point.
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